aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/emacs-wiki
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-03-12 03:33:27 +0800
committerpav <pav@FreeBSD.org>2005-03-12 03:33:27 +0800
commit0dc9a610270e353eb46b1657db8691d91cb3e361 (patch)
treeb56e954adadfc13563ec13e9acc6bd4047b7a339 /textproc/emacs-wiki
parentcfa1077d619525712a8a65f5995717180ac56ae2 (diff)
downloadfreebsd-ports-graphics-0dc9a610270e353eb46b1657db8691d91cb3e361.tar.gz
freebsd-ports-graphics-0dc9a610270e353eb46b1657db8691d91cb3e361.tar.zst
freebsd-ports-graphics-0dc9a610270e353eb46b1657db8691d91cb3e361.zip
emacs-wiki enables you to create and use hyperlinks and simple formatting in
plain text files, and to optionally publish your pages as HTML. PR: ports/78612 Submitted by: Dryice Liu <dryice@liu.com.cn>
Diffstat (limited to 'textproc/emacs-wiki')
-rw-r--r--textproc/emacs-wiki/Makefile61
-rw-r--r--textproc/emacs-wiki/distinfo2
-rw-r--r--textproc/emacs-wiki/pkg-descr5
-rw-r--r--textproc/emacs-wiki/pkg-plist22
4 files changed, 90 insertions, 0 deletions
diff --git a/textproc/emacs-wiki/Makefile b/textproc/emacs-wiki/Makefile
new file mode 100644
index 00000000000..b807edb3211
--- /dev/null
+++ b/textproc/emacs-wiki/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: emacs-wiki
+# Date created: March 09 2005
+# Whom: Dryice Liu <dryice@liu.com.cn>
+#
+# $FreeBSD$
+#
+
+PORTNAME= emacs-wiki
+PORTVERSION= 2.67.1
+CATEGORIES= textproc elisp
+MASTER_SITES= http://www.mwolson.org/static/dist/emacs-wiki/ \
+ http://bsdchat.com/dist/dryice/
+PKGNAMESUFFIX= -${EMACS_PORT_NAME}
+
+MAINTAINER= dryice@liu.com.cn
+COMMENT= Create and use hyperlinks and simple formatting in plain text files
+
+EMACS_PORT_NAME?= emacs21
+
+.if ${EMACS_PORT_NAME} != "emacs21"
+PORTNAMESUFFIX= ${PKGNAMESUFFIX}
+.endif
+
+RUN_DEPENDS+= ${PREFIX}/${EMACS_SITE_LISPDIR}/xml-parse.el:${PORTSDIR}/textproc/xml-parse.el
+RUN_DEPENDS+= ${PREFIX}/${EMACS_SITE_LISPDIR}/htmlize.el:${PORTSDIR}/textproc/htmlize.el
+
+.if defined(WITH_CONTRIB)
+PLIST_SUB+= CONTRIB=""
+.else
+PLIST_SUB+= CONTRIB="@comment "
+.endif
+
+INFO= emacs-wiki
+LISPDIR= ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME}
+
+pre-everything::
+.if !defined(WITH_CONTRIB)
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You may want to build with WITH_CONTRIB=yes"
+ @${ECHO_MSG} "to install some extra packages. Note this may"
+ @${ECHO_MSG} "shadow the versions you already installed elsewhere."
+ @${ECHO_MSG} ""
+.endif
+
+do-build:
+ cd ${WRKSRC}; makeinfo --no-split emacs-wiki.texi
+
+do-install:
+ ${MKDIR} ${LISPDIR}
+.for i in *.el
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${LISPDIR}
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/emacs-wiki.info ${PREFIX}/info
+.if defined(WITH_CONTRIB)
+ ${MKDIR} ${LISPDIR}/contrib
+.for i in *.el
+ ${INSTALL_DATA} ${WRKSRC}/contrib/${i} ${LISPDIR}/contrib
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/emacs-wiki/distinfo b/textproc/emacs-wiki/distinfo
new file mode 100644
index 00000000000..f94d8b72edf
--- /dev/null
+++ b/textproc/emacs-wiki/distinfo
@@ -0,0 +1,2 @@
+MD5 (emacs-wiki-2.67.1.tar.gz) = 9d9e837131dc7d551b6d21846ce55128
+SIZE (emacs-wiki-2.67.1.tar.gz) = 214827
diff --git a/textproc/emacs-wiki/pkg-descr b/textproc/emacs-wiki/pkg-descr
new file mode 100644
index 00000000000..6ea99666717
--- /dev/null
+++ b/textproc/emacs-wiki/pkg-descr
@@ -0,0 +1,5 @@
+emacs-wiki enables you to create and use hyperlinks and simple
+formatting in plain text files, and to optionally publish your pages as
+HTML.
+
+WWW: http://www.mwolson.org/projects/EmacsWiki.html
diff --git a/textproc/emacs-wiki/pkg-plist b/textproc/emacs-wiki/pkg-plist
new file mode 100644
index 00000000000..87cd8805f4b
--- /dev/null
+++ b/textproc/emacs-wiki/pkg-plist
@@ -0,0 +1,22 @@
+%%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/emacs-wiki-colors.el
+%%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/emacs-wiki-httpd.el
+%%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/emacs-wiki-id.el
+%%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/emacs-wiki-macros.el
+%%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/emacs-wiki-mathml.el
+%%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/emacs-wiki-menu.el
+%%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/emacs-wiki-pgg.el
+%%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/emacs-wiki-project.el
+%%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/emacs-wiki-publish.el
+%%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/emacs-wiki-regexps.el
+%%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/emacs-wiki-srctag.el
+%%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/emacs-wiki-table.el
+%%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/emacs-wiki-transition.el
+%%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/emacs-wiki.el
+%%CONTRIB%%%%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/contrib/cgi.el
+%%CONTRIB%%%%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/contrib/htmlize.el
+%%CONTRIB%%%%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/contrib/httpd.el
+%%CONTRIB%%%%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/contrib/pcomplete.el
+%%CONTRIB%%%%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/contrib/table.el
+%%CONTRIB%%%%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/contrib/update-remote.el
+%%CONTRIB%%@dirrm %%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki/contrib
+@dirrm %%EMACS_VERSION_SITE_LISPDIR%%/emacs-wiki