aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/gsed
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2006-04-20 13:51:54 +0800
committersem <sem@FreeBSD.org>2006-04-20 13:51:54 +0800
commit3e0f0a4c31527a975706d3e3d6e34065554df9ba (patch)
tree6c8423cfbc72f39af6dcd268678b595b587cde82 /textproc/gsed
parentff84bb313ff577215fec8cb3ab68904fbe18b19c (diff)
downloadfreebsd-ports-graphics-3e0f0a4c31527a975706d3e3d6e34065554df9ba.tar.gz
freebsd-ports-graphics-3e0f0a4c31527a975706d3e3d6e34065554df9ba.tar.zst
freebsd-ports-graphics-3e0f0a4c31527a975706d3e3d6e34065554df9ba.zip
- Fix build on 4.x
PR: ports/96013 Submitted by: maintainer
Diffstat (limited to 'textproc/gsed')
-rw-r--r--textproc/gsed/Makefile10
-rw-r--r--textproc/gsed/files/extrapatch-lib-regexec.c43
2 files changed, 52 insertions, 1 deletions
diff --git a/textproc/gsed/Makefile b/textproc/gsed/Makefile
index 26646c5b50d..73ee3b34bdf 100644
--- a/textproc/gsed/Makefile
+++ b/textproc/gsed/Makefile
@@ -32,6 +32,14 @@ EXAMPLESDIR= ${PREFIX}/share/examples/${PKGBASE}
PORTDOCS= AUTHORS BUGS COPYING COPYING.DOC NEWS README THANKS
DOCSDIR= ${PREFIX}/share/doc/${PKGBASE}
+.include <bsd.port.pre.mk>
+
+# Required for gcc 2.95 since it is pre-C99
+# and doesn't handle the 'bool' datatype properly.
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES= ${FILESDIR}/extrapatch-lib-regexec.c
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's,^\* sed:,* CNU sed:,' \
${WRKSRC}/doc/config.texi
@@ -59,4 +67,4 @@ post-install:
test:
@cd ${WRKSRC}/testsuite; ${MAKE} check
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/gsed/files/extrapatch-lib-regexec.c b/textproc/gsed/files/extrapatch-lib-regexec.c
new file mode 100644
index 00000000000..a7842dc994e
--- /dev/null
+++ b/textproc/gsed/files/extrapatch-lib-regexec.c
@@ -0,0 +1,43 @@
+#
+# Required for gcc 2.95 since it is pre-C99
+# and doesn't handle the 'bool' datatype properly.
+#
+--- lib/regexec.c.orig Sat Apr 15 20:53:36 2006
++++ lib/regexec.c Sat Apr 15 21:17:03 2006
+@@ -3296,8 +3296,7 @@
+ reg_errcode_t err;
+ int i, j, ch, need_word_trtable = 0;
+ bitset_word_t elem, mask;
+- bool dests_node_malloced = false;
+- bool dest_states_malloced = false;
++ int dests_node_malloced = 0, dest_states_malloced = 0;
+ int ndests; /* Number of the destination states from `state'. */
+ re_dfastate_t **trtable;
+ re_dfastate_t **dest_states = NULL, **dest_states_word, **dest_states_nl;
+@@ -3322,7 +3321,7 @@
+ dests_alloc = re_malloc (struct dests_alloc, 1);
+ if (BE (dests_alloc == NULL, 0))
+ return 0;
+- dests_node_malloced = true;
++ dests_node_malloced = 1;
+ }
+ dests_node = dests_alloc->dests_node;
+ dests_ch = dests_alloc->dests_ch;
+@@ -3371,7 +3370,7 @@
+ free (dests_alloc);
+ return 0;
+ }
+- dest_states_malloced = true;
++ dest_states_malloced = 1;
+ }
+ dest_states_word = dest_states + ndests;
+ dest_states_nl = dest_states_word + ndests;
+@@ -3576,7 +3575,7 @@
+ {
+ if (constraint & NEXT_NEWLINE_CONSTRAINT)
+ {
+- bool accepts_newline = bitset_contain (accepts, NEWLINE_CHAR);
++ int accepts_newline = bitset_contain (accepts, NEWLINE_CHAR);
+ bitset_empty (accepts);
+ if (accepts_newline)
+ bitset_set (accepts, NEWLINE_CHAR);
'>2015-09-082-3/+3 * - Update to 3.5.0Sunpoet Po-Chuan Hsieh2015-09-083-10/+13 * Update to 0.5.5.Raphael Kubo da Costa2015-09-073-91/+12 * graphics/libwmf: Fix bug introduced by patch for CVE-2015-4696Jason Unovitch2015-09-072-2/+5 * - Update to 7.0.0Wen Heping2015-09-074-18/+7 * graphics/maim: update to 3.4.45Jan Beich2015-09-062-4/+3 * Update libgxps to 0.2.3.2.Koop Mast2015-09-062-3/+3 * - use guile-2.0, use swig-3.0Dirk Meyer2015-09-052-20/+19 * SmillaEnlarger is a small graphical tool (based on Qt 4) for resizing and,Alexey Dokuchaev2015-09-054-0/+41 * Remove BROKEN statements for Tier-2 architectures: they do build fine on atAlexey Dokuchaev2015-09-052-9/+1 * UnbreakAntoine Brodin2015-09-051-0/+1 * Fix the build on big-endian architectures (powerpc and hopefully sparc64).Alexey Dokuchaev2015-09-051-4/+2 * Unbreak the build and installation on PowerPC.Alexey Dokuchaev2015-09-054-1/+168 * Update libgxps to 0.2.3.1.Koop Mast2015-09-053-27/+31 * Update gdk-pixbuf2 to 2.31.7.Koop Mast2015-09-053-5/+5 * Convert most ports using cloud.github.com to GHC.Mathieu Arnold2015-09-052-3/+6 * Update eog-plugins to 3.16.1.Koop Mast2015-09-042-5/+4 * Update eog to 3.16.3.Koop Mast2015-09-042-5/+5 * Update atril to 1.10.2.Koop Mast2015-09-046-407/+19 * Update ImageMagick7 to the snapshot from 2015.09.02.Koop Mast2015-09-043-27/+89 * Update to 1.3.1.Jung-uk Kim2015-09-042-4/+3 * - Use BROKEN_RUBY21 and BROKEN_RUBY22Sunpoet Po-Chuan Hsieh2015-09-041-7/+4 * - Add parts of code from newer wine to fix build on mips and aarch64Dmitry Marakasov2015-09-032-0/+204 * Update ImageMagick to 6.9.2-0.Koop Mast2015-09-033-6/+4 * Update devel/tbb to 4.4.0 and bump dependent ports' revisionsGanael LAPLANCHE2015-09-031-1/+1 * - Allow concurrent installation (USE_PYTHON=concurrent)Sunpoet Po-Chuan Hsieh2015-09-021-1/+2 * Fix mysterious linking problems with bundled LZ4 code: it was due to theAlexey Dokuchaev2015-09-012-12/+22 * Update to 1.6.18Antoine Brodin2015-08-313-7/+6 * Drop USES=iconv.Raphael Kubo da Costa2015-08-311-2/+2 * - Update to 3.14.3Veniamin Gvozdikov2015-08-313-5/+4 * - Use %edi register to save/restore contents of %ebx instead of pushingAlexey Dokuchaev2015-08-311-6/+8 * Fix the build against `math/ldouble' when logl(), expl(), and log2l() areAlexey Dokuchaev2015-08-312-3/+19 * Add a port of HDR tools, a set of command-line utilities for creating andAlexey Dokuchaev2015-08-305-0/+113 * Drop USES=iconv:wchar_t.Raphael Kubo da Costa2015-08-301-2/+2 * Cleanup plist, fixing packaging with OPTIONS_UNSET=DOCSAntoine Brodin2015-08-302-2/+0 * Update librsvg2 to 2.40.10.Koop Mast2015-08-294-13/+14 * - Update to 0.3.0TAKATSU Tomonari2015-08-293-6/+6 * - Update to 1.0-6TAKATSU Tomonari2015-08-292-3/+3 * - Security patch for CVE-2015-5203Dirk Meyer2015-08-296-7/+178 * Add a port of appleseed: modern, open source, physically-based renderingAlexey Dokuchaev2015-08-2924-0/+993 * - Bump PORTREVISION after libzip updateMax Brazhnikov2015-08-281-1/+1 * - Update to 0.8.2Sunpoet Po-Chuan Hsieh2015-08-272-3/+3 * Upgrade graphics/cimg to 1.6.4, as it moved to GitHub. It also uses the newerThierry Thomas2015-08-273-34/+32 * - Switch to options helpersDmitry Marakasov2015-08-278-36/+12 * - Switch to options helpersDmitry Marakasov2015-08-272-4/+4 * - Switch to options helpersDmitry Marakasov2015-08-2710-46/+23 * - Add LICENSE_FILEDmitry Marakasov2015-08-272-10/+7 * graphics/darktable: Add patches to fix build with Ninja 1.6.0Jean-Sébastien Pédron2015-08-272-0/+49 * graphics/darktable: Add patch to support LLVM/Clang 3.7.0Jean-Sébastien Pédron2015-08-271-0/+11 * graphics/darktable: Add patch to properly detect GettextJean-Sébastien Pédron2015-08-271-0/+11 * graphics/darktable: Update to 1.6.8Jean-Sébastien Pédron2015-08-272-3/+3 * - Unsilence install commandsDmitry Marakasov2015-08-271-8/+6 * - Update to 1.0Wen Heping2015-08-263-7/+46 * - Do not embed revision hashes inside patches by creating a symlinkAlexey Dokuchaev2015-08-268-16/+20 * - Add LICENSESunpoet Po-Chuan Hsieh2015-08-251-3/+6 * Adjust dependencies.Raphael Kubo da Costa2015-08-251-2/+4 * Convert my ports to new options helpersMax Brazhnikov2015-08-251-9/+2 * - Update to 1.10.0Sunpoet Po-Chuan Hsieh2015-08-252-5/+3 * - Switch to options helpersDmitry Marakasov2015-08-241-8/+3 * - Remove :keepla from USES=libtoolSunpoet Po-Chuan Hsieh2015-08-242-2/+2 * - Remove :keepla from USES=libtoolSunpoet Po-Chuan Hsieh2015-08-242-3/+2 * Consistently spell out ONLY_FOR_ARCHS_REASON due to SSE (and other SIMDAlexey Dokuchaev2015-08-233-3/+3 * Fix devel/glib20-induced abort() with dir monitoring.Matthias Andree2015-08-232-1/+21 * Add a port of Mitsuba, a research-oriented rendering system in the styleAlexey Dokuchaev2015-08-2313-2/+719 * - Update to 0.8.1Sunpoet Po-Chuan Hsieh2015-08-232-3/+3 * - Split ghostscript into X11-independent and -dependent parts:Hiroki Sato2015-08-2319-27/+31 * graphics/vcg: Fix build on DragonFlyJohn Marino2015-08-231-2/+2 * graphics/togl: Alter configure to allow building on DragonFlyJohn Marino2015-08-221-0/+2 * - Split X11 part into graphics/xpeps from graphics/peps.Hiroki Sato2015-08-225-13/+50 * Upgrade to 2.7.2.Vanilla I. Shu2015-08-223-206/+210 * - Switch to options helpersDmitry Marakasov2015-08-221-4/+3 * - Switch to options helpersDmitry Marakasov2015-08-211-21/+10 * - Update graphics/libpgf to 7.15.32Jason E. Hale2015-08-217-39/+13 * Try to fix installation on amd64 by removing stupid `64' suffix that wasAlexey Dokuchaev2015-08-211-1/+9 * - Update The Glorious Glasgow Haskell Compiler to version 7.10.2Gabor Pali2015-08-2118-70/+40 * - Update to 1.0-5TAKATSU Tomonari2015-08-213-7/+4 * - Add NO_ARCHDmitry Marakasov2015-08-212-0/+3 * - Add NO_ARCHDmitry Marakasov2015-08-201-0/+1 * - Fix buil by adding missing dependsDmitry Marakasov2015-08-201-1/+1 * - Fix WWWSunpoet Po-Chuan Hsieh2015-08-201-1/+1 * - Change MASTER_SITES to GitHubSunpoet Po-Chuan Hsieh2015-08-203-5/+7 * - Change MASTER_SITES to GitHubSunpoet Po-Chuan Hsieh2015-08-203-5/+7 * graphics/gimp-help: convert to USES=metaportPhilip M. Gollucci2015-08-201-4/+1 * Update gdkpixbuf2 to 2.31.6.Koop Mast2015-08-193-5/+5 * Reset maintainerErwin Lansing2015-08-191-1/+1 * Reset maintainerErwin Lansing2015-08-191-1/+1 * - Belatedly update to version 1.4 (switch to DISTVERSION to make testingAlexey Dokuchaev2015-08-1911-56/+101 * Add a comment that version 3.17.0 is available, but does not build on i386.Alexey Dokuchaev2015-08-191-0/+3 * Uses/cmake.mk: Replace CMAKE_ENV with CONFIGURE_ENV.Raphael Kubo da Costa2015-08-185-5/+4 * - Add missing file to plistDmitry Marakasov2015-08-182-0/+2 * Remove UNIQUENAME and LATEST_LINK.Mathieu Arnold2015-08-1713-25/+11 * - Fix build by adding missing dependsDmitry Marakasov2015-08-171-1/+1 * - Update to 20130711Dmitry Marakasov2015-08-175-28/+10 * graphics/py-pillow: Update to 2.9.0Kubilay Kocak2015-08-172-7/+7 * - Convert to system libzopfliDanilo Egea Gondolfo2015-08-162-5/+12 * - Update WWWSunpoet Po-Chuan Hsieh2015-08-161-1/+1 * - Update to 2.15.4Sunpoet Po-Chuan Hsieh2015-08-152-3/+3 * Update to 5.4.44 release.Alex Dupre2015-08-151-1/+0 * - Add empty directories to plistDmitry Marakasov2015-08-142-2/+4 * - Remove RG linkSunpoet Po-Chuan Hsieh2015-08-141-1/+0 * - Update to 4.2.10Sunpoet Po-Chuan Hsieh2015-08-142-3/+3 * - Update to 3.3.9Dmitry Marakasov2015-08-133-4/+5 * - Add new port: graphics/R-cran-DiagrammeRTAKATSU Tomonari2015-08-134-0/+26 * - Add new port: graphics/R-cran-dygraphsTAKATSU Tomonari2015-08-124-0/+31 * Update to 1.3.0.Jung-uk Kim2015-08-123-6/+6 * Update to 0.1.3.Jung-uk Kim2015-08-113-5/+7 * Add missing run dependencyAntoine Brodin2015-08-111-1/+2 * - Add new port: graphics/R-cran-gridBaseTAKATSU Tomonari2015-08-114-0/+23 * Update to version 1.4.13Pawel Pekala2015-08-112-3/+3 * Update to version 1.72Pawel Pekala2015-08-114-8/+10 * - Update dependency to databases/grassThomas Zander2015-08-111-1/+2 * Adds -fPIC to CFLAGS_aarch64 to a number of ports that already have itAndrew Turner2015-08-101-0/+1 * Re-commit ofAlexander Leidinger2015-08-1044-42/+439 * * Set USES=compiler:c11 to select clang on 9.3-R. Pass MAKE_ENV to jam inKoop Mast2015-08-092-2/+20 * - editors/lazarus update to 1.4.2Jose Alonso Cardenas Marquez2015-08-0912-12/+12 * Add another PORTSCOUT=ignore to gdk-pixbuf because it won't be updated anymore.Koop Mast2015-08-081-0/+2 * * Add PORTSCOUT macros to only show stable gnome versions.Koop Mast2015-08-083-0/+7 * Remove expired ports:Rene Ladan2015-08-084-82/+0 * Update agryllcms to 1.7.0.Koop Mast2015-08-084-6/+28 * - Update to 1.3.4Danilo Egea Gondolfo2015-08-072-3/+3 * Collapse the EGL option into the OPENGL option.Koop Mast2015-08-062-8/+5 * Fix endianness detection on head with strings(1) from ELF toolchain.Jung-uk Kim2015-08-061-2/+3 * The FreeBSD GNOME team proudly presents GNOME 3.16 for FreeBSD.Koop Mast2015-08-0642-942/+912 * - Switch to USES=tarDmitry Marakasov2015-08-061-2/+2 * - Upgrade x11-wm/enlightenment to 0.19.7 [1]Grzegorz Blach2015-08-0513-20/+19 * Remove unneeded MASTER_SITES=GH entries.Mathieu Arnold2015-08-041-1/+0 * graphics/pngcrush: update 1.7.85 -> 1.7.86Bartek Rutkowski2015-08-042-3/+3 * Cleanup some abusive use of GH_TAGNAME.Mathieu Arnold2015-08-042-4/+4 * Horde package update:Martin Matuska2015-08-032-3/+3 * Part 1 of adding USE_GNOME=intltool to ports that require it.Koop Mast2015-08-0314-14/+14 * Update to 0.4.1Olivier Duchateau2015-08-032-3/+3 * Add some more X11 / NOX11 checks around USES=ghostscript usage.Koop Mast2015-08-032-0/+16 * - Update to 1.3.3Danilo Egea Gondolfo2015-08-034-53/+7 * Update poppler to 0.34.0. [1]Koop Mast2015-08-03