aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/hs-Diff
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2010-05-13 00:33:59 +0800
committerpgj <pgj@FreeBSD.org>2010-05-13 00:33:59 +0800
commitf203c3895196ffa8b69517527e8c488cc49ada57 (patch)
treed7be6abb9940698d6dc43b1587948a03039a23b5 /textproc/hs-Diff
parent965f4ecbcd1c9f6296e907af59901feeedfdc42f (diff)
downloadfreebsd-ports-graphics-f203c3895196ffa8b69517527e8c488cc49ada57.tar.gz
freebsd-ports-graphics-f203c3895196ffa8b69517527e8c488cc49ada57.tar.zst
freebsd-ports-graphics-f203c3895196ffa8b69517527e8c488cc49ada57.zip
Introduce a new (and hopefully better) ports infrastructure for Haskell Cabal
ports which makes possible the direct translation of Cabal package descriptions to FreeBSD ports. It promises both easier addition and maintenance for Cabal-based ports.
Diffstat (limited to 'textproc/hs-Diff')
-rw-r--r--textproc/hs-Diff/Makefile61
-rw-r--r--textproc/hs-Diff/pkg-plist20
2 files changed, 11 insertions, 70 deletions
diff --git a/textproc/hs-Diff/Makefile b/textproc/hs-Diff/Makefile
index ae780999682..6cedcb10116 100644
--- a/textproc/hs-Diff/Makefile
+++ b/textproc/hs-Diff/Makefile
@@ -8,68 +8,9 @@
PORTNAME= Diff
PORTVERSION= 0.1.2
CATEGORIES= textproc haskell
-MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
-PKGNAMEPREFIX= hs-
MAINTAINER= jacula@gmail.com
COMMENT= O(ND) diff algorithm in haskell
-BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
-RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
-
-GHC_VERSION= 6.10.4
-DIFF_VERSION= ${PORTVERSION}
-
-GHC_CMD= ${LOCALBASE}/bin/ghc
-SETUP_CMD= ./setup
-
-DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
-DIFF_LIBDIR_REL= lib/${DISTNAME}
-
-PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
- DIFF_VERSION=${DIFF_VERSION} \
- DIFF_LIBDIR_REL=${DIFF_LIBDIR_REL}
-
-.if defined(NOPORTDOCS)
-PLIST_SUB+= NOPORTDOCS=""
-.else
-PLIST_SUB+= NOPORTDOCS="@comment "
-.endif
-
-.if !defined(NOPORTDOCS)
-
-PORT_HADDOCK!= (cd ${.CURDIR}/../../lang/ghc && ${MAKE} -V PORT_HADDOCK)
-.if !empty(PORT_HADDOCK:M?0)
-BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
-.endif
-BUILD_DEPENDS+= HsColour:${PORTSDIR}/print/hs-hscolour
-
-HSCOLOUR_VERSION= 1.15
-HSCOLOUR_DATADIR= ${PREFIX}/share/hscolour-${HSCOLOUR_VERSION}
-
-PORTDOCS= *
-.endif
-
-.SILENT:
-
-do-configure:
- cd ${WRKSRC} && ${GHC_CMD} --make Setup.lhs -o setup -package Cabal \
- && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX}
-
-do-build:
- cd ${WRKSRC} && ${SETUP_CMD} build \
- && ${SETUP_CMD} register --gen-script
-
-.if !defined(NOPORTDOCS)
- cd ${WRKSRC} && ${SETUP_CMD} haddock --hyperlink-source \
- --hscolour-css=${HSCOLOUR_DATADIR}/hscolour.css
-.endif
-
-do-install:
- cd ${WRKSRC} && ${SETUP_CMD} install \
- && ${INSTALL_SCRIPT} register.sh ${PREFIX}/${DIFF_LIBDIR_REL}/register.sh
-
-post-install:
- ${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
-
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/textproc/hs-Diff/pkg-plist b/textproc/hs-Diff/pkg-plist
index 6b9f07394b7..b6f30e1fd48 100644
--- a/textproc/hs-Diff/pkg-plist
+++ b/textproc/hs-Diff/pkg-plist
@@ -1,15 +1,15 @@
@comment $FreeBSD$
-%%DIFF_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Algorithm/Diff.hi
-%%DIFF_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HSDiff-%%DIFF_VERSION%%.o
-%%DIFF_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHSDiff-%%DIFF_VERSION%%.a
-%%DIFF_LIBDIR_REL%%/register.sh
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Algorithm/Diff.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
+%%LIBDIR_REL%%/register.sh
%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
-@dirrm %%DIFF_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Algorithm
-@dirrm %%DIFF_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data
-@dirrm %%DIFF_LIBDIR_REL%%/ghc-%%GHC_VERSION%%
-@dirrm %%DIFF_LIBDIR_REL%%
-@exec /bin/sh %D/%%DIFF_LIBDIR_REL%%/register.sh
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Algorithm
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%LIBDIR_REL%%
+@exec /bin/sh %D/%%LIBDIR_REL%%/register.sh
@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
-@unexec %D/bin/ghc-pkg unregister Diff
+@unexec %D/bin/ghc-pkg unregister %%PORTNAME%%-%%PORTVERSION%%
@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old