aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/jing/Makefile
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2002-02-09 17:30:35 +0800
committerkevlo <kevlo@FreeBSD.org>2002-02-09 17:30:35 +0800
commitae0c7658bb3743f3154dac2abbfd5ab4421011ba (patch)
treef2970e92c94e4ff0782405bea3c78379799bbeb3 /textproc/jing/Makefile
parent9fda9323e5bbd2122757b3ad45d85e9b5abe83d3 (diff)
downloadfreebsd-ports-graphics-ae0c7658bb3743f3154dac2abbfd5ab4421011ba.tar.gz
freebsd-ports-graphics-ae0c7658bb3743f3154dac2abbfd5ab4421011ba.tar.zst
freebsd-ports-graphics-ae0c7658bb3743f3154dac2abbfd5ab4421011ba.zip
Initial import of jing.
Jing is a RELAX NG validator in Java. PR: 34581 Submitted by: Kimura Fuyuki <fuyuki@mj.0038.net>
Diffstat (limited to 'textproc/jing/Makefile')
-rw-r--r--textproc/jing/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/textproc/jing/Makefile b/textproc/jing/Makefile
new file mode 100644
index 00000000000..2b8385673a9
--- /dev/null
+++ b/textproc/jing/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: jing
+# Date created: 3 February 2002
+# Whom: Kimura Fuyuki <fuyuki@mj.0038.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jing
+PORTVERSION= 2001.12.03
+CATEGORIES= textproc
+MASTER_SITES= http://www.thaiopensource.com/relaxng/
+DISTNAME= ${PORTNAME}
+DISTFILES= ${JAR} jing.html copying.txt
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY=
+
+MAINTAINER= fuyuki@mj.0038.net
+
+JAXP?= crimson # or xalan, saxon
+
+RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper
+
+.if ${JAXP} == "xalan"
+RUN_DEPENDS+= ${LOCALBASE}/xalan-j2.1.0/bin/${JAXP}.jar:${PORTSDIR}/java/xalan-j
+.else
+RUN_DEPENDS+= ${LOCALBASE}/share/java/classes/${JAXP}.jar:${PORTSDIR}/textproc/${JAXP}
+.endif
+
+NO_BUILD= yes
+
+JAR= ${DISTNAME}.jar
+JAVALIBDIR= ${PREFIX}/share/java/classes
+
+do-install:
+ ${MKDIR} ${JAVALIBDIR}
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${JAR} ${JAVALIBDIR}
+
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/*.html ${DOCSDIR}
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/*.txt ${DOCSDIR}
+
+.include <bsd.port.mk>