aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/libebml/Makefile
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2003-05-19 16:43:57 +0800
committerlioux <lioux@FreeBSD.org>2003-05-19 16:43:57 +0800
commitca27e6c26d5f109c8cc4c2e400a92ac36841ea1d (patch)
tree537568083d8b561ba2ceee2d61c3888b19c8a0ef /textproc/libebml/Makefile
parentace1b9e89a6acfffc1158a217c8d2bcb47bc7bc8 (diff)
downloadfreebsd-ports-graphics-ca27e6c26d5f109c8cc4c2e400a92ac36841ea1d.tar.gz
freebsd-ports-graphics-ca27e6c26d5f109c8cc4c2e400a92ac36841ea1d.tar.zst
freebsd-ports-graphics-ca27e6c26d5f109c8cc4c2e400a92ac36841ea1d.zip
New port libebml version 0.4.2: EBML (Extensible Binary Meta
Language), sort of binary version of XML
Diffstat (limited to 'textproc/libebml/Makefile')
-rw-r--r--textproc/libebml/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/textproc/libebml/Makefile b/textproc/libebml/Makefile
new file mode 100644
index 00000000000..efbb431ffe9
--- /dev/null
+++ b/textproc/libebml/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: libebml
+# Date created: Mon May 19 08:29:44 UTC 2003
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libebml
+PORTVERSION= 0.4.2
+CATEGORIES= textproc
+MASTER_SITES= http://matroska.sourceforge.net/downloads/
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= EBML (Extensible Binary Meta Language), sort of binary version of XML
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+BUILD_WRKSRC= ${WRKSRC}/make/linux
+INSTALL_WRKSRC= ${WRKSRC}/make/linux
+
+# Installs dir with proper permissions
+INSTALL_DATA_DIR= ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 755
+
+do-configure:
+ @${REINPLACE_CMD} -E \
+ -e 's|^(prefix)[[:space:]]*=.*$$|\1=${PREFIX}|; \
+ s,^(CXX|LD)[[:space:]]*=.*$$,\1=${CXX},; \
+ s|^(CXXFLAGS)[[:space:]]*=(.*)$$|\1+=\2|; \
+ s|^(INSTALL)[[:space:]]*=.*$$|\1=|; \
+ s|^(INSTALL_DIR_OPTS)[[:space:]]*=.*$$|\1=${INSTALL_DATA_DIR}|; \
+ s,^(INSTALL_OPTS_LIB|INSTALL_OPTS)[[:space:]]*=.*$$,\1=${INSTALL_DATA},' \
+ ${WRKSRC}/make/linux/Makefile
+
+.include <bsd.port.mk>