aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/libmwaw
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-03-31 06:10:10 +0800
committerbapt <bapt@FreeBSD.org>2014-03-31 06:10:10 +0800
commit43556b74fcff011d5fae8780d2903b6b86ab67cc (patch)
tree37cbdf9d3f89df60ab818eda19580973085f17af /textproc/libmwaw
parent17f7170880cf3e41bce8fc907c4b55eb3cf89d6d (diff)
downloadfreebsd-ports-graphics-43556b74fcff011d5fae8780d2903b6b86ab67cc.tar.gz
freebsd-ports-graphics-43556b74fcff011d5fae8780d2903b6b86ab67cc.tar.zst
freebsd-ports-graphics-43556b74fcff011d5fae8780d2903b6b86ab67cc.zip
When STL is libc++ use shared pointer from C++11 instead of boost one
Diffstat (limited to 'textproc/libmwaw')
-rw-r--r--textproc/libmwaw/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/textproc/libmwaw/Makefile b/textproc/libmwaw/Makefile
index b04de765dd2..6456800e425 100644
--- a/textproc/libmwaw/Makefile
+++ b/textproc/libmwaw/Makefile
@@ -12,7 +12,6 @@ COMMENT= Import library for some old mac text documents
LICENSE= LGPL21 MPL
LICENSE_COMB= dual
-BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
LIB_DEPENDS= libwpd-0.9.so:${PORTSDIR}/textproc/libwpd
OPTIONS_DEFINE= DOCS
@@ -22,11 +21,19 @@ CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_XZ= yes
-USES= libtool pkgconfig pathfix
+USES= libtool pkgconfig pathfix tar:xz compiler:features
PORTDOCS= *
DOCS_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
DOCS_CONFIGURE_OFF= --without-docs
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_FEATURES:Mlibc++}
+CONFIGURE_ARGS= --with-sharedptr=c++11
+.else
+BUILD_DEPENDS+= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
+CONFIGURE_ARGS= --with-sharedptr=boost
+.endif
+
+.include <bsd.port.post.mk>