aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/libmwaw
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-04-23 21:25:16 +0800
committertijl <tijl@FreeBSD.org>2014-04-23 21:25:16 +0800
commit55e5c34e31b90aa95311b10bd4a3072f2163ebfe (patch)
tree69c07cdc4812f0f8be0cc44c38513f540c058778 /textproc/libmwaw
parent0c15193d405451f0e1452ba981c8efb1df1447dd (diff)
downloadfreebsd-ports-graphics-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.tar.gz
freebsd-ports-graphics-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.tar.zst
freebsd-ports-graphics-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.zip
When linking a library libA with a library libB using libtool, if libB.la
exists, libtool will add all libraries libB.la refers to (dependency_libs field) to the linker command line and store them in the dependency_libs field of libA.la. So everything that subsequently links with libA will also link to these extra libraries. This causes too much overlinking. This commit modifies Mk/Uses/libtool.mk so it empties the dependency_libs field in .la libraries during staging. However, because .la libraries have very limited use when dependency_libs is empty it makes sense to completely remove them during staging. So with this commit USES=libtool is modified to remove .la libraries and a new form (USES=libtool:keepla) is introduced in case they need to be kept (dependency_libs is still emptied). PORTREVISION is bumped on all ports with USES=libtool that install .la libraries. Most ports are also changed to add :keepla because .la libraries have to be kept around as long as there are dependent ports with .la libraries that refer to them in their dependency_libs field. In most cases :keepla can be removed again as soon as all dependent ports that install .la libraries have some form of USES=libtool added to their Makefile. PR: ports/188759 Exp-run: bdrewery Approved by: portmgr (bdrewery)
Diffstat (limited to 'textproc/libmwaw')
-rw-r--r--textproc/libmwaw/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/textproc/libmwaw/Makefile b/textproc/libmwaw/Makefile
index d1570b610dc..6cb933a0399 100644
--- a/textproc/libmwaw/Makefile
+++ b/textproc/libmwaw/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libmwaw
PORTVERSION= 0.1.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -20,8 +20,8 @@ CONFIGURE_ARGS= --disable-werror
CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
+USES= compiler:features libtool:keepla pathfix pkgconfig tar:xz
USE_LDCONFIG= yes
-USES= libtool pkgconfig pathfix tar:xz compiler:features
PORTDOCS= *
DOCS_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen