aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/php5-wddx
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2016-02-15 03:21:31 +0800
committerrene <rene@FreeBSD.org>2016-02-15 03:21:31 +0800
commitfcda9947bb0106a2b6a81862fe249f8cf0fe0dd3 (patch)
tree8ee58acab1b0a9fe8d1b1eb86093bf1a0d151f63 /textproc/php5-wddx
parent5bb51cc37e4c2b3aa67f6bdc9da7ce2b7f18b36e (diff)
downloadfreebsd-ports-graphics-fcda9947bb0106a2b6a81862fe249f8cf0fe0dd3.tar.gz
freebsd-ports-graphics-fcda9947bb0106a2b6a81862fe249f8cf0fe0dd3.tar.zst
freebsd-ports-graphics-fcda9947bb0106a2b6a81862fe249f8cf0fe0dd3.zip
Remove PHP 5.4 from the Ports Tree, it expired upstream in 2015-Q3 and the
ports expired last month. Adjust Mk/bsd.php.mk Reviewed by: antoine, marino Approved by: portmgr (antoine) Differential Revision: https://reviews.freebsd.org/D5278
Diffstat (limited to 'textproc/php5-wddx')
-rw-r--r--textproc/php5-wddx/Makefile10
-rw-r--r--textproc/php5-wddx/files/patch-config.m422
-rw-r--r--textproc/php5-wddx/files/patch-wddx.c40
3 files changed, 0 insertions, 72 deletions
diff --git a/textproc/php5-wddx/Makefile b/textproc/php5-wddx/Makefile
deleted file mode 100644
index 991fca1829f..00000000000
--- a/textproc/php5-wddx/Makefile
+++ /dev/null
@@ -1,10 +0,0 @@
-# Created by: Alex Dupre <ale@FreeBSD.org>
-# $FreeBSD$
-
-CATEGORIES= textproc
-
-MASTERDIR= ${.CURDIR}/../../lang/php5
-
-PKGNAMESUFFIX= -wddx
-
-.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php5-wddx/files/patch-config.m4 b/textproc/php5-wddx/files/patch-config.m4
deleted file mode 100644
index 08787003b8f..00000000000
--- a/textproc/php5-wddx/files/patch-config.m4
+++ /dev/null
@@ -1,22 +0,0 @@
---- config.m4.orig Mon Jul 26 09:05:10 2004
-+++ config.m4 Mon Jul 26 09:07:46 2004
-@@ -5,6 +5,9 @@
- PHP_ARG_ENABLE(wddx,whether to enable WDDX support,
- [ --enable-wddx Enable WDDX support.])
-
-+PHP_ARG_WITH(libxml-dir, libxml2 install dir,
-+[ --with-libxml-dir=<DIR> WDDX: libxml2 install prefix], no, no)
-+
- if test "$PHP_WDDX" != "no"; then
- if test "$ext_shared" != "yes" && test "$enable_xml" = "no"; then
- AC_MSG_WARN(Activating XML)
-@@ -12,4 +15,9 @@
- fi
- AC_DEFINE(HAVE_WDDX, 1, [ ])
- PHP_NEW_EXTENSION(wddx, wddx.c, $ext_shared)
-+
-+ PHP_SETUP_LIBXML(WDDX_SHARED_LIBADD, [
-+ ], [
-+ AC_MSG_ERROR([xml2-config not found. Please check your libxml2 installation.])
-+ ])
- fi
diff --git a/textproc/php5-wddx/files/patch-wddx.c b/textproc/php5-wddx/files/patch-wddx.c
deleted file mode 100644
index a8a6a79fe47..00000000000
--- a/textproc/php5-wddx/files/patch-wddx.c
+++ /dev/null
@@ -1,40 +0,0 @@
---- wddx.c.orig Sun Jan 1 13:50:16 2006
-+++ wddx.c Mon Jan 16 12:56:21 2006
-@@ -18,6 +18,10 @@
-
- /* $Id: wddx.c,v 1.119.2.8 2006/01/01 12:50:16 sniper Exp $ */
-
-+#ifdef HAVE_CONFIG_H
-+# include "config.h"
-+#endif
-+
- #include "php.h"
-
- #if HAVE_WDDX
-@@ -223,7 +227,7 @@
-
- #include "ext/session/php_session.h"
-
--#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
-+#if HAVE_PHP_SESSION
- /* {{{ PS_SERIALIZER_ENCODE_FUNC
- */
- PS_SERIALIZER_ENCODE_FUNC(wddx)
-@@ -302,7 +306,7 @@
- {
- le_wddx = zend_register_list_destructors_ex(release_wddx_packet_rsrc, NULL, "wddx", module_number);
-
--#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
-+#if HAVE_PHP_SESSION
- php_session_register_serializer("wddx",
- PS_SERIALIZER_ENCODE_NAME(wddx),
- PS_SERIALIZER_DECODE_NAME(wddx));
-@@ -317,7 +321,7 @@
- PHP_MINFO_FUNCTION(wddx)
- {
- php_info_print_table_start();
--#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
-+#if HAVE_PHP_SESSION
- php_info_print_table_header(2, "WDDX Support", "enabled" );
- php_info_print_table_row(2, "WDDX Session Serializer", "enabled" );
- #else