aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/scrollkeeper
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2006-06-12 12:58:43 +0800
committermezz <mezz@FreeBSD.org>2006-06-12 12:58:43 +0800
commitb86cc8d4c3812f7f58f2621fdb68c89ce44b1365 (patch)
treef9d882c6238664cc6cb4f6fbae4e5bdb2e1364ee /textproc/scrollkeeper
parent73e90e9463c57f1bcaa52ced2bda3fd8af02b294 (diff)
downloadfreebsd-ports-graphics-b86cc8d4c3812f7f58f2621fdb68c89ce44b1365.tar.gz
freebsd-ports-graphics-b86cc8d4c3812f7f58f2621fdb68c89ce44b1365.tar.zst
freebsd-ports-graphics-b86cc8d4c3812f7f58f2621fdb68c89ce44b1365.zip
Use the correct mtree when you change the prefix, for example:
Incorrect: (before) ================================ # cd /usr/ports/x11-toolkits/pango # make -V MTREE_FILE /etc/mtree/BSD.x11-4.dist # make PREFIX=/tmp/foo -V MTREE_FILE /etc/mtree/BSD.local.dist <-- Here... ================================ Correct: (after) ================================ # cd /usr/ports/x11-toolkits/pango # make -V MTREE_FILE /etc/mtree/BSD.x11-4.dist # make PREFIX=/tmp/foo -V MTREE_FILE /etc/mtree/BSD.x11-4.dist <-- Here... ================================
Diffstat (limited to 'textproc/scrollkeeper')
-rw-r--r--textproc/scrollkeeper/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/textproc/scrollkeeper/Makefile b/textproc/scrollkeeper/Makefile
index 67183ca6a21..83c25f91bbf 100644
--- a/textproc/scrollkeeper/Makefile
+++ b/textproc/scrollkeeper/Makefile
@@ -53,6 +53,14 @@ MAN7= scrollkeeper.7
MAN8= scrollkeeper-preinstall.8 scrollkeeper-rebuilddb.8 \
scrollkeeper-update.8
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} == xfree86-3
+MTREE_FILE= /etc/mtree/BSD.x11.dist
+.else
+MTREE_FILE= /etc/mtree/BSD.x11-4.dist
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|[(]LN_S[)] -f -n|(LN_S) -f|g'
@@ -61,4 +69,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/extract/dtds/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>