aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/uim-qt
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /textproc/uim-qt
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-graphics-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-graphics-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-graphics-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'textproc/uim-qt')
-rw-r--r--textproc/uim-qt/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/textproc/uim-qt/Makefile b/textproc/uim-qt/Makefile
index 207f92683ba..002a264c1db 100644
--- a/textproc/uim-qt/Makefile
+++ b/textproc/uim-qt/Makefile
@@ -19,10 +19,10 @@ PKGDIR= ${.CURDIR}
CONFIGURE_ARGS= --with-qt --enable-pref --enable-default-toolkit=qt \
--disable-kde-applet
CONFIGURE_ENV= QTDIR=${LOCALBASE}/lib QTINCDIR=${LOCALBASE}/include \
- CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
- CXXFLAGS="${CXXFLAGS} ${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
- LIBS="${LIBS} ${PTHREAD_LIBS} -L${LOCALBASE}/lib" \
- LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS} -L${LOCALBASE}/lib"
+ LIBS="${LIBS} ${PTHREAD_LIBS} -L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
+CXXFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
UIM_SLAVE= yes
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-qt_Makefile.in \