aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/uncrustify
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-07-22 17:23:56 +0800
committermiwi <miwi@FreeBSD.org>2006-07-22 17:23:56 +0800
commitbb62654c2c2ec0278898f029e5e3c28c7e16a0cb (patch)
treede0e827094fec201ebf60755e02f20347fd0828f /textproc/uncrustify
parenta1dd54cbe211506b96d323b6cd37b30d193b627a (diff)
downloadfreebsd-ports-graphics-bb62654c2c2ec0278898f029e5e3c28c7e16a0cb.tar.gz
freebsd-ports-graphics-bb62654c2c2ec0278898f029e5e3c28c7e16a0cb.tar.zst
freebsd-ports-graphics-bb62654c2c2ec0278898f029e5e3c28c7e16a0cb.zip
Add uncrustify , highly configurable source code beautifier.
The goals of this project are simple: Create a highly configurable, easily modifiable source code beautifier. What it does: * Ident code, aligning on parens, assignments, etc * Align on '=' and variable definitions * Align structure initializers * Align #define stuff * Align backslash-newline stuff * Reformat comments (a little bit) * Fix inter-character spacing * Add or remove parens on return statements * Add or remove braces on single-statement if/do/while/for statements * Highly configurable - 118 configurable options as of version 0.0.15 WWW: http://uncrustify.sourceforge.net PR: ports/100604 Submitted by: Dmitry Marakasov <amdmi3 at mail.ru>
Diffstat (limited to 'textproc/uncrustify')
-rw-r--r--textproc/uncrustify/Makefile21
-rw-r--r--textproc/uncrustify/distinfo3
-rw-r--r--textproc/uncrustify/files/patch-src-uncrustify.cpp10
-rw-r--r--textproc/uncrustify/pkg-descr16
-rw-r--r--textproc/uncrustify/pkg-plist10
5 files changed, 60 insertions, 0 deletions
diff --git a/textproc/uncrustify/Makefile b/textproc/uncrustify/Makefile
new file mode 100644
index 00000000000..3f13e6c524a
--- /dev/null
+++ b/textproc/uncrustify/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: uncrustify
+# Date created: 03 Jul 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= uncrustify
+PORTVERSION= 0.0.22
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= Highly configurable source code beautifier
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/uncrustify/distinfo b/textproc/uncrustify/distinfo
new file mode 100644
index 00000000000..44a90cfdcbd
--- /dev/null
+++ b/textproc/uncrustify/distinfo
@@ -0,0 +1,3 @@
+MD5 (uncrustify-0.0.22.tgz) = cc4f034d9c4e49a27c9496d90070172f
+SHA256 (uncrustify-0.0.22.tgz) = de0479c9e7868cd588d44f68cd167d91c8da89983509d2241684423bf8d77e22
+SIZE (uncrustify-0.0.22.tgz) = 347617
diff --git a/textproc/uncrustify/files/patch-src-uncrustify.cpp b/textproc/uncrustify/files/patch-src-uncrustify.cpp
new file mode 100644
index 00000000000..b9fe2bb059e
--- /dev/null
+++ b/textproc/uncrustify/files/patch-src-uncrustify.cpp
@@ -0,0 +1,10 @@
+--- src/uncrustify.cpp.orig Wed Jul 19 20:39:15 2006
++++ src/uncrustify.cpp Wed Jul 19 20:39:48 2006
+@@ -15,6 +15,7 @@
+ #include "logger.h"
+ #include "log_levels.h"
+
++#include <libgen.h>
+ #include <cstdio>
+ #include <cstdlib>
+ #include <cstring>
diff --git a/textproc/uncrustify/pkg-descr b/textproc/uncrustify/pkg-descr
new file mode 100644
index 00000000000..7cafe593b05
--- /dev/null
+++ b/textproc/uncrustify/pkg-descr
@@ -0,0 +1,16 @@
+The goals of this project are simple:
+Create a highly configurable, easily modifiable source code beautifier.
+
+What it does:
+* Ident code, aligning on parens, assignments, etc
+* Align on '=' and variable definitions
+* Align structure initializers
+* Align #define stuff
+* Align backslash-newline stuff
+* Reformat comments (a little bit)
+* Fix inter-character spacing
+* Add or remove parens on return statements
+* Add or remove braces on single-statement if/do/while/for statements
+* Highly configurable - 118 configurable options as of version 0.0.15
+
+WWW: http://uncrustify.sourceforge.net
diff --git a/textproc/uncrustify/pkg-plist b/textproc/uncrustify/pkg-plist
new file mode 100644
index 00000000000..6e1acc5144d
--- /dev/null
+++ b/textproc/uncrustify/pkg-plist
@@ -0,0 +1,10 @@
+bin/uncrustify
+%%DATADIR%%/ben.cfg
+%%DATADIR%%/d.cfg
+%%DATADIR%%/gnu-indent.cfg
+%%DATADIR%%/kr-indent.cfg
+%%DATADIR%%/linux-indent.cfg
+%%DATADIR%%/linux.cfg
+%%DATADIR%%/mono.cfg
+%%DATADIR%%/xsupplicant.cfg
+@dirrm %%DATADIR%%