aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/urlview
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2005-11-30 20:00:43 +0800
committerflz <flz@FreeBSD.org>2005-11-30 20:00:43 +0800
commit8c60daa00cc4d9517a48599e743b77bbb5bfd6db (patch)
tree7dd835b4c61f19e93babcb1506e91cee31031ae9 /textproc/urlview
parentbe806e2e0aa58766cd3bd23069657dc9273ee98f (diff)
downloadfreebsd-ports-graphics-8c60daa00cc4d9517a48599e743b77bbb5bfd6db.tar.gz
freebsd-ports-graphics-8c60daa00cc4d9517a48599e743b77bbb5bfd6db.tar.zst
freebsd-ports-graphics-8c60daa00cc4d9517a48599e743b77bbb5bfd6db.zip
- Fix segfault on machines where sizeof(int) != sizeof(char *).
PR: ports/88729 Submitted by: Vasil Dimov <vd@datamax.bg> Approved by: maintainer timeout (2 weeks)
Diffstat (limited to 'textproc/urlview')
-rw-r--r--textproc/urlview/Makefile2
-rw-r--r--textproc/urlview/files/patch-urlview.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/textproc/urlview/Makefile b/textproc/urlview/Makefile
index c448ffdfea2..aff29aeeba7 100644
--- a/textproc/urlview/Makefile
+++ b/textproc/urlview/Makefile
@@ -8,7 +8,7 @@
PORTNAME= urlview
PORTVERSION= 0.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc www
MASTER_SITES= ftp://ftp.mutt.org/mutt/contrib/ \
ftp://ftp.sunsite.auc.dk/pub/mail/mutt/contrib/ \
diff --git a/textproc/urlview/files/patch-urlview.c b/textproc/urlview/files/patch-urlview.c
new file mode 100644
index 00000000000..84fd3714048
--- /dev/null
+++ b/textproc/urlview/files/patch-urlview.c
@@ -0,0 +1,11 @@
+--- urlview.c.orig Wed Nov 9 15:34:39 2005
++++ urlview.c Wed Nov 9 15:35:06 2005
+@@ -46,6 +46,8 @@
+ #include <rx/rxposix.h>
+ #endif
+
++#include "quote.h"
++
+ #define DEFAULT_REGEXP "(((https?|ftp|gopher)://|(mailto|file|news):)[^' \t<>\"]+|(www|web|w3)\\.[-a-z0-9.]+)[^' \t.,;<>\"\\):]"
+ #define DEFAULT_COMMAND "url_handler.sh %s"
+ #define SYSTEM_INITFILE "/usr/local/etc/urlview.conf"