aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-07-12 13:53:15 +0800
committerrafan <rafan@FreeBSD.org>2006-07-12 13:53:15 +0800
commit03c2907fa274ef5bc2dfba9e73745fc589f3527e (patch)
tree8621893ccb5633fc2f6cd22246d45476e959411a /textproc
parent4b64f308afdf7bfacf9938caaa6cbd023e8c64d0 (diff)
downloadfreebsd-ports-graphics-03c2907fa274ef5bc2dfba9e73745fc589f3527e.tar.gz
freebsd-ports-graphics-03c2907fa274ef5bc2dfba9e73745fc589f3527e.tar.zst
freebsd-ports-graphics-03c2907fa274ef5bc2dfba9e73745fc589f3527e.zip
Add csvdiff 1.3, compare/diff two (comma) seperated files with each
other. PR: ports/100097 Submitted by: chinsan <chinsan.tw at gmail.com>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/csvdiff/Makefile36
-rw-r--r--textproc/csvdiff/distinfo3
-rw-r--r--textproc/csvdiff/pkg-descr9
4 files changed, 49 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index e108b1b6165..8cb12c2d0ff 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -60,6 +60,7 @@
SUBDIR += csb-aspell
SUBDIR += csv2latex
SUBDIR += csv2xml
+ SUBDIR += csvdiff
SUBDIR += ctpp
SUBDIR += cwtext
SUBDIR += cy-aspell
diff --git a/textproc/csvdiff/Makefile b/textproc/csvdiff/Makefile
new file mode 100644
index 00000000000..7c393c08f77
--- /dev/null
+++ b/textproc/csvdiff/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: csvdiff
+# Date created: 2006/07/12
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= csvdiff
+PORTVERSION= 1.3
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}_${PORTVERSION:S,.,-,g}
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= Compare/diff two (comma) seperated files with each other
+
+NO_BUILD= yes
+USE_PERL5= yes
+PLIST_FILES= bin/csvdiff
+WRKSRC= ${WRKDIR}
+.if !defined(NOPORTDOCS)
+PORTDOCS= CHANGES README TODO
+.endif
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl \
+ ${PREFIX}/bin/${PORTNAME}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/csvdiff/distinfo b/textproc/csvdiff/distinfo
new file mode 100644
index 00000000000..6d5dd89bcff
--- /dev/null
+++ b/textproc/csvdiff/distinfo
@@ -0,0 +1,3 @@
+MD5 (csvdiff_1-3.tar.gz) = ffcafdf67c0526fe56fe1c2aa96475c8
+SHA256 (csvdiff_1-3.tar.gz) = 60b2680c748763ea19f5b0ab710d86cb44a33433be5fe0b117c3a15a0962ac91
+SIZE (csvdiff_1-3.tar.gz) = 14739
diff --git a/textproc/csvdiff/pkg-descr b/textproc/csvdiff/pkg-descr
new file mode 100644
index 00000000000..9f9ba51174f
--- /dev/null
+++ b/textproc/csvdiff/pkg-descr
@@ -0,0 +1,9 @@
+csvdiff is a Perl script to diff/compare two csv files with the possibility
+to select the separator.
+
+Differences will be shown like:
+"Column XYZ in record 999" is different.
+After this, the actual and the expected result for this
+column will be shown.
+
+WWW: http://csvdiff.sourceforge.net/
an class='deletions'>-6/+5 * * mail/postfixmnag2007-04-053-17/+19 * - Update to 2.3.8mnag2007-03-072-9/+8 * - Add mail to PROVIDE line. This fixes other scripts that require mailrafan2007-02-212-1/+2 * Addition of postfix_flags variable to rc.subr startup script.koitsu2007-02-211-2/+5 * - Update to 2.3.7rafan2007-02-012-4/+4 * - Update to 2.3.5mnag2006-12-132-4/+4 * - Remove SPF compatible options. Patch are removed in 20060719.mnag2006-11-291-1/+1 * - Update VDA patch to 2.3.4mnag2006-11-092-5/+5 * - Update to 2.3.4mnag2006-11-022-8/+8 * - Update to 2.3.3mnag2006-08-272-5/+4 * - Update VDA patch to 2.3.2mnag2006-08-132-4/+4 * Fix "typo" in previous commit.itetcu2006-08-021-1/+1 * Make rc.d start postfix later, like sendmail does.itetcu2006-08-021-1/+2 * - Update to 2.3.2mnag2006-07-312-8/+8 * - Update to 2.3.1mnag2006-07-252-4/+4 * - Spell fixes [1]mnag2006-07-202-4/+4 * * UPDATINGmnag2006-07-1910-332/+284 * - Update to use USE_BDB flagmnag2006-04-222-66/+8 * - VDA patch are rerolled. Minor changes in patch.mnag2006-04-191-3/+3 * - Update VDA patch to 2.2.10mnag2006-04-183-5/+6 * - Update to 2.2.10mnag2006-04-074-11/+20 * - Update to 2.2.9mnag2006-02-223-10/+9 * - Linker fix when use OPENSSL from portsmnag2006-01-253-5/+4 * Replace ugly "@unexec rmdir %D... 2>/dev/null || true" with @dirrmtryedwin2006-01-221-1/+1 * Modify rc.d script like example in Porters Handbook.mnag2006-01-171-11/+15 * Fix rc.d/postfix.sh restart adding pidfile and procnamemnag2006-01-132-1/+7 * Add rcNG script to start postfixmnag2006-01-134-27/+53 * Update to 2.2.8mnag2006-01-053-11/+9 * Update to 2.2.7mnag2005-12-132-4/+4 * Add MIT kerberos 5 optionmnag2005-12-011-1/+6 * Update to 2.2.6mnag2005-12-015-16/+22 * Add WITH_OPENLDAP_VER to reflect options menumnag2005-10-141-1/+4 * Proper link when use OPENSSL from ports.mnag2005-10-042-5/+5 * VDA bugfixmnag2005-09-291-2/+2 * Update PORTREVISION because libspf2 is movedvsevolod2005-09-126-164/+144 * - Add cdb map lookupsgarga2005-08-311-2/+9 * Fix outdated information regarding sendmail rc.conf variableslawrance2005-08-021-1/+4 * - Allow Marcus Grando to bypass maintainerpav2005-07-251-0/+1 * - Update to 2.2.5pav2005-07-232-4/+3 * - Update comment to match existing optionspav2005-07-221-1/+1 * - Fix build on FreeBSD 7pav2005-07-141-3/+5 * - Fix manpage links [1] [2]jylefort2005-07-073-15/+21 * - Update to 2.2.4.flz2005-06-232-4/+4 * - Add instructions for /etc/rc.conf that makebarner2005-05-201-3/+6 * Update the VDA patch to 2.2.3jylefort2005-05-113-4/+5 * Update to 2.2.3jylefort2005-05-032-3/+3 * - Update postfix to 2.2.2pav2005-04-064-8/+8 * - Update to 2.2.1pav2005-03-2012-569/+463 * - Update VDA patch to 2.1.5pav2005-02-182-4/+4 * postfix's optional postgres support doesn't work with the new Postgres portleeym2005-02-081-20/+3 * [PATCH] mail/postfix: Update to libspf2-2.1.5-5edwin2004-11-274-26/+6 * - Support SPF and TLS at the same timepav2004-11-152-1/+22 * - Fix build with SASLKRB5 optionpav2004-10-261-2/+2 * update mail/postfix to latestedwin2004-10-133-12/+12 * Make sure this patch applies correctly when PATCH_STRIP=-p1, as is thedes2004-09-041-2/+2 * Fix build on 6.0.des2004-08-312-0/+22 * - Add VDA (Virtual Delivery Agent) patchpav2004-08-222-1/+9 * Add a patch to optionnaly add libspf2mat2004-08-183-2/+21 * - Update to 2.1.4pav2004-07-143-4/+8 * - Update IPv6 patches to 2.1.3pav2004-06-252-11/+11 * - Update to 2.1.3pav2004-06-233-10/+10 * - Wordsmithing in commentpav2004-06-111-1/+1 * - Update IPv6 patches to 1.24pav2004-05-222-7/+7 * update mail/postfix to latest releaseedwin2004-05-142-3/+3 * - Update to 2.1.0pav2004-05-1214-283/+288 * - Update to 2.0.20pav2004-05-032-4/+5 * Use /usr/sbin/nologin instead of /sbin/nologin if it exists and isdes2004-04-131-4/+13 * - Kill trailing whitespacepav2004-04-021-2/+2 * - Add support for db42pav2004-03-301-10/+23 * - Update 2.0.19clement2004-03-232-3/+5 * s/USE_OPENLDAP_VER/WANT_OPENLDAP_VER/g in comments.ale2004-03-111-2/+2 * Use USE_MYSQL and USE_OPENLDAP.ale2004-03-111-21/+9 * Fix build with LDAP.osa2004-02-201-3/+3 * Update to latest released version. Update TLS/IPv6 patches to match.eik2004-01-313-9/+20 * Respect ${CC} flag.osa2003-12-311-1/+1 * Add the rc.conf pid-file specification line for startup.petef2003-12-211-0/+1 * - add CONFLICTSdinoex2003-10-141-0/+1 * Update to 2.0.16osa2003-10-023-10/+13 * Update postfix to latest release (mainly a Solaris bug workaround).osa2003-09-092-2/+2 * Update to 2.0.14 [1]osa2003-08-284-99/+99 * Fix plist at optional IPv6 configuration.kuriyama2003-08-172-1/+7 * Fix non-default dependency on openldap2[012] which is broken by splitting.kuriyama2003-08-151-3/+3 * One of the patch files for postfix was not PREFIX-clean. This makes iterwin2003-07-231-7/+7 * Included in this email is a patch to postfix which I need applied forerwin2003-07-101-1/+13 * Fix building with SASL2 case.osa2003-07-071-4/+1 * update mail/postfix: 2.0.12 --> 2.0.13daichi2003-07-023-17/+12 * Upgrade to 2.0.12.obraun2003-06-283-12/+12 * - Update postfix to 2.0.10 releasenaddy2003-06-023-4/+15 * * Upgrade to 2.0.9.obraun2003-05-133-21/+17 * update postfix to 2.0.7leeym2003-04-153-18/+34 * update postfix to 2.0.6leeym2003-03-113-4/+3 * Batch building of packages for postfix is failing due to PCRE issues.leeym2003-03-042-12/+19 * Spell `-ldes' as `-lcrypto'.nectar2003-03-031-3/+3 * Point dependencies on net/openldap to net/openldap12edwin2003-02-241-2/+2 * add PORTEPOCH=1, which was removed by maintainer in rev 1.67leeym2003-02-231-0/+1 * Add missing manpage.demon2003-02-231-2/+2 * update postfix to 2.0.4leeym2003-02-233-10/+9 * De-pkg-comment.knu2003-02-212-1/+1 * upgrade to version 2.0.2sada2003-01-195-19/+67 * Update to 2.0.0.2.petef2003-01-0917-115/+208 * Missed configure scripts in libpq version bump: chase lib version.seanc2003-01-051-2/+3 * upgrade to 1.1.12ijliao2003-01-0258-1074/+42 * Add hooks to preselect postfix optionsdwcjr2002-08-273-31/+47 * moving saslv1 includes files to make it easier to add saslv2ume2002-07-293-6/+6 * Update to 1.1.11dwcjr2002-06-205-10/+25 * Update to latestdwcjr2002-05-172-2/+2 * Update to 1.1.9dwcjr2002-05-153-12/+12 * Add PGSQL supportdwcjr2002-05-092-2/+13 * Add missing pkg-messagedwcjr2002-05-071-0/+24 * Update to 1.1.8dwcjr2002-05-074-26/+24 * handle batch buildsdwcjr2002-04-212-4/+4