aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-05-14 07:01:26 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-05-14 07:01:26 +0800
commit105a1dfe331d50f193169207dced39c81b84a5dd (patch)
treee9c1620da47d9f0fbd8b3e42de4dac496df28773 /textproc
parent2bd5ce7e3be9f335ffc8b65b6a8f02bf02f55e87 (diff)
downloadfreebsd-ports-graphics-105a1dfe331d50f193169207dced39c81b84a5dd.tar.gz
freebsd-ports-graphics-105a1dfe331d50f193169207dced39c81b84a5dd.tar.zst
freebsd-ports-graphics-105a1dfe331d50f193169207dced39c81b84a5dd.zip
RapidXml is an attempt to create the fastest XML parser possible,
while retaining useability, portability and reasonable W3C compatibility. It is an in-situ parser written in modern C++, with parsing speed approaching that of strlen function executed on the same data. RapidXml has been around since 2006, and is being used by lots of people. HTC uses it in some of its mobile phones. If you are looking for a stable and fast parser, look no further. Integration with your project will be trivial, because entire library is contained in a single header file, and requires no building or configuration. WWW: http://rapidxml.sourceforge.net/
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/rapidxml/Makefile29
-rw-r--r--textproc/rapidxml/distinfo2
-rw-r--r--textproc/rapidxml/pkg-descr15
4 files changed, 47 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 4764ae2cd10..13bff48e903 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1222,6 +1222,7 @@
SUBDIR += qu-aspell
SUBDIR += queequeg
SUBDIR += rand
+ SUBDIR += rapidxml
SUBDIR += raptor
SUBDIR += raptor2
SUBDIR += rarian
diff --git a/textproc/rapidxml/Makefile b/textproc/rapidxml/Makefile
new file mode 100644
index 00000000000..dda74e3474c
--- /dev/null
+++ b/textproc/rapidxml/Makefile
@@ -0,0 +1,29 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= rapidxml
+PORTVERSION= 1.13
+CATEGORIES= textproc
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}%20${PORTVERSION}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Fast C++ library for parsing XML
+
+LICENSE= BSL
+
+USES= zip
+NO_BUILD= yes
+PLIST_FILES= include/rapidxml.hpp \
+ include/rapidxml_iterators.hpp \
+ include/rapidxml_print.hpp \
+ include/rapidxml_utils.hpp
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/*.hpp ${STAGEDIR}${PREFIX}/include
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/manual.html ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/rapidxml/distinfo b/textproc/rapidxml/distinfo
new file mode 100644
index 00000000000..e5e1adf1c0c
--- /dev/null
+++ b/textproc/rapidxml/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rapidxml-1.13.zip) = c3f0b886374981bb20fabcf323d755db4be6dba42064599481da64a85f5b3571
+SIZE (rapidxml-1.13.zip) = 44163
diff --git a/textproc/rapidxml/pkg-descr b/textproc/rapidxml/pkg-descr
new file mode 100644
index 00000000000..c13bfcaf00b
--- /dev/null
+++ b/textproc/rapidxml/pkg-descr
@@ -0,0 +1,15 @@
+RapidXml is an attempt to create the fastest XML parser possible,
+while retaining useability, portability and reasonable W3C
+compatibility. It is an in-situ parser written in modern C++, with
+parsing speed approaching that of strlen function executed on the
+same data.
+
+RapidXml has been around since 2006, and is being used by lots of
+people. HTC uses it in some of its mobile phones.
+
+If you are looking for a stable and fast parser, look no further.
+Integration with your project will be trivial, because entire library
+is contained in a single header file, and requires no building or
+configuration.
+
+WWW: http://rapidxml.sourceforge.net/