aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2015-09-30 10:19:14 +0800
committervanilla <vanilla@FreeBSD.org>2015-09-30 10:19:14 +0800
commit17e9c07bb44791b0482fe0be7e285cbc85c3b5b7 (patch)
tree3ce5a2b445da3d3ab2bd1a7a293efbe9eeeeba80 /textproc
parent3df881e7660159c424b5dcffe08e0819f2c91308 (diff)
downloadfreebsd-ports-graphics-17e9c07bb44791b0482fe0be7e285cbc85c3b5b7.tar.gz
freebsd-ports-graphics-17e9c07bb44791b0482fe0be7e285cbc85c3b5b7.tar.zst
freebsd-ports-graphics-17e9c07bb44791b0482fe0be7e285cbc85c3b5b7.zip
1: Rename google-ctemplate to ctemplate.
2: Upgrade to 2.3. 3: move to github.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile2
-rw-r--r--textproc/ctemplate/Makefile (renamed from textproc/google-ctemplate/Makefile)24
-rw-r--r--textproc/ctemplate/distinfo2
-rw-r--r--textproc/ctemplate/files/patch-small_map.h (renamed from textproc/google-ctemplate/files/patch-small_map.h)0
-rw-r--r--textproc/ctemplate/files/patch-src__ctemplate__template_string.h.in (renamed from textproc/google-ctemplate/files/patch-src__ctemplate__template_string.h.in)0
-rw-r--r--textproc/ctemplate/files/patch-src__template_dictionary.cc (renamed from textproc/google-ctemplate/files/patch-src__template_dictionary.cc)0
-rw-r--r--textproc/ctemplate/pkg-descr (renamed from textproc/google-ctemplate/pkg-descr)0
-rw-r--r--textproc/ctemplate/pkg-plist (renamed from textproc/google-ctemplate/pkg-plist)8
-rw-r--r--textproc/google-ctemplate/distinfo2
9 files changed, 23 insertions, 15 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index f7fab8ab9ad..75b53f0385a 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -96,6 +96,7 @@
SUBDIR += csb-aspell
SUBDIR += csv2latex
SUBDIR += csvdiff
+ SUBDIR += ctemplate
SUBDIR += ctpl
SUBDIR += ctpp2
SUBDIR += cwtext
@@ -215,7 +216,6 @@
SUBDIR += go-text
SUBDIR += go.text
SUBDIR += goldendict
- SUBDIR += google-ctemplate
SUBDIR += google-translate-cli
SUBDIR += gpp
SUBDIR += grap
diff --git a/textproc/google-ctemplate/Makefile b/textproc/ctemplate/Makefile
index 1625a6fe71c..f99ba7d117d 100644
--- a/textproc/google-ctemplate/Makefile
+++ b/textproc/ctemplate/Makefile
@@ -1,24 +1,28 @@
# Created by: ijliao
# $FreeBSD$
-PORTNAME= google-ctemplate
-PORTVERSION= 2.2
-PORTREVISION= 3
+PORTNAME= ctemplate
+PORTVERSION= 2.3
CATEGORIES= textproc
-MASTER_SITES= GOOGLE_CODE
-PROJECTHOST= ctemplate
-DISTNAME= ctemplate-${PORTVERSION}
MAINTAINER= vanilla@FreeBSD.org
COMMENT= Simple but powerful template language for C++
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
OPTIONS_DEFINE= DOCS
-USES= libtool pathfix pkgconfig shebangfix
+USES= libtool pathfix pkgconfig python shebangfix
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-silent-rules
-SHEBANG_FILES= src/template-converter
+SHEBANG_FILES= src/template-converter src/htmlparser/generate_fsm.py src/htmlparser/fsm_config.py
USE_LDCONFIG= yes
+USE_GITHUB= yes
+GH_ACCOUNT= OlafvdSpek
+GH_TAGNAME= 359a9f0
+python_OLD_CMD= /usr/bin/env python
+INSTALL_target= install-strip
post-patch:
@${REINPLACE_CMD} -e \
@@ -33,6 +37,10 @@ post-patch-DOCS-off:
'/install-data-am/ s|install-dist_docDATA||' \
${WRKSRC}/Makefile.in
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${LOCALBASE}/lib/libctemplate.so.3.0.0
+ @${STRIP_CMD} ${STAGEDIR}${LOCALBASE}/lib/libctemplate_nothreads.so.3.0.0
+
regression-test: build
@${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} \
${MAKE_ARGS} check -C ${WRKSRC}
diff --git a/textproc/ctemplate/distinfo b/textproc/ctemplate/distinfo
new file mode 100644
index 00000000000..103eee6f93a
--- /dev/null
+++ b/textproc/ctemplate/distinfo
@@ -0,0 +1,2 @@
+SHA256 (OlafvdSpek-ctemplate-2.3-359a9f0_GH0.tar.gz) = a93983b5cd68eac296303f5557a6b075ca36be46d1b4dff17e48ca640db39b92
+SIZE (OlafvdSpek-ctemplate-2.3-359a9f0_GH0.tar.gz) = 720754
diff --git a/textproc/google-ctemplate/files/patch-small_map.h b/textproc/ctemplate/files/patch-small_map.h
index 8bce6353ee7..8bce6353ee7 100644
--- a/textproc/google-ctemplate/files/patch-small_map.h
+++ b/textproc/ctemplate/files/patch-small_map.h
diff --git a/textproc/google-ctemplate/files/patch-src__ctemplate__template_string.h.in b/textproc/ctemplate/files/patch-src__ctemplate__template_string.h.in
index ac1f89a75d5..ac1f89a75d5 100644
--- a/textproc/google-ctemplate/files/patch-src__ctemplate__template_string.h.in
+++ b/textproc/ctemplate/files/patch-src__ctemplate__template_string.h.in
diff --git a/textproc/google-ctemplate/files/patch-src__template_dictionary.cc b/textproc/ctemplate/files/patch-src__template_dictionary.cc
index 9f04884d07c..9f04884d07c 100644
--- a/textproc/google-ctemplate/files/patch-src__template_dictionary.cc
+++ b/textproc/ctemplate/files/patch-src__template_dictionary.cc
diff --git a/textproc/google-ctemplate/pkg-descr b/textproc/ctemplate/pkg-descr
index 569d0c4f1b1..569d0c4f1b1 100644
--- a/textproc/google-ctemplate/pkg-descr
+++ b/textproc/ctemplate/pkg-descr
diff --git a/textproc/google-ctemplate/pkg-plist b/textproc/ctemplate/pkg-plist
index d802d81de11..b4a46b1c0ee 100644
--- a/textproc/google-ctemplate/pkg-plist
+++ b/textproc/ctemplate/pkg-plist
@@ -16,12 +16,12 @@ include/ctemplate/template_pathops.h
include/ctemplate/template_string.h
lib/libctemplate.a
lib/libctemplate.so
-lib/libctemplate.so.2
-lib/libctemplate.so.2.0.1
+lib/libctemplate.so.3
+lib/libctemplate.so.3.0.0
lib/libctemplate_nothreads.a
lib/libctemplate_nothreads.so
-lib/libctemplate_nothreads.so.2
-lib/libctemplate_nothreads.so.2.0.1
+lib/libctemplate_nothreads.so.3
+lib/libctemplate_nothreads.so.3.0.0
libdata/pkgconfig/libctemplate.pc
libdata/pkgconfig/libctemplate_nothreads.pc
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
diff --git a/textproc/google-ctemplate/distinfo b/textproc/google-ctemplate/distinfo
deleted file mode 100644
index 6f08fb400f0..00000000000
--- a/textproc/google-ctemplate/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (ctemplate-2.2.tar.gz) = 04f3cbc0f7ff36adedc904bce776a0817cc6b704b3c4a04b4df5de66fd7e686f
-SIZE (ctemplate-2.2.tar.gz) = 889458