aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-26 17:04:31 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-26 17:04:31 +0800
commit2c0b2f8d308c7f2b52a6d44b513506e4e262caec (patch)
treeefe10d614528dd2d06709c0a589819faeeaa0976 /textproc
parent70a3c39ba4c124ff442eb0a2be81e06d56a91b05 (diff)
downloadfreebsd-ports-graphics-2c0b2f8d308c7f2b52a6d44b513506e4e262caec.tar.gz
freebsd-ports-graphics-2c0b2f8d308c7f2b52a6d44b513506e4e262caec.tar.zst
freebsd-ports-graphics-2c0b2f8d308c7f2b52a6d44b513506e4e262caec.zip
Support staging
Diffstat (limited to 'textproc')
-rw-r--r--textproc/odt2txt/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/textproc/odt2txt/Makefile b/textproc/odt2txt/Makefile
index 9d26ea0e91a..884a7a720d8 100644
--- a/textproc/odt2txt/Makefile
+++ b/textproc/odt2txt/Makefile
@@ -9,26 +9,23 @@ MASTER_SITES= http://stosberg.net/odt2txt/ \
ftp://ftp.renatasystems.org/pub/FreeBSD/ports/distfiles/
MAINTAINER= alexey@renatasystems.org
-COMMENT= A simple converter from OpenDocument Text to plain text
+COMMENT= Simple converter from OpenDocument Text to plain text
LICENSE= GPLv2
-USE_GMAKE= yes
-USES= iconv
+USES= iconv gmake
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-PLIST_FILES= bin/odt2txt
-
-MAN1= odt2txt.1
+PLIST_FILES= bin/odt2txt man/man1/odt2txt.1.gz
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e 's#/usr/local#${LOCALBASE}#g' \
-e 's#-liconv#${ICONV_LIB}#' ${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/odt2txt ${PREFIX}/bin/odt2txt
- ${INSTALL_MAN} ${WRKSRC}/odt2txt.1 ${MANPREFIX}/man/man1/odt2txt.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/odt2txt ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/odt2txt.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>