aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorbarner <barner@FreeBSD.org>2005-06-02 17:48:10 +0800
committerbarner <barner@FreeBSD.org>2005-06-02 17:48:10 +0800
commit497b2275739f81032fb432f89315aa5c29c0fc0b (patch)
tree5cacada54eec3f5fc4bbb7fe918e7a14a966d05b /textproc
parent209f1d2044ff171f061acff4f95457e009dc8b95 (diff)
downloadfreebsd-ports-graphics-497b2275739f81032fb432f89315aa5c29c0fc0b.tar.gz
freebsd-ports-graphics-497b2275739f81032fb432f89315aa5c29c0fc0b.tar.zst
freebsd-ports-graphics-497b2275739f81032fb432f89315aa5c29c0fc0b.zip
Add p5-Bloom-Filter 0.03,
a probabilistic algorithm for doing existence tests. PR: 70062 Submitted by: Aaron Straup Cope <ascope@cpan.org>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Bloom-Filter/Makefile34
-rw-r--r--textproc/p5-Bloom-Filter/distinfo2
-rw-r--r--textproc/p5-Bloom-Filter/pkg-descr5
-rw-r--r--textproc/p5-Bloom-Filter/pkg-plist5
5 files changed, 47 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 3c371435200..862194b4878 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -269,6 +269,7 @@
SUBDIR += or-aspell
SUBDIR += p5-Apache-ParseLog
SUBDIR += p5-Apache-XBEL
+ SUBDIR += p5-Bloom-Filter
SUBDIR += p5-CSS-SAC
SUBDIR += p5-CSS-Tiny
SUBDIR += p5-Data-FormValidator
diff --git a/textproc/p5-Bloom-Filter/Makefile b/textproc/p5-Bloom-Filter/Makefile
new file mode 100644
index 00000000000..a23c90da427
--- /dev/null
+++ b/textproc/p5-Bloom-Filter/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Bloom-Filter
+# Date created: August 06, 2004
+# Whom: Aaron Straup Cope <ascope@cpan.org>
+#
+# $FreeBSD$
+#
+
+# Bloom::Filter.pm is not part of the standard
+# MASTER_SITES tree due to unresolved namespace
+# issues
+
+PORTNAME= Bloom-Filter
+PORTVERSION= 0.03
+CATEGORIES= textproc perl5
+MASTER_SITES= http://www.cpan.org/authors/id/M/MC/MCEGLOWS/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ascope@cpan.org
+COMMENT= A probabilistic algorithm for doing existence tests
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Bloom::Filter.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= "requires Perl 5.6 or above"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Bloom-Filter/distinfo b/textproc/p5-Bloom-Filter/distinfo
new file mode 100644
index 00000000000..8a62370f598
--- /dev/null
+++ b/textproc/p5-Bloom-Filter/distinfo
@@ -0,0 +1,2 @@
+MD5 (Bloom-Filter-0.03.tar.gz) = 3df62a97e96392d0bef7e0bfaf04b583
+SIZE (Bloom-Filter-0.03.tar.gz) = 4415
diff --git a/textproc/p5-Bloom-Filter/pkg-descr b/textproc/p5-Bloom-Filter/pkg-descr
new file mode 100644
index 00000000000..6654f664169
--- /dev/null
+++ b/textproc/p5-Bloom-Filter/pkg-descr
@@ -0,0 +1,5 @@
+A Bloom filter is a probabilistic algorithm for doing existence tests
+in less memory than a full list of keys would require. The tradeoff to
+using Bloom filters is a certain configurable risk of false positives.
+
+WWW: http://search.cpan.org/dist/Bloom-Filter
diff --git a/textproc/p5-Bloom-Filter/pkg-plist b/textproc/p5-Bloom-Filter/pkg-plist
new file mode 100644
index 00000000000..3c6cc5f2f4e
--- /dev/null
+++ b/textproc/p5-Bloom-Filter/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Bloom/Filter.pm
+@unexec rmdir %D/%%SITE_PERL%%/Bloom 2>/dev/null || true
+%%SITE_PERL%%/mach/auto/Bloom/Filter/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/mach/auto/Bloom/Filter 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/mach/auto/Bloom 2>/dev/null || true