aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2016-08-23 19:10:11 +0800
committerolgeni <olgeni@FreeBSD.org>2016-08-23 19:10:11 +0800
commit5eac8597faa044af708c2374e7e6ec085d7d8798 (patch)
tree35a48c11303b3d98d22f57676d72aad6d4a6f74a /textproc
parent07a98bb3cb436d61df56bd089da9dfc72dbe1f47 (diff)
downloadfreebsd-ports-graphics-5eac8597faa044af708c2374e7e6ec085d7d8798.tar.gz
freebsd-ports-graphics-5eac8597faa044af708c2374e7e6ec085d7d8798.tar.zst
freebsd-ports-graphics-5eac8597faa044af708c2374e7e6ec085d7d8798.zip
Add textproc/erlang-fast_xml, an XML parsing and manipulation library
for Erlang. (requires erlang.mk from r420660)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/erlang-fast_xml/Makefile28
-rw-r--r--textproc/erlang-fast_xml/distinfo3
-rw-r--r--textproc/erlang-fast_xml/files/patch-rebar.config11
-rw-r--r--textproc/erlang-fast_xml/pkg-descr4
-rw-r--r--textproc/erlang-fast_xml/pkg-plist24
6 files changed, 71 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 21440b87c10..9004826e5e7 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -173,6 +173,7 @@
SUBDIR += eo-aspell
SUBDIR += eqe
SUBDIR += erlang-edown
+ SUBDIR += erlang-fast_xml
SUBDIR += erlang-p1_utils
SUBDIR += erlang-p1xml
SUBDIR += erlang-yamerl
diff --git a/textproc/erlang-fast_xml/Makefile b/textproc/erlang-fast_xml/Makefile
new file mode 100644
index 00000000000..69a434d7538
--- /dev/null
+++ b/textproc/erlang-fast_xml/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= fast_xml
+PORTVERSION= 1.1.15
+CATEGORIES= textproc
+PKGNAMEPREFIX= erlang-
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= Erlang XML parsing and manipulation library
+
+LICENSE= APACHE20
+
+LIB_DEPENDS= libexpat.so:textproc/expat2
+
+USES= erlang:rebar
+USE_GITHUB= yes
+GH_ACCOUNT= processone
+
+ERL_BUILD_DEPS= textproc/erlang-p1_utils
+ERL_RUN_DEPS:= ${ERL_BUILD_DEPS}
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -l expat
+
+pre-install:
+ ${STRIP_CMD} ${WRKSRC}/priv/lib/*.so
+
+.include <bsd.port.mk>
diff --git a/textproc/erlang-fast_xml/distinfo b/textproc/erlang-fast_xml/distinfo
new file mode 100644
index 00000000000..a7f1e279219
--- /dev/null
+++ b/textproc/erlang-fast_xml/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1471945280
+SHA256 (processone-fast_xml-1.1.15_GH0.tar.gz) = 3cab1d45b67ae9f703e51480a4607f670caafede6fbdb4126e94a34b56a381f5
+SIZE (processone-fast_xml-1.1.15_GH0.tar.gz) = 86948
diff --git a/textproc/erlang-fast_xml/files/patch-rebar.config b/textproc/erlang-fast_xml/files/patch-rebar.config
new file mode 100644
index 00000000000..1857ebadd57
--- /dev/null
+++ b/textproc/erlang-fast_xml/files/patch-rebar.config
@@ -0,0 +1,11 @@
+--- rebar.config.orig 2016-08-23 10:16:49 UTC
++++ rebar.config
+@@ -25,7 +25,7 @@
+ {port_specs, [{"priv/lib/fxml.so", ["c_src/fxml.c"]},
+ {"priv/lib/fxml_stream.so", ["c_src/fxml_stream.c"]}]}.
+
+-{deps, [{p1_utils, ".*", {git, "https://github.com/processone/p1_utils", {tag, "1.0.5"}}}]}.
++{deps, []}.
+
+ {clean_files, ["c_src/fxml.gcda", "c_src/fxml.gcno", "c_src/fxml_stream.gcda", "c_src/fxml_stream.gcno"]}.
+
diff --git a/textproc/erlang-fast_xml/pkg-descr b/textproc/erlang-fast_xml/pkg-descr
new file mode 100644
index 00000000000..71d2d71edec
--- /dev/null
+++ b/textproc/erlang-fast_xml/pkg-descr
@@ -0,0 +1,4 @@
+Fast Expat based Erlang XML parsing library, with a strong focus
+on XML stream parsing from network.
+
+WWW: https://github.com/processone/fast_xml
diff --git a/textproc/erlang-fast_xml/pkg-plist b/textproc/erlang-fast_xml/pkg-plist
new file mode 100644
index 00000000000..f97d8d8cdec
--- /dev/null
+++ b/textproc/erlang-fast_xml/pkg-plist
@@ -0,0 +1,24 @@
+lib/erlang/lib/fast_xml-%%VERSION%%/ebin/fast_xml.app
+lib/erlang/lib/fast_xml-%%VERSION%%/ebin/fast_xml.beam
+lib/erlang/lib/fast_xml-%%VERSION%%/ebin/fxml.beam
+lib/erlang/lib/fast_xml-%%VERSION%%/ebin/fxml_gen.beam
+lib/erlang/lib/fast_xml-%%VERSION%%/ebin/fxml_gen_pt.beam
+lib/erlang/lib/fast_xml-%%VERSION%%/ebin/fxml_stream.beam
+lib/erlang/lib/fast_xml-%%VERSION%%/ebin/fxml_sup.beam
+lib/erlang/lib/fast_xml-%%VERSION%%/ebin/fxmlrpc.beam
+lib/erlang/lib/fast_xml-%%VERSION%%/ebin/fxmlrpc_codec.beam
+lib/erlang/lib/fast_xml-%%VERSION%%/include/fxml.hrl
+lib/erlang/lib/fast_xml-%%VERSION%%/include/fxml_gen.hrl
+lib/erlang/lib/fast_xml-%%VERSION%%/priv/lib/.keepme
+lib/erlang/lib/fast_xml-%%VERSION%%/priv/lib/fxml.so
+lib/erlang/lib/fast_xml-%%VERSION%%/priv/lib/fxml_stream.so
+lib/erlang/lib/fast_xml-%%VERSION%%/src/fast_xml.app.src
+lib/erlang/lib/fast_xml-%%VERSION%%/src/fast_xml.erl
+lib/erlang/lib/fast_xml-%%VERSION%%/src/fxml.erl
+lib/erlang/lib/fast_xml-%%VERSION%%/src/fxml_gen.erl
+lib/erlang/lib/fast_xml-%%VERSION%%/src/fxml_gen_pt.erl
+lib/erlang/lib/fast_xml-%%VERSION%%/src/fxml_stream.erl
+lib/erlang/lib/fast_xml-%%VERSION%%/src/fxml_sup.erl
+lib/erlang/lib/fast_xml-%%VERSION%%/src/fxmlrpc.erl
+lib/erlang/lib/fast_xml-%%VERSION%%/src/fxmlrpc_codec.erl
+%%PORTDOCS%%%%DOCSDIR%%/README.md