aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2002-11-04 11:17:29 +0800
committeredwin <edwin@FreeBSD.org>2002-11-04 11:17:29 +0800
commit690d5eb77dfe38a8ae1bee0d3c26e53669d15fcd (patch)
tree2cdd4a2b9a4f727046ab669be268f18bab7f2d42 /textproc
parent266a6d44cdb9993738dffb2c3b706a6ca59eeb36 (diff)
downloadfreebsd-ports-graphics-690d5eb77dfe38a8ae1bee0d3c26e53669d15fcd.tar.gz
freebsd-ports-graphics-690d5eb77dfe38a8ae1bee0d3c26e53669d15fcd.tar.zst
freebsd-ports-graphics-690d5eb77dfe38a8ae1bee0d3c26e53669d15fcd.zip
PERL -> REINPLACE
and USE_PERL5 in some places Noticed by: bento
Diffstat (limited to 'textproc')
-rw-r--r--textproc/dadadodo/Makefile4
-rw-r--r--textproc/mguesser/Makefile4
-rw-r--r--textproc/tclExpat/Makefile3
-rw-r--r--textproc/ua-ispell/Makefile1
4 files changed, 9 insertions, 3 deletions
diff --git a/textproc/dadadodo/Makefile b/textproc/dadadodo/Makefile
index 1a20c5755df..7937a016555 100644
--- a/textproc/dadadodo/Makefile
+++ b/textproc/dadadodo/Makefile
@@ -12,8 +12,10 @@ MASTER_SITES= http://www.jwz.org/dadadodo/
MAINTAINER= markp@FreeBSD.org
+USE_REINPLACE= yes
+
pre-patch:
- ${PERL} -pi -e "s/^(CC|CFLAGS).+//" ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e "s/^(CC|CFLAGS).+//" ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dadadodo ${PREFIX}/bin
diff --git a/textproc/mguesser/Makefile b/textproc/mguesser/Makefile
index e59965a4172..29b5e27966b 100644
--- a/textproc/mguesser/Makefile
+++ b/textproc/mguesser/Makefile
@@ -15,9 +15,11 @@ MAINTAINER= markp@FreeBSD.org
WRKSRC= ${WRKDIR}/guesser
CFLAGS+= -DUDM_GUESSER_STANDALONG -DLMDIR=\"${PREFIX}/share/mguesser\"
MAKE_ENV+= CFLAGS="${$CFLAGS}"
+USE_REINPLACE= yes
post-patch:
- ${PERL} -pi -e "s/^CC=.+//g; s|^CFLAGS=|CFLAGS+=|g; s|-Wall -g||g; \
+ ${REINPLACE_CMD} -e \
+ "s/^CC=.+//g; s|^CFLAGS=|CFLAGS+=|g; s|-Wall -g||g; \
s|./maps|${PREFIX}/share/mguesser|g" ${WRKSRC}/Makefile
do-install:
diff --git a/textproc/tclExpat/Makefile b/textproc/tclExpat/Makefile
index eed7a6e8aa8..5ceef9f244a 100644
--- a/textproc/tclExpat/Makefile
+++ b/textproc/tclExpat/Makefile
@@ -17,6 +17,7 @@ LIB_DEPENDS= tcl${TCL_DVER}:${PORTSDIR}/lang/tcl${TCL_DVER} \
expat.4:${PORTSDIR}/textproc/expat2
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
TCL_VERSION= 8.3
TCL_DVER= ${TCL_VERSION:S/.//}
@@ -29,7 +30,7 @@ post-extract:
${RM} -rf ${WRKSRC}/expat
post-patch:
- ${PERL} -pi -e 's/TCL_MAJOR_VERSION == 8 && TCL_MINOR_VERSION == 0/TCL_MAJOR_VERSION >= 8/;' \
+ ${REINPLACE_CMD} -e 's/TCL_MAJOR_VERSION == 8 && TCL_MINOR_VERSION == 0/TCL_MAJOR_VERSION >= 8/;' \
-e 's/xmlparse.h/expat.h/;' ${WRKSRC}/tclexpat.c
test: build
diff --git a/textproc/ua-ispell/Makefile b/textproc/ua-ispell/Makefile
index 7639bd636a7..701d21e4982 100644
--- a/textproc/ua-ispell/Makefile
+++ b/textproc/ua-ispell/Makefile
@@ -18,6 +18,7 @@ BUILD_DEPENDS= buildhash:${PORTSDIR}/textproc/ispell
USE_BZIP2= YES
ALL_TARGET= koi
USE_GMAKE= YES
+USE_PERL5= yes
# Still need gmake for other reasons :-\
#post-patch: