aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authortj <tj@FreeBSD.org>2015-12-16 01:06:11 +0800
committertj <tj@FreeBSD.org>2015-12-16 01:06:11 +0800
commit7b82cf6b46e845cc1e059a277f6c415665fb745c (patch)
tree0936d945f9117ca87084e2b3cb289917f0a78293 /textproc
parente7ec648acdd0c23e8083adeb2ae97f27297dcb82 (diff)
downloadfreebsd-ports-graphics-7b82cf6b46e845cc1e059a277f6c415665fb745c.tar.gz
freebsd-ports-graphics-7b82cf6b46e845cc1e059a277f6c415665fb745c.tar.zst
freebsd-ports-graphics-7b82cf6b46e845cc1e059a277f6c415665fb745c.zip
Update to 2.1.
Changes: https://www.elastic.co/guide/en/elasticsearch/reference/2.1/release-notes-2.1.0.html - Fix path to allow service to start at boot - Misc cleanup from ohauer PR: 195861, 204821, 204902, 204910
Diffstat (limited to 'textproc')
-rw-r--r--textproc/elasticsearch2/Makefile65
-rw-r--r--textproc/elasticsearch2/distinfo4
-rw-r--r--textproc/elasticsearch2/files/patch-bin-elasticsearch.in.sh11
-rw-r--r--textproc/elasticsearch2/pkg-descr2
-rw-r--r--textproc/elasticsearch2/pkg-plist17
5 files changed, 32 insertions, 67 deletions
diff --git a/textproc/elasticsearch2/Makefile b/textproc/elasticsearch2/Makefile
index 9e9daae93a5..04b5eabbcde 100644
--- a/textproc/elasticsearch2/Makefile
+++ b/textproc/elasticsearch2/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= elasticsearch
-PORTVERSION= 2.0.0
+PORTVERSION= 2.1.0
CATEGORIES= textproc java devel
MASTER_SITES= http://download.elasticsearch.org/${PORTNAME}/${PORTNAME}/ \
http://mirrors.rit.edu/zi/
@@ -26,48 +26,8 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-LUCENEVER= 5.2.1
+LUCENEVER= 5.3.1
CONFIG_FILES= elasticsearch.yml logging.yml
-JARS= elasticsearch-${PORTVERSION}.jar \
- HdrHistogram-2.1.6.jar \
- antlr-runtime-3.5.jar \
- apache-log4j-extras-1.2.17.jar \
- asm-4.1.jar \
- asm-commons-4.1.jar \
- commons-cli-1.3.1.jar \
- compiler-0.8.13.jar \
- compress-lzf-1.0.2.jar \
- groovy-all-2.4.4-indy.jar \
- guava-18.0.jar \
- hppc-0.7.1.jar \
- jackson-core-2.5.3.jar \
- jackson-dataformat-cbor-2.5.3.jar \
- jackson-dataformat-smile-2.5.3.jar \
- jackson-dataformat-yaml-2.5.3.jar \
- jna-4.1.0.jar \
- joda-convert-1.2.jar \
- joda-time-2.8.2.jar \
- jsr166e-1.1.0.jar \
- jts-1.13.jar \
- log4j-1.2.17.jar \
- lucene-analyzers-common-${LUCENEVER}.jar \
- lucene-backward-codecs-${LUCENEVER}.jar \
- lucene-core-${LUCENEVER}.jar \
- lucene-expressions-${LUCENEVER}.jar \
- lucene-grouping-${LUCENEVER}.jar \
- lucene-highlighter-${LUCENEVER}.jar \
- lucene-join-${LUCENEVER}.jar \
- lucene-memory-${LUCENEVER}.jar \
- lucene-misc-${LUCENEVER}.jar \
- lucene-queries-${LUCENEVER}.jar \
- lucene-queryparser-${LUCENEVER}.jar \
- lucene-sandbox-${LUCENEVER}.jar \
- lucene-spatial-${LUCENEVER}.jar \
- lucene-suggest-${LUCENEVER}.jar \
- netty-3.10.5.Final.jar \
- snakeyaml-1.12.jar \
- spatial4j-0.4.1.jar \
- t-digest-3.0.jar
BINS= elasticsearch.in.sh \
elasticsearch \
plugin
@@ -96,25 +56,25 @@ PLIST_SUB= SEARCHUSER=${SEARCHUSER} \
ELASTIC_LOGDIR=${ELASTIC_LOGDIR}
post-patch:
- ${SED} -i .bak -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/config/elasticsearch.yml
- ${SED} -i .bak -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/bin/elasticsearch.in.sh
+ ${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/config/elasticsearch.yml
+ ${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/bin/elasticsearch.in.sh
do-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/etc/elasticsearch
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/elasticsearch
.for f in ${CONFIG_FILES}
${INSTALL} -m 440 ${WRKSRC}/config/${f} ${STAGEDIR}${ETCDIR}/${f}.sample
.endfor
- ${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/bin
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/bin
.for f in ${BINS}
${INSTALL_SCRIPT} ${WRKSRC}/bin/${f} ${STAGEDIR}${PREFIX}/lib/elasticsearch/bin
.endfor
- ${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/lib
-.for f in ${JARS}
- ${INSTALL_DATA} ${WRKSRC}/lib/${f} ${STAGEDIR}${PREFIX}/lib/elasticsearch/lib
-.endfor
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/lib
+ (cd ${WRKSRC}/lib && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/lib/elasticsearch/lib/ "-name *\.jar")
- ${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/plugins
- ${MKDIR} ${STAGEDIR}${PREFIX}/libexec/elasticsearch
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/plugins
+ @${MKDIR} ${STAGEDIR}${PREFIX}/libexec/elasticsearch
+ @${MKDIR} ${STAGEDIR}${ELASTIC_DBDIR} ${STAGEDIR}${ELASTIC_LOGDIR}
+ cd ${STAGEDIR}${PREFIX}/bin && ${LN} -s ${PREFIX}/lib/elasticsearch/bin/plugin elasticsearch-plugin
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@@ -122,6 +82,5 @@ do-install-DOCS-on:
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
- cd ${STAGEDIR}${PREFIX}/bin && ${LN} -s ${PREFIX}/lib/elasticsearch/bin/plugin elasticsearch-plugin
.include <bsd.port.mk>
diff --git a/textproc/elasticsearch2/distinfo b/textproc/elasticsearch2/distinfo
index 75867aab0c0..81fe8e58ce3 100644
--- a/textproc/elasticsearch2/distinfo
+++ b/textproc/elasticsearch2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (elasticsearch-2.0.0.tar.gz) = b25f13f615337c2072964fd9fc5c7250f8a2a983b22198daf93548285d5d16df
-SIZE (elasticsearch-2.0.0.tar.gz) = 28576708
+SHA256 (elasticsearch-2.1.0.tar.gz) = 8a4e85bcb506daa369651506af1cbc55c09fd7ff387d111142ae14d0a85d4d14
+SIZE (elasticsearch-2.1.0.tar.gz) = 28994631
diff --git a/textproc/elasticsearch2/files/patch-bin-elasticsearch.in.sh b/textproc/elasticsearch2/files/patch-bin-elasticsearch.in.sh
index ccc1f18eb10..090e678c0d3 100644
--- a/textproc/elasticsearch2/files/patch-bin-elasticsearch.in.sh
+++ b/textproc/elasticsearch2/files/patch-bin-elasticsearch.in.sh
@@ -1,6 +1,6 @@
---- bin/elasticsearch.in.sh.orig 2015-11-19 16:02:28.386051810 -0500
-+++ bin/elasticsearch.in.sh 2015-11-19 16:02:56.618049877 -0500
-@@ -1,5 +1,19 @@
+--- bin/elasticsearch.in.sh.orig 2015-10-21 04:41:12.000000000 -0400
++++ bin/elasticsearch.in.sh 2015-12-15 12:00:37.323441838 -0500
+@@ -1,5 +1,20 @@
#!/bin/sh
+if [ `uname -o` == "FreeBSD" ]; then
@@ -13,8 +13,9 @@
+ ES_USE_IPV4=${elasticsearch_use_ipv4}
+ ES_GC_OPTS=${elasticsearch_gc_opts}
+ ES_GC_LOG_FILE=${elasticsearch_gc_logfile}
-+ JAVA_OPTS="$JAVA_OPTS -Des.path.conf=${elasticsearch_config:="%%PREFIX%%/etc/elasticsearch"}"
-+ JAVA_OPTS="$JAVA_OPTS -Des.path.scripts=${elasticsearch_scripts:="%%PREFIX%%/libexec/elasticsearch"}"
++ JAVA_OPTS="$JAVA_OPTS -Des.path.conf=${elasticsearch_config:="/usr/local/etc/elasticsearch"}"
++ JAVA_OPTS="$JAVA_OPTS -Des.path.scripts=${elasticsearch_scripts:="/usr/local/libexec/elasticsearch"}"
++ PATH=${PATH}:/usr/local/bin
+fi
+
# check in case a user was using this mechanism
diff --git a/textproc/elasticsearch2/pkg-descr b/textproc/elasticsearch2/pkg-descr
index a4d6442315f..0eb44650711 100644
--- a/textproc/elasticsearch2/pkg-descr
+++ b/textproc/elasticsearch2/pkg-descr
@@ -1,4 +1,4 @@
Elasticsearch aims to be a Distributed, RESTful, Search Engine built on top of
Apache Lucene.
-WWW: http://www.elasticsearch.org/
+WWW: http://www.elastic.co/
diff --git a/textproc/elasticsearch2/pkg-plist b/textproc/elasticsearch2/pkg-plist
index 7649a867497..625d0be050a 100644
--- a/textproc/elasticsearch2/pkg-plist
+++ b/textproc/elasticsearch2/pkg-plist
@@ -15,10 +15,10 @@ lib/elasticsearch/lib/elasticsearch-%%PORTVERSION%%.jar
lib/elasticsearch/lib/groovy-all-2.4.4-indy.jar
lib/elasticsearch/lib/guava-18.0.jar
lib/elasticsearch/lib/hppc-0.7.1.jar
-lib/elasticsearch/lib/jackson-core-2.5.3.jar
-lib/elasticsearch/lib/jackson-dataformat-cbor-2.5.3.jar
-lib/elasticsearch/lib/jackson-dataformat-smile-2.5.3.jar
-lib/elasticsearch/lib/jackson-dataformat-yaml-2.5.3.jar
+lib/elasticsearch/lib/jackson-core-2.6.2.jar
+lib/elasticsearch/lib/jackson-dataformat-cbor-2.6.2.jar
+lib/elasticsearch/lib/jackson-dataformat-smile-2.6.2.jar
+lib/elasticsearch/lib/jackson-dataformat-yaml-2.6.2.jar
lib/elasticsearch/lib/jna-4.1.0.jar
lib/elasticsearch/lib/joda-convert-1.2.jar
lib/elasticsearch/lib/joda-time-2.8.2.jar
@@ -38,10 +38,11 @@ lib/elasticsearch/lib/lucene-queries-%%LUCENEVER%%.jar
lib/elasticsearch/lib/lucene-queryparser-%%LUCENEVER%%.jar
lib/elasticsearch/lib/lucene-sandbox-%%LUCENEVER%%.jar
lib/elasticsearch/lib/lucene-spatial-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-spatial3d-%%LUCENEVER%%.jar
lib/elasticsearch/lib/lucene-suggest-%%LUCENEVER%%.jar
lib/elasticsearch/lib/netty-3.10.5.Final.jar
-lib/elasticsearch/lib/snakeyaml-1.12.jar
-lib/elasticsearch/lib/spatial4j-0.4.1.jar
+lib/elasticsearch/lib/snakeyaml-1.15.jar
+lib/elasticsearch/lib/spatial4j-0.5.jar
lib/elasticsearch/lib/t-digest-3.0.jar
lib/elasticsearch/bin/elasticsearch.in.sh
lib/elasticsearch/bin/elasticsearch
@@ -54,3 +55,7 @@ lib/elasticsearch/bin/plugin
@dir lib/elasticsearch/plugins
@dir lib/elasticsearch
@dir libexec/elasticsearch
+@dir(%%SEARCHUSER%%,%%SEARCHGROUP%%,750) %%ELASTIC_LOGDIR%%
+@dir(%%SEARCHUSER%%,%%SEARCHGROUP%%,750) %%ELASTIC_DBDIR%%
+@postunexec if [ -d %%ELASTIC_LOGDIR%% ]; then echo "You should remove %%ELASTIC_LOGDIR%% if you don't need it any more."; fi
+@postunexec if [ -d %%ELASTIC_DBDIR%% ]; then echo "You should remove %%ELASTIC_DBDIR%% if you don't need it any more."; fi