aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2012-03-16 10:47:11 +0800
committerswills <swills@FreeBSD.org>2012-03-16 10:47:11 +0800
commit86705b6c99ad2dc802e544892105f0f40f556f86 (patch)
tree45dc9f94e6ff3e543d903f13ecdb859a97babfc9 /textproc
parent592760e7abf2f93d50cfcb33999728104adf9016 (diff)
downloadfreebsd-ports-graphics-86705b6c99ad2dc802e544892105f0f40f556f86.tar.gz
freebsd-ports-graphics-86705b6c99ad2dc802e544892105f0f40f556f86.tar.zst
freebsd-ports-graphics-86705b6c99ad2dc802e544892105f0f40f556f86.zip
- Patches to fix tests
- Bump PORTREVISION Submitted by: rflynn@acsalaska.net (via irc) Feature safe: yes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/p5-Text-Unaccent/Makefile2
-rw-r--r--textproc/p5-Text-Unaccent/files/patch-Unaccent.xs11
-rw-r--r--textproc/p5-Text-Unaccent/files/patch-unac.c15
3 files changed, 28 insertions, 0 deletions
diff --git a/textproc/p5-Text-Unaccent/Makefile b/textproc/p5-Text-Unaccent/Makefile
index f9bd3ce96b5..75450eebb66 100644
--- a/textproc/p5-Text-Unaccent/Makefile
+++ b/textproc/p5-Text-Unaccent/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Text-Unaccent
PORTVERSION= 1.08
+PORTREVISION= 1
CATEGORIES= textproc perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -18,5 +19,6 @@ MAN3= Text::Unaccent.3
USE_ICONV= yes
PERL_CONFIGURE= yes
+CFLAGS+= -DICONV_CONST=const
.include <bsd.port.mk>
diff --git a/textproc/p5-Text-Unaccent/files/patch-Unaccent.xs b/textproc/p5-Text-Unaccent/files/patch-Unaccent.xs
new file mode 100644
index 00000000000..38aeb4c0fce
--- /dev/null
+++ b/textproc/p5-Text-Unaccent/files/patch-Unaccent.xs
@@ -0,0 +1,11 @@
+--- Unaccent.xs.orig 2004-12-29 02:45:18.000000000 -0900
++++ Unaccent.xs 2012-03-15 17:04:26.000000000 -0800
+@@ -35,7 +35,7 @@
+ #include "unac.h"
+
+ static char* buffer;
+-static int buffer_length;
++static size_t buffer_length;
+
+ static void unac_debug_print(const char* message, void* data)
+ {
diff --git a/textproc/p5-Text-Unaccent/files/patch-unac.c b/textproc/p5-Text-Unaccent/files/patch-unac.c
new file mode 100644
index 00000000000..67cceacea89
--- /dev/null
+++ b/textproc/p5-Text-Unaccent/files/patch-unac.c
@@ -0,0 +1,15 @@
+--- unac.c.orig 2004-10-17 11:00:36.000000000 -0800
++++ unac.c 2012-03-15 16:55:01.042386000 -0800
+@@ -13881,10 +13881,10 @@
+ *out_lengthp = 0;
+ } else {
+ char* utf16 = 0;
+- int utf16_length = 0;
+ char* utf16_unaccented = 0;
+- int utf16_unaccented_length = 0;
++ size_t utf16_length, utf16_unaccented_length;
+
++ utf16_length = utf16_unaccented_length = 0;
+ if(convert(charset, utf16be(), in, in_length, &utf16, &utf16_length) < 0) {
+ return -1;
+ }