aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2007-04-21 05:13:41 +0800
committersobomax <sobomax@FreeBSD.org>2007-04-21 05:13:41 +0800
commit9e7510b9a1299479907cbb3b0ba6b82811385018 (patch)
treea59538600c5abdbc66799459161fdf0e34409f5e /textproc
parent1a251172a3915541edbd0ee33f9d241f8cb37868 (diff)
downloadfreebsd-ports-graphics-9e7510b9a1299479907cbb3b0ba6b82811385018.tar.gz
freebsd-ports-graphics-9e7510b9a1299479907cbb3b0ba6b82811385018.tar.zst
freebsd-ports-graphics-9e7510b9a1299479907cbb3b0ba6b82811385018.zip
This package doesn't really require X11 or Motif.
Make it respecting CFLAGS while I am here.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/pdftohtml/Makefile2
-rw-r--r--textproc/pdftohtml/files/patch-fofi::Makefile14
-rw-r--r--textproc/pdftohtml/files/patch-splash::Makefile14
-rw-r--r--textproc/pdftohtml/files/patch-src::Makefile14
4 files changed, 43 insertions, 1 deletions
diff --git a/textproc/pdftohtml/Makefile b/textproc/pdftohtml/Makefile
index fbd5f06c246..9e142fb76e0 100644
--- a/textproc/pdftohtml/Makefile
+++ b/textproc/pdftohtml/Makefile
@@ -8,6 +8,7 @@
PORTNAME= pdftohtml
PORTVERSION= 0.39
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,7 +18,6 @@ COMMENT= A command-line tool for converting pdf-files into html
USE_GHOSTSCRIPT_RUN= yes
USE_GMAKE= yes
-USE_MOTIF= yes
PLIST_FILES= bin/pdftohtml
diff --git a/textproc/pdftohtml/files/patch-fofi::Makefile b/textproc/pdftohtml/files/patch-fofi::Makefile
new file mode 100644
index 00000000000..da7cee0ad0d
--- /dev/null
+++ b/textproc/pdftohtml/files/patch-fofi::Makefile
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- fofi/Makefile
++++ fofi/Makefile
+@@ -14,7 +14,7 @@
+ GOOSRCDIR = $(srcdir)/../goo
+ GOOLIBDIR = ../goo
+
+-CXXFLAGS = -DHAVE_CONFIG_H -I.. -I$(GOOSRCDIR) -I$(srcdir)
++CXXFLAGS += -DHAVE_CONFIG_H -I.. -I$(GOOSRCDIR) -I$(srcdir)
+
+ CXX = g++
+ AR = ar rc
diff --git a/textproc/pdftohtml/files/patch-splash::Makefile b/textproc/pdftohtml/files/patch-splash::Makefile
new file mode 100644
index 00000000000..b868bc8a84d
--- /dev/null
+++ b/textproc/pdftohtml/files/patch-splash::Makefile
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- splash/Makefile
++++ splash/Makefile
+@@ -16,7 +16,7 @@
+ FOFISRCDIR = $(srcdir)/../fofi
+ FOFILIBDIR = ../fofi
+
+-CXXFLAGS = -DHAVE_CONFIG_H -I.. -I$(GOOSRCDIR) -I$(FOFISRCDIR) -I$(srcdir)
++CXXFLAGS += -DHAVE_CONFIG_H -I.. -I$(GOOSRCDIR) -I$(FOFISRCDIR) -I$(srcdir)
+
+ CXX = g++
+ AR = ar rc
diff --git a/textproc/pdftohtml/files/patch-src::Makefile b/textproc/pdftohtml/files/patch-src::Makefile
new file mode 100644
index 00000000000..d3ba7fb85d0
--- /dev/null
+++ b/textproc/pdftohtml/files/patch-src::Makefile
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/Makefile
++++ src/Makefile
+@@ -11,7 +11,7 @@
+ SPLASHSRCDIR = ../splash
+ SPLASHLIBDIR = ../splash
+
+-CXXFLAGS = -DHAVE_CONFIG_H -DHAVE_DIRENT_H=1 -I.. -DHAVE_REWINDDIR=1 -DHAVE_POPEN=1 -I.. -I$(GOOSRCDIR) -I$(XPDFSRCDIR) -I$(FOFISRCDIR) -I$(SPLASHSRCDIR) -I$(srcdir) -I/usr/X11R6/include
++CXXFLAGS += -DHAVE_CONFIG_H -DHAVE_DIRENT_H=1 -I.. -DHAVE_REWINDDIR=1 -DHAVE_POPEN=1 -I.. -I$(GOOSRCDIR) -I$(XPDFSRCDIR) -I$(FOFISRCDIR) -I$(SPLASHSRCDIR) -I$(srcdir) -I/usr/X11R6/include
+
+ LDFLAGS =
+