aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorkmoore <kmoore@FreeBSD.org>2015-09-12 21:36:35 +0800
committerkmoore <kmoore@FreeBSD.org>2015-09-12 21:36:35 +0800
commita5008d926b2def1f6547ef90a3f7e6f78d5ec17b (patch)
treedc08ec0c757d01ec871eb6b7b33007401651f3dc /textproc
parentf3e62043630153d0e53af92d68ac8fbf6ed75a10 (diff)
downloadfreebsd-ports-graphics-a5008d926b2def1f6547ef90a3f7e6f78d5ec17b.tar.gz
freebsd-ports-graphics-a5008d926b2def1f6547ef90a3f7e6f78d5ec17b.tar.zst
freebsd-ports-graphics-a5008d926b2def1f6547ef90a3f7e6f78d5ec17b.zip
This is a Sphinx package for autonumbering figures. With numfig you can
have numbered figures in your Sphinx documents and refer to them by number. WWW: https://bitbucket.org/arjones6/sphinx-numfig/wiki/Home
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-sphinx_numfig/Makefile27
-rw-r--r--textproc/py-sphinx_numfig/distinfo2
-rw-r--r--textproc/py-sphinx_numfig/files/patch-setup.py20
-rw-r--r--textproc/py-sphinx_numfig/pkg-descr4
5 files changed, 54 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 0eeeb54541f..5c5a6131795 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1260,6 +1260,7 @@
SUBDIR += py-sphinx
SUBDIR += py-sphinx-intl
SUBDIR += py-sphinx_rtd_theme
+ SUBDIR += py-sphinx_numfig
SUBDIR += py-sphinxcontrib-adadomain
SUBDIR += py-sphinxcontrib-bitbucket
SUBDIR += py-sphinxcontrib-httpdomain
diff --git a/textproc/py-sphinx_numfig/Makefile b/textproc/py-sphinx_numfig/Makefile
new file mode 100644
index 00000000000..3abb74783d4
--- /dev/null
+++ b/textproc/py-sphinx_numfig/Makefile
@@ -0,0 +1,27 @@
+# Created by: Dru Lavigne <dru@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= sphinx_numfig
+PORTVERSION= r13
+CATEGORIES= textproc
+MASTER_SITES= http://sourceforge.net/projects/numfig/files/latest/download/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= kris@FreeBSD.org
+COMMENT= Autonumbering figures in Sphinx
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PKGNAMEPREFIX}sphinx>=1.3.1:${PORTSDIR}/textproc/py-sphinx
+
+USES= python tar:tgz
+NO_BUILD= yes
+SPHINXDIR= ${PYTHON_LIBDIR}/site-packages/sphinx
+PLIST_FILES= ${SPHINXDIR}/ext/numfig.py ${SPHINXDIR}/ext/numfig.pyc
+
+do-install:
+ cd ${WRKDIR}/sphinx_numfig-r13 && \
+ ${MKDIR} ${STAGEDIR}${SPHINXDIR}/ext && \
+ ${PYTHON_CMD} setup.py install ${STAGEDIR}${SPHINXDIR} ${SPHINXDIR}/ext
+
+.include <bsd.port.mk>
diff --git a/textproc/py-sphinx_numfig/distinfo b/textproc/py-sphinx_numfig/distinfo
new file mode 100644
index 00000000000..ae09d5a0b81
--- /dev/null
+++ b/textproc/py-sphinx_numfig/distinfo
@@ -0,0 +1,2 @@
+SHA256 (sphinx_numfig-r13.tgz) = 00bd28edc5d91e3fc17a35163cd2426a22364d4760691f730b22e309c4e6ed25
+SIZE (sphinx_numfig-r13.tgz) = 2053
diff --git a/textproc/py-sphinx_numfig/files/patch-setup.py b/textproc/py-sphinx_numfig/files/patch-setup.py
new file mode 100644
index 00000000000..4fabd7b7e03
--- /dev/null
+++ b/textproc/py-sphinx_numfig/files/patch-setup.py
@@ -0,0 +1,20 @@
+--- setup.py.orig 2012-10-08 16:34:53 UTC
++++ setup.py
+@@ -19,7 +19,7 @@ else:
+ sys.exit(1)
+
+ # Remove the old installation
+-sphinxdir = os.path.dirname(sphinx.__file__)
++sphinxdir = sys.argv[2]
+ olddst = os.path.join(sphinxdir, "numfig.py")
+ olddstc = os.path.join(sphinxdir, "numfig.pyc")
+ sphinxextdir = os.path.join(sphinxdir, "ext")
+@@ -39,7 +39,7 @@ shutil.copyfile("numfig.py", dst)
+ # Compile to bytecode
+ import py_compile
+ print "Compiling", dst, "to bytecode."
+-py_compile.compile(dst)
++py_compile.compile(dst, dstc, sys.argv[3])
+
+ # Fix perms
+ mode = stat.S_IRUSR | stat.S_IWUSR | stat.S_IRGRP | stat.S_IWGRP | stat.S_IROTH
diff --git a/textproc/py-sphinx_numfig/pkg-descr b/textproc/py-sphinx_numfig/pkg-descr
new file mode 100644
index 00000000000..dfcbcb8934c
--- /dev/null
+++ b/textproc/py-sphinx_numfig/pkg-descr
@@ -0,0 +1,4 @@
+This is a Sphinx package for autonumbering figures. With numfig you can
+have numbered figures in your Sphinx documents and refer to them by number.
+
+WWW: https://bitbucket.org/arjones6/sphinx-numfig/wiki/Home