aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authortj <tj@FreeBSD.org>2016-11-04 15:28:35 +0800
committertj <tj@FreeBSD.org>2016-11-04 15:28:35 +0800
commita8f6a1ed84c5f8d9075e50afc5016ac946ef134c (patch)
tree13ed3d77f03d8a01d8f5e14146428bd6e57e497e /textproc
parentdab022dd8072490274aeaa9512a44285dd5d278b (diff)
downloadfreebsd-ports-graphics-a8f6a1ed84c5f8d9075e50afc5016ac946ef134c.tar.gz
freebsd-ports-graphics-a8f6a1ed84c5f8d9075e50afc5016ac946ef134c.tar.zst
freebsd-ports-graphics-a8f6a1ed84c5f8d9075e50afc5016ac946ef134c.zip
Add Elasticsearch 5.0.0.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/elasticsearch/Makefile2
-rw-r--r--textproc/elasticsearch2/Makefile3
-rw-r--r--textproc/elasticsearch5/Makefile91
-rw-r--r--textproc/elasticsearch5/distinfo3
-rw-r--r--textproc/elasticsearch5/files/elasticsearch.in167
-rw-r--r--textproc/elasticsearch5/files/patch-bin_elasticsearch.in.sh22
-rw-r--r--textproc/elasticsearch5/files/patch-config_elasticsearch.yml18
-rw-r--r--textproc/elasticsearch5/files/pkg-message.in6
-rw-r--r--textproc/elasticsearch5/pkg-descr4
-rw-r--r--textproc/elasticsearch5/pkg-plist108
11 files changed, 422 insertions, 3 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 72eeb78f321..0fe448de397 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -161,6 +161,7 @@
SUBDIR += elasticsearch2-plugin-marvel
SUBDIR += elasticsearch2-plugin-migration
SUBDIR += elasticsearch2-plugin-sql
+ SUBDIR += elasticsearch5
SUBDIR += elixir-earmark
SUBDIR += elixir-ex_doc
SUBDIR += elixir-funnel
diff --git a/textproc/elasticsearch/Makefile b/textproc/elasticsearch/Makefile
index 8d98186e215..34d661e4de7 100644
--- a/textproc/elasticsearch/Makefile
+++ b/textproc/elasticsearch/Makefile
@@ -14,7 +14,7 @@ LICENSE= APACHE20
RUN_DEPENDS= java-sigar>=0:java/sigar
-CONFLICTS= elasticsearch2-[0-9]*
+CONFLICTS= elasticsearch[0-9]-[0-9]*
USES= cpe
NO_ARCH= yes
diff --git a/textproc/elasticsearch2/Makefile b/textproc/elasticsearch2/Makefile
index ad2cf66f9e3..a297e701cc6 100644
--- a/textproc/elasticsearch2/Makefile
+++ b/textproc/elasticsearch2/Makefile
@@ -14,7 +14,7 @@ COMMENT= Full-text search engine for Java
LICENSE= APACHE20
-CONFLICTS= elasticsearch-[0-9]*
+CONFLICTS= elasticsearch-[0-9]* elasticsearch5-[0-9]*
USES= cpe
NO_ARCH= yes
@@ -85,5 +85,4 @@ do-install-DOCS-on:
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-
.include <bsd.port.mk>
diff --git a/textproc/elasticsearch5/Makefile b/textproc/elasticsearch5/Makefile
new file mode 100644
index 00000000000..b8cfc2ea79f
--- /dev/null
+++ b/textproc/elasticsearch5/Makefile
@@ -0,0 +1,91 @@
+# Created by: Tom Judge <tj@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= elasticsearch
+PORTVERSION= 5.0.0
+CATEGORIES= textproc java devel
+MASTER_SITES= https://artifacts.elastic.co/downloads/${PORTNAME}/ \
+ http://mirrors.rit.edu/zi/
+PKGNAMESUFFIX= 5
+
+MAINTAINER= tj@FreeBSD.org
+COMMENT= Full-text search engine for Java
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= bash>0:shells/bash
+
+CONFLICTS= elasticsearch-[0-9]* elasticsearch2-[0-9]*
+
+USES= cpe shebangfix
+NO_ARCH= yes
+USE_JAVA= yes
+NO_BUILD= yes
+JAVA_VERSION= 1.8+
+USE_RC_SUBR= ${PORTNAME}
+SHEBANG_FILES= bin/elasticsearch-plugin \
+ bin/elasticsearch
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+LUCENEVER= 6.2.0
+CONFIG_FILES= elasticsearch.yml log4j2.properties jvm.options
+BINS= elasticsearch.in.sh \
+ elasticsearch \
+ elasticsearch-plugin
+
+DOCS= LICENSE.txt \
+ NOTICE.txt \
+ README.textile
+
+SIGAR_ARCH= ${ARCH:S|i386|x86|}
+SEARCHUSER?= elasticsearch
+SEARCHGROUP?= ${SEARCHUSER}
+USERS= ${SEARCHUSER}
+GROUPS= ${SEARCHGROUP}
+ELASTIC_DBDIR= /var/db/elasticsearch
+ELASTIC_LOGDIR= /var/log/elasticsearch
+
+SUB_LIST= SEARCHUSER=${SEARCHUSER} \
+ SEARCHGROUP=${SEARCHGROUP} \
+ PORTVERSION=${PORTVERSION}
+SUB_FILES= pkg-message
+PLIST_SUB= SEARCHUSER=${SEARCHUSER} \
+ SEARCHGROUP=${SEARCHGROUP} \
+ LUCENEVER=${LUCENEVER} \
+ PORTVERSION=${PORTVERSION} \
+ ELASTIC_DBDIR=${ELASTIC_DBDIR} \
+ ELASTIC_LOGDIR=${ELASTIC_LOGDIR}
+
+post-patch:
+ ${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/config/elasticsearch.yml
+ ${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/bin/elasticsearch.in.sh
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/elasticsearch
+.for f in ${CONFIG_FILES}
+ ${INSTALL} -m 440 ${WRKSRC}/config/${f} ${STAGEDIR}${ETCDIR}/${f}.sample
+.endfor
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/bin
+.for f in ${BINS}
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/${f} ${STAGEDIR}${PREFIX}/lib/elasticsearch/bin
+.endfor
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/lib
+ (cd ${WRKSRC}/lib && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/lib/elasticsearch/lib/ "-name *\.jar")
+
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/modules
+ (cd ${WRKSRC}/modules && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/lib/elasticsearch/modules/)
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/plugins
+ @${MKDIR} ${STAGEDIR}${PREFIX}/libexec/elasticsearch
+ @${MKDIR} ${STAGEDIR}${ELASTIC_DBDIR} ${STAGEDIR}${ELASTIC_LOGDIR}
+ cd ${STAGEDIR}${PREFIX}/bin && ${LN} -s ${PREFIX}/lib/elasticsearch/bin/elasticsearch-plugin elasticsearch-plugin
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/textproc/elasticsearch5/distinfo b/textproc/elasticsearch5/distinfo
new file mode 100644
index 00000000000..970b601ca0d
--- /dev/null
+++ b/textproc/elasticsearch5/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1478218577
+SHA256 (elasticsearch-5.0.0.tar.gz) = a866534f0fa7428e980c985d712024feef1dee04709add6e360fc7b73bb1e7ae
+SIZE (elasticsearch-5.0.0.tar.gz) = 32968292
diff --git a/textproc/elasticsearch5/files/elasticsearch.in b/textproc/elasticsearch5/files/elasticsearch.in
new file mode 100644
index 00000000000..8074bd2cf78
--- /dev/null
+++ b/textproc/elasticsearch5/files/elasticsearch.in
@@ -0,0 +1,167 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: elasticsearch
+# REQUIRE: NETWORKING SERVERS
+# BEFORE: DAEMON
+# KEYWORD: shutdown
+#
+# Add the following line to /etc/rc.conf to enable elasticsearch:
+#
+# elasticsearch_enable="YES"
+#
+# elasticsearch_user (username): Set to elasticsearch by default.
+# Set it to required username.
+# elasticsearch_group (group): Set to elasticsearch by default.
+# Set it to required group.
+# elasticsearch_config (path): Set to /usr/local/etc/elasticsearch/elasticsearch.yml by default.
+# Set it to the config file location.
+# elasticsearch_min_mem (num): Minumum JVM heap size, 256m by default.
+# elasticsearch_max_mem (num): Maximum JVM heap size, 1g by default.
+# elasticsearch_props (args): Additional java properties or arguments.
+# elasticsearch_tmp (path): Set to /var/tmp/elasticsearch by default.
+# Set it to the path to be used for temp files.
+#
+. /etc/rc.subr
+
+name=elasticsearch
+rcvar=elasticsearch_enable
+
+load_rc_config ${name}
+
+: ${elasticsearch_enable:="NO"}
+: ${elasticsearch_user:=%%SEARCHUSER%%}
+: ${elasticsearch_group:=%%SEARCHGROUP%%}
+: ${elasticsearch_config:="%%PREFIX%%/etc/elasticsearch"}
+: ${elasticsearch_tmp:="/var/tmp/elasticsearch"}
+
+required_files="${elasticsearch_config}/elasticsearch.yml"
+_pidprefix="/var/run/elasticsearch"
+pidfile="${_pidprefix}.pid"
+
+extra_commands="console status"
+console_cmd="elasticsearch_console"
+start_precmd="elasticsearch_precmd"
+status_cmd="elasticsearch_status"
+stop_cmd="elasticsearch_stop"
+command="%%PREFIX%%/lib/elasticsearch/bin/elasticsearch"
+command_args="-d --pidfile=${pidfile}"
+
+elasticsearch_precmd()
+{
+ touch ${pidfile}
+ chown ${elasticsearch_user}:${elasticsearch_group} ${pidfile}
+ /usr/bin/install -d -o ${elasticsearch_user} -g ${elasticsearch_group} -m 750 ${elasticsearch_tmp}
+ /usr/bin/install -d -o ${elasticsearch_user} -g ${elasticsearch_group} -m 750 /var/db/elasticsearch
+ /usr/bin/install -d -o ${elasticsearch_user} -g ${elasticsearch_group} -m 750 /var/log/elasticsearch
+}
+
+elasticsearch_console()
+{
+ command_args=""
+ run_rc_command "start"
+}
+
+
+elasticsearch_stop()
+{
+ rc_pid=$(elasticsearch_check_pidfile $pidfile)
+
+ if [ -z "$rc_pid" ]; then
+ [ -n "$rc_fast" ] && return 0
+ echo "${name} not running? (check $pidfile)."
+ return 1
+ fi
+
+ echo "Stopping ${name}."
+ kill ${rc_pid} 2> /dev/null
+}
+
+elasticsearch_status()
+{
+ rc_pid=$(elasticsearch_check_pidfile $pidfile)
+
+ if [ -z "$rc_pid" ]; then
+ [ -n "$rc_fast" ] && return 0
+ echo "${name} not running? (check $pidfile)."
+ return 1
+ fi
+ echo "${name} is running as pid ${rc_pid}."
+}
+
+elasticsearch_check_pidfile()
+{
+ _pidfile=$1
+ if [ -z "$_pidfile" ]; then
+ err 3 'USAGE: elasticsearch_check_pidfile pidfile'
+ fi
+ if [ ! -f $_pidfile ]; then
+ debug "pid file ($_pidfile): not readable."
+ return
+ fi
+ read _pid _junk < $_pidfile
+ if [ -z "$_pid" ]; then
+ debug "pid file ($_pidfile): no pid in file."
+ return
+ fi
+ if [ -n "`%%LOCALBASE%%/bin/jps -l | grep -e "^$_pid"`" ]; then
+ echo -n $_pid
+ fi
+}
+if [ -n "$2" ]; then
+ profile="$2"
+ if [ "x${elasticsearch_profiles}" != "x" ]; then
+ pidfile="${_pidprefix}.${profile}.pid"
+ eval elasticsearch_config="\${elasticsearch_${profile}_config:-}"
+ if [ "x${elasticsearch_config}" = "x" ]; then
+ echo "You must define a configuration (elasticsearch_${profile}_config)"
+ exit 1
+ fi
+ required_files="${elasticsearch_config}/elasticsearch.yml"
+ eval elasticsearch_enable="\${elasticsearch_${profile}_enable:-${elasticsearch_enable}}"
+ eval elasticsearch_props="\${elasticsearch_${profile}_props:-${elasticsearch_props}}"
+ eval elasticsearch_min_mem="\${elasticsearch_${profile}_min_mem:-${elasticsearch_min_mem}}"
+ eval elasticsearch_max_mem="\${elasticsearchlimits_${profile}_enable:-${elasticsearch_max_mem}}"
+ eval elasticsearch_tmp="\${elasticsearchlimits_${profile}_args:-${elasticsearch_tmp}}"
+ else
+ echo "$0: extra argument ignored"
+ fi
+else
+ eval elasticsearch_envvars=${envvars}
+ if [ "x${elasticsearch_profiles}" != "x" -a "x$1" != "x" ]; then
+ for profile in ${elasticsearch_profiles}; do
+ eval _enable="\${elasticsearch_${profile}_enable}"
+ case "x${_enable:-${elasticsearch_enable}}" in
+ x|x[Nn][Oo]|x[Nn][Oo][Nn][Ee])
+ continue
+ ;;
+ x[Yy][Ee][Ss])
+ ;;
+ *)
+ if test -z "$_enable"; then
+ _var=elasticsearch_enable
+ else
+ _var=elasticsearch_"${profile}"_enable
+ fi
+ echo "Bad value" \
+ "'${_enable:-${elasticsearch_enable}}'" \
+ "for ${_var}. " \
+ "Profile ${profile} skipped."
+ continue
+ ;;
+ esac
+ echo "===> elasticsearch profile: ${profile}"
+ /usr/local/etc/rc.d/elasticsearch $1 ${profile}
+ retcode="$?"
+ if [ "0${retcode}" -ne 0 ]; then
+ failed="${profile} (${retcode}) ${failed:-}"
+ else
+ success="${profile} ${success:-}"
+ fi
+ done
+ exit 0
+ fi
+fi
+
+run_rc_command "$1"
diff --git a/textproc/elasticsearch5/files/patch-bin_elasticsearch.in.sh b/textproc/elasticsearch5/files/patch-bin_elasticsearch.in.sh
new file mode 100644
index 00000000000..2608186764b
--- /dev/null
+++ b/textproc/elasticsearch5/files/patch-bin_elasticsearch.in.sh
@@ -0,0 +1,22 @@
+--- bin/elasticsearch.in.sh.orig 2016-10-26 04:35:54 UTC
++++ bin/elasticsearch.in.sh
+@@ -1,5 +1,19 @@
+ #!/bin/bash
+
++if [ `uname -o` == "FreeBSD" ]; then
++ . /etc/rc.subr
++ load_rc_config elasticsearch
++ ES_MIN_MEM=${elasticsearch_min_mem}
++ ES_MAX_MEM=${elasticsearch_max_mem}
++ ES_HEAP_NEW_SIZE=${elasticsearch_heap_newsize}
++ ES_DIRECT_SIZE=${elasticsearch_direct_size}
++ ES_USE_IPV4=${elasticsearch_use_ipv4}
++ ES_GC_OPTS=${elasticsearch_gc_opts}
++ ES_GC_LOG_FILE=${elasticsearch_gc_logfile}
++ ES_JAVA_OPTS="$ES_JAVA_OPTS -Des.path.conf=${elasticsearch_config:="/usr/local/etc/elasticsearch"}"
++ PATH=${PATH}:/usr/local/bin
++fi
++
+ # check in case a user was using this mechanism
+ if [ "x$ES_CLASSPATH" != "x" ]; then
+ cat >&2 << EOF
diff --git a/textproc/elasticsearch5/files/patch-config_elasticsearch.yml b/textproc/elasticsearch5/files/patch-config_elasticsearch.yml
new file mode 100644
index 00000000000..a20c30e446a
--- /dev/null
+++ b/textproc/elasticsearch5/files/patch-config_elasticsearch.yml
@@ -0,0 +1,18 @@
+--- config/elasticsearch.yml.orig 2016-10-26 04:35:54 UTC
++++ config/elasticsearch.yml
+@@ -31,10 +31,15 @@
+ # Path to directory where to store the data (separate multiple locations by comma):
+ #
+ #path.data: /path/to/data
++path.data: /var/db/elasticsearch
+ #
+ # Path to log files:
+ #
+ #path.logs: /path/to/logs
++path.logs: /var/log/elasticsearch
++#
++# Path to scripts dir:
++path.scripts: /usr/local/libexec/elasticsearch
+ #
+ # ----------------------------------- Memory -----------------------------------
+ #
diff --git a/textproc/elasticsearch5/files/pkg-message.in b/textproc/elasticsearch5/files/pkg-message.in
new file mode 100644
index 00000000000..e7f3aecf52b
--- /dev/null
+++ b/textproc/elasticsearch5/files/pkg-message.in
@@ -0,0 +1,6 @@
+======================================================================
+
+Please see %%ETCDIR%% for sample versions of
+elasticsearch.yml and logging.yml.
+
+======================================================================
diff --git a/textproc/elasticsearch5/pkg-descr b/textproc/elasticsearch5/pkg-descr
new file mode 100644
index 00000000000..0eb44650711
--- /dev/null
+++ b/textproc/elasticsearch5/pkg-descr
@@ -0,0 +1,4 @@
+Elasticsearch aims to be a Distributed, RESTful, Search Engine built on top of
+Apache Lucene.
+
+WWW: http://www.elastic.co/
diff --git a/textproc/elasticsearch5/pkg-plist b/textproc/elasticsearch5/pkg-plist
new file mode 100644
index 00000000000..0eb96afb316
--- /dev/null
+++ b/textproc/elasticsearch5/pkg-plist
@@ -0,0 +1,108 @@
+@sample(%%SEARCHUSER%%,%%SEARCHGROUP%%,440) %%ETCDIR%%/elasticsearch.yml.sample
+@sample(%%SEARCHUSER%%,%%SEARCHGROUP%%,440) %%ETCDIR%%/log4j2.properties.sample
+@sample(%%SEARCHUSER%%,%%SEARCHGROUP%%,440) %%ETCDIR%%/jvm.options.sample
+@unexec if [ -d %%ELASTIC_LOGDIR%% ]; then echo "You should remove %%ELASTIC_LOGDIR%% if you don't need it any more."; fi
+@unexec if [ -d %%ELASTIC_DBDIR%% ]; then echo "You should remove %%ELASTIC_DBDIR%% if you don't need it any more."; fi
+bin/elasticsearch-plugin
+lib/elasticsearch/lib/HdrHistogram-2.1.6.jar
+lib/elasticsearch/lib/elasticsearch-%%PORTVERSION%%.jar
+lib/elasticsearch/lib/hppc-0.7.1.jar
+lib/elasticsearch/lib/jackson-core-2.8.1.jar
+lib/elasticsearch/lib/jackson-dataformat-cbor-2.8.1.jar
+lib/elasticsearch/lib/jackson-dataformat-smile-2.8.1.jar
+lib/elasticsearch/lib/jackson-dataformat-yaml-2.8.1.jar
+lib/elasticsearch/lib/jna-4.2.2.jar
+lib/elasticsearch/lib/joda-convert-1.2.jar
+lib/elasticsearch/lib/joda-time-2.9.4.jar
+lib/elasticsearch/lib/jopt-simple-5.0.2.jar
+lib/elasticsearch/lib/jts-1.13.jar
+lib/elasticsearch/lib/log4j-1.2-api-2.6.2.jar
+lib/elasticsearch/lib/log4j-api-2.6.2.jar
+lib/elasticsearch/lib/log4j-core-2.6.2.jar
+lib/elasticsearch/lib/lucene-analyzers-common-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-backward-codecs-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-core-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-grouping-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-highlighter-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-join-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-memory-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-misc-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-queries-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-queryparser-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-sandbox-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-spatial-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-spatial-extras-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-spatial3d-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/lucene-suggest-%%LUCENEVER%%.jar
+lib/elasticsearch/lib/securesm-1.1.jar
+lib/elasticsearch/lib/snakeyaml-1.15.jar
+lib/elasticsearch/lib/spatial4j-0.6.jar
+lib/elasticsearch/lib/t-digest-3.0.jar
+lib/elasticsearch/bin/elasticsearch.in.sh
+lib/elasticsearch/bin/elasticsearch
+lib/elasticsearch/bin/elasticsearch-plugin
+lib/elasticsearch/modules/aggs-matrix-stats/aggs-matrix-stats-%%PORTVERSION%%.jar
+lib/elasticsearch/modules/aggs-matrix-stats/plugin-descriptor.properties
+lib/elasticsearch/modules/ingest-common/ingest-common-%%PORTVERSION%%.jar
+lib/elasticsearch/modules/ingest-common/jcodings-1.0.12.jar
+lib/elasticsearch/modules/ingest-common/joni-2.1.6.jar
+lib/elasticsearch/modules/ingest-common/plugin-descriptor.properties
+lib/elasticsearch/modules/lang-expression/antlr4-runtime-4.5.1-1.jar
+lib/elasticsearch/modules/lang-expression/asm-5.0.4.jar
+lib/elasticsearch/modules/lang-expression/asm-commons-5.0.4.jar
+lib/elasticsearch/modules/lang-expression/asm-tree-5.0.4.jar
+lib/elasticsearch/modules/lang-expression/lang-expression-%%PORTVERSION%%.jar
+lib/elasticsearch/modules/lang-expression/lucene-expressions-%%LUCENEVER%%.jar
+lib/elasticsearch/modules/lang-expression/plugin-descriptor.properties
+lib/elasticsearch/modules/lang-expression/plugin-security.policy
+lib/elasticsearch/modules/lang-groovy/groovy-2.4.6-indy.jar
+lib/elasticsearch/modules/lang-groovy/lang-groovy-%%PORTVERSION%%.jar
+lib/elasticsearch/modules/lang-groovy/plugin-descriptor.properties
+lib/elasticsearch/modules/lang-groovy/plugin-security.policy
+lib/elasticsearch/modules/lang-mustache/compiler-0.9.3.jar
+lib/elasticsearch/modules/lang-mustache/lang-mustache-%%PORTVERSION%%.jar
+lib/elasticsearch/modules/lang-mustache/plugin-descriptor.properties
+lib/elasticsearch/modules/lang-mustache/plugin-security.policy
+lib/elasticsearch/modules/lang-painless/antlr4-runtime-4.5.1-1.jar
+lib/elasticsearch/modules/lang-painless/asm-debug-all-5.1.jar
+lib/elasticsearch/modules/lang-painless/lang-painless-%%PORTVERSION%%.jar
+lib/elasticsearch/modules/lang-painless/plugin-descriptor.properties
+lib/elasticsearch/modules/lang-painless/plugin-security.policy
+lib/elasticsearch/modules/percolator/percolator-%%PORTVERSION%%.jar
+lib/elasticsearch/modules/percolator/plugin-descriptor.properties
+lib/elasticsearch/modules/reindex/commons-codec-1.10.jar
+lib/elasticsearch/modules/reindex/commons-logging-1.1.3.jar
+lib/elasticsearch/modules/reindex/httpasyncclient-4.1.2.jar
+lib/elasticsearch/modules/reindex/httpclient-4.5.2.jar
+lib/elasticsearch/modules/reindex/httpcore-4.4.5.jar
+lib/elasticsearch/modules/reindex/httpcore-nio-4.4.5.jar
+lib/elasticsearch/modules/reindex/plugin-descriptor.properties
+lib/elasticsearch/modules/reindex/reindex-%%PORTVERSION%%.jar
+lib/elasticsearch/modules/reindex/rest-%%PORTVERSION%%.jar
+lib/elasticsearch/modules/transport-netty3/netty-3.10.6.Final.jar
+lib/elasticsearch/modules/transport-netty3/plugin-descriptor.properties
+lib/elasticsearch/modules/transport-netty3/plugin-security.policy
+lib/elasticsearch/modules/transport-netty3/transport-netty3-%%PORTVERSION%%.jar
+lib/elasticsearch/modules/transport-netty4/netty-buffer-4.1.5.Final.jar
+lib/elasticsearch/modules/transport-netty4/netty-codec-4.1.5.Final.jar
+lib/elasticsearch/modules/transport-netty4/netty-codec-http-4.1.5.Final.jar
+lib/elasticsearch/modules/transport-netty4/netty-common-4.1.5.Final.jar
+lib/elasticsearch/modules/transport-netty4/netty-handler-4.1.5.Final.jar
+lib/elasticsearch/modules/transport-netty4/netty-resolver-4.1.5.Final.jar
+lib/elasticsearch/modules/transport-netty4/netty-transport-4.1.5.Final.jar
+lib/elasticsearch/modules/transport-netty4/plugin-descriptor.properties
+lib/elasticsearch/modules/transport-netty4/plugin-security.policy
+lib/elasticsearch/modules/transport-netty4/transport-netty4-%%PORTVERSION%%.jar
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
+%%PORTDOCS%%%%DOCSDIR%%/NOTICE.txt
+%%PORTDOCS%%%%DOCSDIR%%/README.textile
+@dir lib/elasticsearch/lib
+@dir lib/elasticsearch/bin
+@dir lib/elasticsearch/modules
+@dir lib/elasticsearch/plugins
+@dir lib/elasticsearch
+@dir libexec/elasticsearch
+@dir(%%SEARCHUSER%%,%%SEARCHGROUP%%,750) %%ELASTIC_LOGDIR%%
+@dir(%%SEARCHUSER%%,%%SEARCHGROUP%%,750) %%ELASTIC_DBDIR%%
+@postunexec if [ -d %%ELASTIC_LOGDIR%% ]; then echo "You should remove %%ELASTIC_LOGDIR%% if you don't need it any more."; fi
+@postunexec if [ -d %%ELASTIC_DBDIR%% ]; then echo "You should remove %%ELASTIC_DBDIR%% if you don't need it any more."; fi