aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2004-08-12 20:48:01 +0800
committermat <mat@FreeBSD.org>2004-08-12 20:48:01 +0800
commitb2915fd9d1aba9c155acea1793e42c7659e36be8 (patch)
tree7f1b6a044bd73b3a561e1fee38519f0ba6679d11 /textproc
parent1140f51cbed662c0f6dbd4ef84e3b5f2849f7cbd (diff)
downloadfreebsd-ports-graphics-b2915fd9d1aba9c155acea1793e42c7659e36be8.tar.gz
freebsd-ports-graphics-b2915fd9d1aba9c155acea1793e42c7659e36be8.tar.zst
freebsd-ports-graphics-b2915fd9d1aba9c155acea1793e42c7659e36be8.zip
After devel/p5-File-Temp has gained an IGNORE for PERL_LEVEL > 500800, all
these ports were broken because they always depended on it. I've rearranged all the dependencies to fit the new scheme.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/p5-PerlPoint-Package/Makefile6
-rw-r--r--textproc/p5-XML-SAX/Makefile11
2 files changed, 11 insertions, 6 deletions
diff --git a/textproc/p5-PerlPoint-Package/Makefile b/textproc/p5-PerlPoint-Package/Makefile
index 0ffafc8ae65..5eeec7e2ad5 100644
--- a/textproc/p5-PerlPoint-Package/Makefile
+++ b/textproc/p5-PerlPoint-Package/Makefile
@@ -46,10 +46,10 @@ post-install:
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
-.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec \
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
.endif
.endif
diff --git a/textproc/p5-XML-SAX/Makefile b/textproc/p5-XML-SAX/Makefile
index 09a4b864cec..bd57461e1a9 100644
--- a/textproc/p5-XML-SAX/Makefile
+++ b/textproc/p5-XML-SAX/Makefile
@@ -15,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= Simple API for XML
-RUN_DEPENDS= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
- ${SITE_PERL}/XML/NamespaceSupport.pm:${PORTSDIR}/textproc/p5-XML-NamespaceSupport
+RUN_DEPENDS= ${SITE_PERL}/XML/NamespaceSupport.pm:${PORTSDIR}/textproc/p5-XML-NamespaceSupport
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
@@ -33,4 +32,10 @@ post-configure:
@${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' \
${WRKSRC}/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+.endif
+
+.include <bsd.port.post.mk>