aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2006-12-13 20:41:35 +0800
committerroam <roam@FreeBSD.org>2006-12-13 20:41:35 +0800
commitde4cf73f5446a2a8a2c782e21edd36968046a9e7 (patch)
treea8af6bc7bac65179902c59b7a1f9ab026c6203c4 /textproc
parentf6df9e67cbe8aa509adda747e0c3bcbe05c8c99b (diff)
downloadfreebsd-ports-graphics-de4cf73f5446a2a8a2c782e21edd36968046a9e7.tar.gz
freebsd-ports-graphics-de4cf73f5446a2a8a2c782e21edd36968046a9e7.tar.zst
freebsd-ports-graphics-de4cf73f5446a2a8a2c782e21edd36968046a9e7.zip
Update the ftp/curl port to 7.16.0.
Bump PORTREVISION of all dependent ports. Fix the build errors in the few ports that still use the long deprecated, and now obsoleted, cURL options. Thanks to everyone who took the time to look over the patch! Discussed on: -ports
Diffstat (limited to 'textproc')
-rw-r--r--textproc/libnxml/Makefile3
-rw-r--r--textproc/raptor/Makefile3
-rw-r--r--textproc/raptor/files/patch-configure178
-rw-r--r--textproc/raptor2/Makefile3
-rw-r--r--textproc/raptor2/files/patch-configure178
5 files changed, 362 insertions, 3 deletions
diff --git a/textproc/libnxml/Makefile b/textproc/libnxml/Makefile
index 7a62664b395..2b0e9945e37 100644
--- a/textproc/libnxml/Makefile
+++ b/textproc/libnxml/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libnxml
PORTVERSION= 0.15
+PORTREVISION= 1
CATEGORIES= textproc devel
MASTER_SITES= http://www2.autistici.org/bakunin/libnxml/ \
http://nivi.interfree.it/distfiles/${PORTNAME}/${PORTVERSION}/
@@ -14,7 +15,7 @@ MASTER_SITES= http://www2.autistici.org/bakunin/libnxml/ \
MAINTAINER= nivit@FreeBSD.org
COMMENT= A C library for writing XML 1.0/1.1 files or streams
-LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I/${LOCALBASE}/include" LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
diff --git a/textproc/raptor/Makefile b/textproc/raptor/Makefile
index cf971d9b5e1..fe9c99811de 100644
--- a/textproc/raptor/Makefile
+++ b/textproc/raptor/Makefile
@@ -8,6 +8,7 @@
PORTNAME= raptor
PORTVERSION= 1.4.13
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://download.librdf.org/source/
@@ -16,7 +17,7 @@ MASTER_SITE_SUBDIR= librdf
MAINTAINER= chuck@pkix.net
COMMENT= RDF Parser Toolkit for Redland
-LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl
USE_GNOME= gnomehack gnometarget libxml2
USE_GETOPT_LONG= yes
diff --git a/textproc/raptor/files/patch-configure b/textproc/raptor/files/patch-configure
new file mode 100644
index 00000000000..9501209fda7
--- /dev/null
+++ b/textproc/raptor/files/patch-configure
@@ -0,0 +1,178 @@
+--- configure.orig Mon Dec 11 15:16:01 2006
++++ configure Mon Dec 11 15:28:29 2006
+@@ -19868,6 +19868,74 @@
+
+
+
++# Check whether --with-curl-config was given.
++if test "${with_curl_config+set}" = set; then
++ withval=$with_curl_config; curl_config="$withval"
++else
++ curl_config=""
++fi
++
++
++if test "X$curl_config" != "X" ; then
++ { echo "$as_me:$LINENO: checking for $curl_config" >&5
++echo $ECHO_N "checking for $curl_config... $ECHO_C" >&6; }
++
++ if test -f $curl_config ; then
++ CURL_CONFIG=$curl_config
++ { echo "$as_me:$LINENO: result: yes" >&5
++echo "${ECHO_T}yes" >&6; }
++ else
++ { echo "$as_me:$LINENO: result: no - searching PATH" >&5
++echo "${ECHO_T}no - searching PATH" >&6; }
++ fi
++fi
++if test "X$CURL_CONFIG" = "X"; then
++ for ac_prog in curl-config
++do
++ # Extract the first word of "$ac_prog", so it can be a program name with args.
++set dummy $ac_prog; ac_word=$2
++{ echo "$as_me:$LINENO: checking for $ac_word" >&5
++echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
++if test "${ac_cv_prog_CURL_CONFIG+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ if test -n "$CURL_CONFIG"; then
++ ac_cv_prog_CURL_CONFIG="$CURL_CONFIG" # Let the user override the test.
++else
++as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
++for as_dir in $PATH
++do
++ IFS=$as_save_IFS
++ test -z "$as_dir" && as_dir=.
++ for ac_exec_ext in '' $ac_executable_extensions; do
++ if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; }; then
++ ac_cv_prog_CURL_CONFIG="$ac_prog"
++ echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
++ break 2
++ fi
++done
++done
++IFS=$as_save_IFS
++
++fi
++fi
++CURL_CONFIG=$ac_cv_prog_CURL_CONFIG
++if test -n "$CURL_CONFIG"; then
++ { echo "$as_me:$LINENO: result: $CURL_CONFIG" >&5
++echo "${ECHO_T}$CURL_CONFIG" >&6; }
++else
++ { echo "$as_me:$LINENO: result: no" >&5
++echo "${ECHO_T}no" >&6; }
++fi
++
++
++ test -n "$CURL_CONFIG" && break
++done
++
++fi
++
++oCPPFLAGS="$CPPFLAGS"
++CPPFLAGS="$CPPFLAGS `$CURL_CONFIG --cflags`"
+
+ for ac_header in errno.h stdlib.h unistd.h string.h limits.h dmalloc.h getopt.h sys/stat.h curl/curl.h libxml/nanohttp.h sys/param.h sys/time.h
+ do
+@@ -20037,6 +20105,9 @@
+
+ done
+
++CPPFLAGS="$oCPPFLAGS"
++LIBS="$oLIBS"
++
+ { echo "$as_me:$LINENO: checking whether time.h and sys/time.h may both be included" >&5
+ echo $ECHO_N "checking whether time.h and sys/time.h may both be included... $ECHO_C" >&6; }
+ if test "${ac_cv_header_time+set}" = set; then
+@@ -23931,72 +24002,6 @@
+ fi
+
+
+-# Check whether --with-curl-config was given.
+-if test "${with_curl_config+set}" = set; then
+- withval=$with_curl_config; curl_config="$withval"
+-else
+- curl_config=""
+-fi
+-
+-
+-if test "X$curl_config" != "X" ; then
+- { echo "$as_me:$LINENO: checking for $curl_config" >&5
+-echo $ECHO_N "checking for $curl_config... $ECHO_C" >&6; }
+-
+- if test -f $curl_config ; then
+- CURL_CONFIG=$curl_config
+- { echo "$as_me:$LINENO: result: yes" >&5
+-echo "${ECHO_T}yes" >&6; }
+- else
+- { echo "$as_me:$LINENO: result: no - searching PATH" >&5
+-echo "${ECHO_T}no - searching PATH" >&6; }
+- fi
+-fi
+-if test "X$CURL_CONFIG" = "X"; then
+- for ac_prog in curl-config
+-do
+- # Extract the first word of "$ac_prog", so it can be a program name with args.
+-set dummy $ac_prog; ac_word=$2
+-{ echo "$as_me:$LINENO: checking for $ac_word" >&5
+-echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
+-if test "${ac_cv_prog_CURL_CONFIG+set}" = set; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+- if test -n "$CURL_CONFIG"; then
+- ac_cv_prog_CURL_CONFIG="$CURL_CONFIG" # Let the user override the test.
+-else
+-as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+-for as_dir in $PATH
+-do
+- IFS=$as_save_IFS
+- test -z "$as_dir" && as_dir=.
+- for ac_exec_ext in '' $ac_executable_extensions; do
+- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; }; then
+- ac_cv_prog_CURL_CONFIG="$ac_prog"
+- echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
+- break 2
+- fi
+-done
+-done
+-IFS=$as_save_IFS
+-
+-fi
+-fi
+-CURL_CONFIG=$ac_cv_prog_CURL_CONFIG
+-if test -n "$CURL_CONFIG"; then
+- { echo "$as_me:$LINENO: result: $CURL_CONFIG" >&5
+-echo "${ECHO_T}$CURL_CONFIG" >&6; }
+-else
+- { echo "$as_me:$LINENO: result: no" >&5
+-echo "${ECHO_T}no" >&6; }
+-fi
+-
+-
+- test -n "$CURL_CONFIG" && break
+-done
+-
+-fi
+-
+
+ oLIBS="$LIBS"
+
+@@ -25623,7 +25628,9 @@
+
+ oCPPFLAGS="$CPPFLAGS"
+ if test "X$CURL_CONFIG" != X; then
++ oCPPFLAGS="$CPPFLAGS"
+ oLIBS="$LIBS"
++ CPPFLAGS="$CPPFLAGS `$CURL_CONFIG --cflags`"
+ LIBS="$LIBS `$CURL_CONFIG --libs`"
+ { echo "$as_me:$LINENO: checking for curl_easy_init" >&5
+ echo $ECHO_N "checking for curl_easy_init... $ECHO_C" >&6; }
+@@ -25728,6 +25735,7 @@
+ have_curl_easy_init=no
+ fi
+
++ CPPFLAGS="$oCPPFLAGS"
+ LIBS="$oLIBS"
+ { echo "$as_me:$LINENO: checking for libcurl library" >&5
+ echo $ECHO_N "checking for libcurl library... $ECHO_C" >&6; }
diff --git a/textproc/raptor2/Makefile b/textproc/raptor2/Makefile
index cf971d9b5e1..fe9c99811de 100644
--- a/textproc/raptor2/Makefile
+++ b/textproc/raptor2/Makefile
@@ -8,6 +8,7 @@
PORTNAME= raptor
PORTVERSION= 1.4.13
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://download.librdf.org/source/
@@ -16,7 +17,7 @@ MASTER_SITE_SUBDIR= librdf
MAINTAINER= chuck@pkix.net
COMMENT= RDF Parser Toolkit for Redland
-LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl
USE_GNOME= gnomehack gnometarget libxml2
USE_GETOPT_LONG= yes
diff --git a/textproc/raptor2/files/patch-configure b/textproc/raptor2/files/patch-configure
new file mode 100644
index 00000000000..9501209fda7
--- /dev/null
+++ b/textproc/raptor2/files/patch-configure
@@ -0,0 +1,178 @@
+--- configure.orig Mon Dec 11 15:16:01 2006
++++ configure Mon Dec 11 15:28:29 2006
+@@ -19868,6 +19868,74 @@
+
+
+
++# Check whether --with-curl-config was given.
++if test "${with_curl_config+set}" = set; then
++ withval=$with_curl_config; curl_config="$withval"
++else
++ curl_config=""
++fi
++
++
++if test "X$curl_config" != "X" ; then
++ { echo "$as_me:$LINENO: checking for $curl_config" >&5
++echo $ECHO_N "checking for $curl_config... $ECHO_C" >&6; }
++
++ if test -f $curl_config ; then
++ CURL_CONFIG=$curl_config
++ { echo "$as_me:$LINENO: result: yes" >&5
++echo "${ECHO_T}yes" >&6; }
++ else
++ { echo "$as_me:$LINENO: result: no - searching PATH" >&5
++echo "${ECHO_T}no - searching PATH" >&6; }
++ fi
++fi
++if test "X$CURL_CONFIG" = "X"; then
++ for ac_prog in curl-config
++do
++ # Extract the first word of "$ac_prog", so it can be a program name with args.
++set dummy $ac_prog; ac_word=$2
++{ echo "$as_me:$LINENO: checking for $ac_word" >&5
++echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
++if test "${ac_cv_prog_CURL_CONFIG+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ if test -n "$CURL_CONFIG"; then
++ ac_cv_prog_CURL_CONFIG="$CURL_CONFIG" # Let the user override the test.
++else
++as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
++for as_dir in $PATH
++do
++ IFS=$as_save_IFS
++ test -z "$as_dir" && as_dir=.
++ for ac_exec_ext in '' $ac_executable_extensions; do
++ if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; }; then
++ ac_cv_prog_CURL_CONFIG="$ac_prog"
++ echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
++ break 2
++ fi
++done
++done
++IFS=$as_save_IFS
++
++fi
++fi
++CURL_CONFIG=$ac_cv_prog_CURL_CONFIG
++if test -n "$CURL_CONFIG"; then
++ { echo "$as_me:$LINENO: result: $CURL_CONFIG" >&5
++echo "${ECHO_T}$CURL_CONFIG" >&6; }
++else
++ { echo "$as_me:$LINENO: result: no" >&5
++echo "${ECHO_T}no" >&6; }
++fi
++
++
++ test -n "$CURL_CONFIG" && break
++done
++
++fi
++
++oCPPFLAGS="$CPPFLAGS"
++CPPFLAGS="$CPPFLAGS `$CURL_CONFIG --cflags`"
+
+ for ac_header in errno.h stdlib.h unistd.h string.h limits.h dmalloc.h getopt.h sys/stat.h curl/curl.h libxml/nanohttp.h sys/param.h sys/time.h
+ do
+@@ -20037,6 +20105,9 @@
+
+ done
+
++CPPFLAGS="$oCPPFLAGS"
++LIBS="$oLIBS"
++
+ { echo "$as_me:$LINENO: checking whether time.h and sys/time.h may both be included" >&5
+ echo $ECHO_N "checking whether time.h and sys/time.h may both be included... $ECHO_C" >&6; }
+ if test "${ac_cv_header_time+set}" = set; then
+@@ -23931,72 +24002,6 @@
+ fi
+
+
+-# Check whether --with-curl-config was given.
+-if test "${with_curl_config+set}" = set; then
+- withval=$with_curl_config; curl_config="$withval"
+-else
+- curl_config=""
+-fi
+-
+-
+-if test "X$curl_config" != "X" ; then
+- { echo "$as_me:$LINENO: checking for $curl_config" >&5
+-echo $ECHO_N "checking for $curl_config... $ECHO_C" >&6; }
+-
+- if test -f $curl_config ; then
+- CURL_CONFIG=$curl_config
+- { echo "$as_me:$LINENO: result: yes" >&5
+-echo "${ECHO_T}yes" >&6; }
+- else
+- { echo "$as_me:$LINENO: result: no - searching PATH" >&5
+-echo "${ECHO_T}no - searching PATH" >&6; }
+- fi
+-fi
+-if test "X$CURL_CONFIG" = "X"; then
+- for ac_prog in curl-config
+-do
+- # Extract the first word of "$ac_prog", so it can be a program name with args.
+-set dummy $ac_prog; ac_word=$2
+-{ echo "$as_me:$LINENO: checking for $ac_word" >&5
+-echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
+-if test "${ac_cv_prog_CURL_CONFIG+set}" = set; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+- if test -n "$CURL_CONFIG"; then
+- ac_cv_prog_CURL_CONFIG="$CURL_CONFIG" # Let the user override the test.
+-else
+-as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+-for as_dir in $PATH
+-do
+- IFS=$as_save_IFS
+- test -z "$as_dir" && as_dir=.
+- for ac_exec_ext in '' $ac_executable_extensions; do
+- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; }; then
+- ac_cv_prog_CURL_CONFIG="$ac_prog"
+- echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
+- break 2
+- fi
+-done
+-done
+-IFS=$as_save_IFS
+-
+-fi
+-fi
+-CURL_CONFIG=$ac_cv_prog_CURL_CONFIG
+-if test -n "$CURL_CONFIG"; then
+- { echo "$as_me:$LINENO: result: $CURL_CONFIG" >&5
+-echo "${ECHO_T}$CURL_CONFIG" >&6; }
+-else
+- { echo "$as_me:$LINENO: result: no" >&5
+-echo "${ECHO_T}no" >&6; }
+-fi
+-
+-
+- test -n "$CURL_CONFIG" && break
+-done
+-
+-fi
+-
+
+ oLIBS="$LIBS"
+
+@@ -25623,7 +25628,9 @@
+
+ oCPPFLAGS="$CPPFLAGS"
+ if test "X$CURL_CONFIG" != X; then
++ oCPPFLAGS="$CPPFLAGS"
+ oLIBS="$LIBS"
++ CPPFLAGS="$CPPFLAGS `$CURL_CONFIG --cflags`"
+ LIBS="$LIBS `$CURL_CONFIG --libs`"
+ { echo "$as_me:$LINENO: checking for curl_easy_init" >&5
+ echo $ECHO_N "checking for curl_easy_init... $ECHO_C" >&6; }
+@@ -25728,6 +25735,7 @@
+ have_curl_easy_init=no
+ fi
+
++ CPPFLAGS="$oCPPFLAGS"
+ LIBS="$oLIBS"
+ { echo "$as_me:$LINENO: checking for libcurl library" >&5
+ echo $ECHO_N "checking for libcurl library... $ECHO_C" >&6; }