aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2015-10-08 03:28:47 +0800
committerolivierd <olivierd@FreeBSD.org>2015-10-08 03:28:47 +0800
commite9b748f05833285bf152ea573715110030e2eb0d (patch)
tree06979e0028a737e777e825544c6b3617f94b4ff4 /textproc
parent7d1ec7c80a18b26a6c0b4376c22af145725a2b05 (diff)
downloadfreebsd-ports-graphics-e9b748f05833285bf152ea573715110030e2eb0d.tar.gz
freebsd-ports-graphics-e9b748f05833285bf152ea573715110030e2eb0d.tar.zst
freebsd-ports-graphics-e9b748f05833285bf152ea573715110030e2eb0d.zip
cmark is the C reference implementation of CommonMark, a rationalized
version of Markdown syntax with a spec. It provides a shared library (libcmark) with functions for parsing CommonMark documents to an abstract syntax tree (AST), manipulating the AST, and rendering the document to HTML, groff man, LaTeX, CommonMark, or an XML representation of the AST. It also provides a command-line program (cmark) for parsing and rendering CommonMark documents. WWW: https://github.com/jgm/cmark PR: 203532 Submitted by: Tobias Kortkamp <t@tobik.me>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/cmark/Makefile21
-rw-r--r--textproc/cmark/distinfo2
-rw-r--r--textproc/cmark/files/patch-src_CMakeLists.txt11
-rw-r--r--textproc/cmark/pkg-descr11
-rw-r--r--textproc/cmark/pkg-plist9
6 files changed, 55 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index e3673744cc2..6c19f271a45 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -83,6 +83,7 @@
SUBDIR += clucene
SUBDIR += clucene-qt4
SUBDIR += clucene-qt5
+ SUBDIR += cmark
SUBDIR += coccigrep
SUBDIR += code2html
SUBDIR += codespell
diff --git a/textproc/cmark/Makefile b/textproc/cmark/Makefile
new file mode 100644
index 00000000000..b06a8845937
--- /dev/null
+++ b/textproc/cmark/Makefile
@@ -0,0 +1,21 @@
+# Created by: Tobias Kortkamp <t@tobik.me>
+# $FreeBSD$
+
+PORTNAME= cmark
+PORTVERSION= 0.22.0
+CATEGORIES= textproc
+
+MAINTAINER= t@tobik.me
+COMMENT= CommonMark parsing and rendering library and program in C
+
+LICENSE= BSD2CLAUSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= jgm
+
+USES= cmake:outsource
+
+post-patch:
+ ${REINPLACE_CMD} -i "" 's|share/||g' ${WRKSRC}/man/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/textproc/cmark/distinfo b/textproc/cmark/distinfo
new file mode 100644
index 00000000000..493c3ce9393
--- /dev/null
+++ b/textproc/cmark/distinfo
@@ -0,0 +1,2 @@
+SHA256 (jgm-cmark-0.22.0_GH0.tar.gz) = a45956e6ee491d71e9271ddeb09364599a136b8956d219f0168dd6042f6f791b
+SIZE (jgm-cmark-0.22.0_GH0.tar.gz) = 213617
diff --git a/textproc/cmark/files/patch-src_CMakeLists.txt b/textproc/cmark/files/patch-src_CMakeLists.txt
new file mode 100644
index 00000000000..53d43f3f34f
--- /dev/null
+++ b/textproc/cmark/files/patch-src_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- src/CMakeLists.txt.orig 2015-10-04 10:17:08 UTC
++++ src/CMakeLists.txt
+@@ -55,7 +55,7 @@ configure_file(${CMAKE_CURRENT_SOURCE_DI
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/libcmark.pc.in
+ ${CMAKE_CURRENT_BINARY_DIR}/libcmark.pc @ONLY)
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/libcmark.pc
+- DESTINATION lib/pkgconfig)
++ DESTINATION libdata/pkgconfig)
+
+ include (GenerateExportHeader)
+
diff --git a/textproc/cmark/pkg-descr b/textproc/cmark/pkg-descr
new file mode 100644
index 00000000000..60acec98b0d
--- /dev/null
+++ b/textproc/cmark/pkg-descr
@@ -0,0 +1,11 @@
+cmark is the C reference implementation of CommonMark, a rationalized
+version of Markdown syntax with a spec.
+
+It provides a shared library (libcmark) with functions for parsing
+CommonMark documents to an abstract syntax tree (AST), manipulating
+the AST, and rendering the document to HTML, groff man, LaTeX,
+CommonMark, or an XML representation of the AST. It also provides a
+command-line program (cmark) for parsing and rendering CommonMark
+documents.
+
+WWW: https://github.com/jgm/cmark
diff --git a/textproc/cmark/pkg-plist b/textproc/cmark/pkg-plist
new file mode 100644
index 00000000000..13d09aa5d32
--- /dev/null
+++ b/textproc/cmark/pkg-plist
@@ -0,0 +1,9 @@
+bin/cmark
+include/cmark.h
+include/cmark_export.h
+include/cmark_version.h
+lib/libcmark.so
+lib/libcmark.so.0.22.0
+libdata/pkgconfig/libcmark.pc
+man/man1/cmark.1.gz
+man/man3/cmark.3.gz