aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-06-10 13:20:03 +0800
committerwill <will@FreeBSD.org>2000-06-10 13:20:03 +0800
commiteeaf0cb4a1b3fff94d351be3e4cc15f459ce0d1d (patch)
tree6da1da00214227984bc5d09d23be9b075f780803 /textproc
parentb3fa8b7f7199b605c562d1a9f11f78c1eab8346d (diff)
downloadfreebsd-ports-graphics-eeaf0cb4a1b3fff94d351be3e4cc15f459ce0d1d.tar.gz
freebsd-ports-graphics-eeaf0cb4a1b3fff94d351be3e4cc15f459ce0d1d.tar.zst
freebsd-ports-graphics-eeaf0cb4a1b3fff94d351be3e4cc15f459ce0d1d.zip
Add cost, a structure-controlled SGML/XML application programming tool.
PR: 18855 Submitted by: Allan Bowhill <bowhill@bowhill.vservers.com>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/cost/Makefile39
-rw-r--r--textproc/cost/distinfo1
-rw-r--r--textproc/cost/pkg-comment1
-rw-r--r--textproc/cost/pkg-descr5
-rw-r--r--textproc/cost/pkg-plist21
6 files changed, 68 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index f07758d0d3b..1b345dad38d 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -12,6 +12,7 @@
SUBDIR += cocoon
SUBDIR += code2html
SUBDIR += cole
+ SUBDIR += cost
SUBDIR += de-ispell
SUBDIR += dealt-ispell
SUBDIR += deneu-ispell
diff --git a/textproc/cost/Makefile b/textproc/cost/Makefile
new file mode 100644
index 00000000000..b5f590cf1b9
--- /dev/null
+++ b/textproc/cost/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: costsh
+# Date created: May 22, 2000
+# Whom: Allan Bowhill <kosmos@blarg.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cost
+PORTVERSION= 2.2p1
+CATEGORIES= textproc tk82
+MASTER_SITES= http://www.flightlab.com/~joe/cost/ \
+ ftp://bowhill.vservers.com/pub/
+
+MAINTAINER= kosmos@blarg.net
+
+LIB_DEPENDS= tcl82.1:${PORTSDIR}/lang/tcl82
+BUILD_DEPENDS= ${WRKDIRPREFIXPORTSDIR}/lang/tcl82/work/tcl-8.2.3/src:${PORTSDIR}/lang/tcl82:patch
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+HAS_CONFIGURE= YES
+CONFIGURE_ARGS= --with-tcl=${PREFIX}/lib/tcl8.2 \
+ --with-docdir=${PREFIX}/share/doc/cost --with-charmaps
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/cost2.2
+ ${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME}/lib/*.tcl ${PREFIX}/lib/cost2.2
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/lib/*.spec ${PREFIX}/lib/cost2.2
+ ${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME}/lib/*.itcl ${PREFIX}/lib/cost2.2
+ ${INSTALL_DATA} ${WRKSRC}/libcost2.2.so ${PREFIX}/lib/cost2.2
+ ${INSTALL_PROGRAM} ${WRKSRC}/costsh ${PREFIX}/bin/costsh
+
+.if !defined(NOPORTDOCS)
+ @${ECHO} "===> Installing Cost documentation"
+ @${MKDIR} ${PREFIX}/share/doc/cost && ${CHMOD} a+rx ${PREFIX}/share/doc/cost
+ @cd ${WRKDIR}/${DISTNAME}/doc; && ${INSTALL_MAN} manual.html manual.ps rtflib.html simple.html \
+ ${PREFIX}/share/doc/cost
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/cost/distinfo b/textproc/cost/distinfo
new file mode 100644
index 00000000000..39459d95b68
--- /dev/null
+++ b/textproc/cost/distinfo
@@ -0,0 +1 @@
+MD5 (cost-2.2p1.tar.gz) = 8249c0558e7df158245a9b0f1f40bebe
diff --git a/textproc/cost/pkg-comment b/textproc/cost/pkg-comment
new file mode 100644
index 00000000000..de1ba2f4197
--- /dev/null
+++ b/textproc/cost/pkg-comment
@@ -0,0 +1 @@
+SGML/XML application programming tool
diff --git a/textproc/cost/pkg-descr b/textproc/cost/pkg-descr
new file mode 100644
index 00000000000..cd298fefb8f
--- /dev/null
+++ b/textproc/cost/pkg-descr
@@ -0,0 +1,5 @@
+Cost is a structure-controlled SGML/XML application programming tool.
+It is implemented as a Tcl extension, and works in conjunction
+with James Clark's nsgmls, sgmls, and/or expat parsers.
+
+WWW: http://www.flightlab.com/cost/
diff --git a/textproc/cost/pkg-plist b/textproc/cost/pkg-plist
new file mode 100644
index 00000000000..d7cf154f40e
--- /dev/null
+++ b/textproc/cost/pkg-plist
@@ -0,0 +1,21 @@
+bin/costsh
+lib/cost2.2/libcost2.2.so
+lib/cost2.2/Core.tcl
+lib/cost2.2/Counters.tcl
+lib/cost2.2/Numerals.tcl
+lib/cost2.2/Simple.tcl
+lib/cost2.2/auxfile.tcl
+lib/cost2.2/costinit.tcl
+lib/cost2.2/htmllib.tcl
+lib/cost2.2/pkgIndex.tcl
+lib/cost2.2/rtflib.tcl
+lib/cost2.2/textutil.tcl
+lib/cost2.2/winhelp-stylesheet.tcl
+lib/cost2.2/RTF.spec
+lib/cost2.2/EventHandler.itcl
+share/doc/cost/manual.html
+share/doc/cost/manual.ps
+share/doc/cost/rtflib.html
+share/doc/cost/simple.html
+@dirrm share/doc/cost
+@dirrm lib/cost2.2