aboutsummaryrefslogtreecommitdiffstats
path: root/www/apache13-fp/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-09-27 10:52:26 +0800
committersteve <steve@FreeBSD.org>1999-09-27 10:52:26 +0800
commitb85fc2c18af0661c6428ba9988e97b3158f5c328 (patch)
tree23ee3f34b245fadedef2db446d8eb8fbd5945183 /www/apache13-fp/Makefile
parent2c541af9aa3758bce2c11ef3d2ffa05a26b427bf (diff)
downloadfreebsd-ports-graphics-b85fc2c18af0661c6428ba9988e97b3158f5c328.tar.gz
freebsd-ports-graphics-b85fc2c18af0661c6428ba9988e97b3158f5c328.tar.zst
freebsd-ports-graphics-b85fc2c18af0661c6428ba9988e97b3158f5c328.zip
Update to use Apache version 1.3.9. Misc. notes from maintainer:
patch-au corrects a problem when either ResourceConfig/AccessConfig is set to the apache configuration file (${PREFIX}/etc/apache/httpd.conf). Without this patch, if you set the apache server to listen to alterate ports the server would fail to start and the error log would contain: [crit] (48)Address already in use: make_sock: could not bind to port 8000 ResourceConfig/AccessConfig can't be set to /dev/null. The fpsrvadm.exe will not be able to obtain the DocumnetRoot from the ResourceConfig file (/dev/null). PR: 13673 Submitted by: maintainer
Diffstat (limited to 'www/apache13-fp/Makefile')
-rw-r--r--www/apache13-fp/Makefile75
1 files changed, 53 insertions, 22 deletions
diff --git a/www/apache13-fp/Makefile b/www/apache13-fp/Makefile
index df64e0274c3..b9b407103c2 100644
--- a/www/apache13-fp/Makefile
+++ b/www/apache13-fp/Makefile
@@ -39,7 +39,7 @@ PATCH_DIST_ARGS= -d ${WRKSRC}/src -E ${PATCH_DIST_STRIP}
PATCH_DIST_ARGS= -d ${WRKSRC}/src --forward --quiet -E ${PATCH_DIST_STRIP}
.endif
-AP_VERS= 1.3.6
+AP_VERS= 1.3.9
APACHE= ${DISTNAME}${EXTRACT_SUFX}
FRONTPAGE= fp30.bsdi3.tar.Z
@@ -56,43 +56,52 @@ MOD_FP= ${FILESDIR}/mod_frontpage.c
INSTALL_FILE=${INSTALL} -c -m 555 -o bin -g bin
Y2K= http://www.apache.org/docs/misc/FAQ.html#year2000
+Y2K+= http://computingcentral.msn.com/guide/year2000/msy2k/productinfo/frontpage.asp
+
+PLIST= ${WRKDIR}/PLIST
#
# Set APACHE_PERF_TUNING env. variable to YES to get maximum performance
#
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= \
- --prefix=${PREFIX} \
+CONFIGURE_ARGS= --prefix=${PREFIX} \
--with-layout=GNU \
+ --with-perl=${PERL} \
+ --bindir=${PREFIX}/bin \
+ --sbindir=${PREFIX}/sbin \
+ --libexecdir=${PREFIX}/libexec/apache \
+ --mandir=${PREFIX}/man \
--sysconfdir=${PREFIX}/etc/apache \
+ --datadir=${PREFIX}/www \
--includedir=${PREFIX}/include/apache \
--localstatedir=/var \
- --datadir=${PREFIX}/www \
- --proxycachedir=${PREFIX}/www/proxy \
- --libexecdir=${PREFIX}/libexec/apache \
+ --runtimedir=/var/run \
+ --logfiledir=/var/log \
+ --proxycachedir=/var/spool/proxy \
--without-confadjust \
- --enable-shared=remain \
--enable-module=most \
--enable-module=auth_db \
--disable-module=auth_dbm \
--add-module=${MOD_FP} \
- --enable-shared=frontpage
+ --enable-shared=frontpage \
+ --enable-shared=max
# Currently perl version doesn't matter
USE_PERL5= YES
-CONFIGURE_ARGS+= --with-perl=${PERL5}
-OPTIM=-DHARD_SERVER_LIMIT=512 \
--DDOCUMENT_LOCATION=\\"${PREFIX}/www/data/\\" \
--DDEFAULT_PATH=\\"/bin:/usr/bin:${PREFIX}/bin\\"
+OPTIM= -DHARD_SERVER_LIMIT=512 \
+ -DDOCUMENT_LOCATION=\\"${PREFIX}/www/data/\\" \
+ -DDEFAULT_PATH=\\"/bin:/usr/bin:${PREFIX}/bin\\"
-.if defined(APACHE_PERF_TUNING) && ${APACHE_PERF_TUNING} == YES
-OPTIM+= -DBUFFERED_LOGS
-CFLAGS+= -O6 -fomit-frame-pointer
+.if defined(APACHE_PERF_TUNING)
+OPTIM+= -DBUFFERED_LOGS -DFD_SETSIZE=1024
+CFLAGS+= -O6 -funroll-loops -fstrength-reduce -fomit-frame-pointer \
+ -fexpensive-optimizations -ffast-math
.endif
-CONFIGURE_ENV= OPTIM='${OPTIM}'
+CONFIGURE_ENV= CFLAGS='${CFLAGS}' \
+ OPTIM='${OPTIM}'
MAN1= dbmmanage.1 htdigest.1 htpasswd.1
MAN8= ab.8 apachectl.8 apxs.8 httpd.8 logresolve.8 rotatelogs.8
@@ -121,14 +130,36 @@ pre-extract:
post-extract:
@${ECHO} "===> Extracting FrontPage install scripts"
@cd ${WRKSRC} && \
- ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${FRONTPAGE} ${EXTRACT_AFTER_ARGS} ${FPINSTALL} ${CHANGESERVER}
+ ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${FRONTPAGE} \
+ ${EXTRACT_AFTER_ARGS} ${FPINSTALL} ${CHANGESERVER}
+
+.if !defined(PATCH_DEBUG)
+post-patch:
+ @ cd ${WRKSRC} \
+ && find . -type f -name "*.orig" -print | xargs ${RM} -f
+.endif
+
+post-configure:
+.if defined(SUEXEC)
+ ${CP} ${PKGDIR}/PLIST ${PLIST}
+.else
+ ${CAT} ${PKGDIR}/PLIST | grep -v sbin/suexec >${PLIST}
+.endif
post-install:
- @${ECHO} "Installing ${PREFIX}/etc/rc.d/apache.sh file."
- @${CAT} ${FILESDIR}/apache.sh.tmpl | \
- ${SED} -e 's;PREFIX;${PREFIX};' -e 's;PERL5;${PERL};' \
- > ${PREFIX}/etc/rc.d/apache.sh
- @${CHMOD} 751 ${PREFIX}/etc/rc.d/apache.sh
+ @if [ ! -f ${PREFIX}/${FPINSTALL} ]; then \
+ ${MAKE} fp-install ; \
+ fi
+ @if [ ! -f ${PREFIX}/etc/rc.d/apache.sh ]; then \
+ ${ECHO} "Installing ${PREFIX}/etc/rc.d/apache.sh file."; \
+ ${CAT} ${FILESDIR}/apache.sh.tmpl | \
+ ${SED} -e 's;PREFIX;${PREFIX};' \
+ -e 's;PERL5;${PERL};' \
+ > ${PREFIX}/etc/rc.d/apache.sh; \
+ ${CHMOD} 751 ${PREFIX}/etc/rc.d/apache.sh; \
+ fi
+
+fp-install:
@${CAT} ${WRKSRC}/${FPINSTALL} | \
${SED} -e 's;PREFIX;${PREFIX};' > ${WRKDIR}/tmp.fpinstall
@${SH} ${WRKDIR}/tmp.fpinstall