aboutsummaryrefslogtreecommitdiffstats
path: root/www/apache2/files
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2005-07-26 16:25:13 +0800
committerclement <clement@FreeBSD.org>2005-07-26 16:25:13 +0800
commit051c2b7e5f4af9c3ed4f36e2421b73a3f0c9de40 (patch)
treee17dc127919d3064cc1912d059343be2096e578a /www/apache2/files
parentc0cb020fd929842f3e720c25db3bfc98c9130398 (diff)
downloadfreebsd-ports-graphics-051c2b7e5f4af9c3ed4f36e2421b73a3f0c9de40.tar.gz
freebsd-ports-graphics-051c2b7e5f4af9c3ed4f36e2421b73a3f0c9de40.tar.zst
freebsd-ports-graphics-051c2b7e5f4af9c3ed4f36e2421b73a3f0c9de40.zip
Security: fix a buffer overrun in ssl_callback_SSLVerify_CRL()
Reported by: thierry
Diffstat (limited to 'www/apache2/files')
-rw-r--r--www/apache2/files/patch-secfix-ssl_engine_kernel.c11
1 files changed, 11 insertions, 0 deletions
diff --git a/www/apache2/files/patch-secfix-ssl_engine_kernel.c b/www/apache2/files/patch-secfix-ssl_engine_kernel.c
new file mode 100644
index 00000000000..3b8be849954
--- /dev/null
+++ b/www/apache2/files/patch-secfix-ssl_engine_kernel.c
@@ -0,0 +1,11 @@
+--- modules/ssl/ssl_engine_kernel.c 2005/06/08 09:00:24 189561
++++ modules/ssl/ssl_engine_kernel.c 2005/06/08 09:08:09 189562
+@@ -1398,7 +1398,7 @@
+ BIO_printf(bio, ", nextUpdate: ");
+ ASN1_UTCTIME_print(bio, X509_CRL_get_nextUpdate(crl));
+
+- n = BIO_read(bio, buff, sizeof(buff));
++ n = BIO_read(bio, buff, sizeof(buff) - 1);
+ buff[n] = '\0';
+
+ BIO_free(bio);
mt/ourmon?h=mate-1.16&id=4500e6f95eef76996051b447f00584b31e4abedf'>In the rc.d scripts, change assignments to rcvar to use thedougb2012-01-141-1/+1 * - change required APACHE version from 13+ to 20+ohauer2012-01-021-1/+1 * - bump PORTREVISION from ports if USE_APACHE=13+ or 20+ is definedohauer2011-08-211-1/+1 * - set IS_INTERACTIVE=yesohauer2011-07-194-246/+640 * - Get Rid MD5 supportmiwi2011-03-201-1/+0 * - update to 1.4.1dinoex2010-03-281-1/+1 * Begin the process of deprecating sysutils/rc_subr bydougb2010-03-271-1/+1 * - Switch SourceForge ports to the new File Release System: categories startin...amdmi32009-08-221-1/+1 * - USE_APACHE=yes is deprecatedpgollucci2009-04-291-1/+1 * - Chase rrdtool 1.3.0 update, bump PORTREVISIONrafan2008-06-241-1/+1 * - Fix pkg-plist.araujo2008-05-212-16/+2 * - Fix typo.lippe2008-05-181-1/+2 * - Update to 2.8.1.lippe2008-05-177-237/+409 * First steps in a big migration:edwin2007-07-051-1/+1 * - Welcome X.org 7.2 \o/.flz2007-05-201-0/+1 * SHA256ifyedwin2006-01-241-1/+2 * Change spaces to tab.linimon2005-11-291-1/+1