aboutsummaryrefslogtreecommitdiffstats
path: root/www/apache22
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2008-09-01 00:51:38 +0800
committerclement <clement@FreeBSD.org>2008-09-01 00:51:38 +0800
commite751c1a59b4a3dc7a6c689e39d4914843e40fd81 (patch)
tree74b22b9c05877920a4ccc13da024ee37221d1d35 /www/apache22
parent0fe80b4d3031b869faa5ac8b5c17e1c3c9f0b635 (diff)
downloadfreebsd-ports-graphics-e751c1a59b4a3dc7a6c689e39d4914843e40fd81.tar.gz
freebsd-ports-graphics-e751c1a59b4a3dc7a6c689e39d4914843e40fd81.tar.zst
freebsd-ports-graphics-e751c1a59b4a3dc7a6c689e39d4914843e40fd81.zip
- Fix plist when NOPORTDOCS is defined [1]
- Add WITH_SVN knob. It enables BDB for apache22 port and force dependency on dev/apr-svn when WITH_APR_FROM_PORTS is defined. (should help fixing [2]). Introduce APR_PORT. - Add support for db-4.7 [3] - Add mod_ldap OPTIONS fixup [4] - Sometimes, rc scripts aren't included in package Try to fix this. [5] PR: ports/126053 [2], ports/125520 [3] ports/124651 [4], ports/126670 [5] (partially) Reported by: QA Tindy [1], Crazig Leres [2], Larry Rosenman [4] Kirk Strauser [3], Joseph S. Atkinson [5]
Diffstat (limited to 'www/apache22')
-rw-r--r--www/apache22/Makefile21
-rw-r--r--www/apache22/files/patch-srclib:apr-util:build:dbm.m4140
-rw-r--r--www/apache22/pkg-plist1
3 files changed, 150 insertions, 12 deletions
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index 60c14d8bea0..99ec832b809 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -9,6 +9,7 @@
PORTNAME= apache
PORTVERSION= 2.2.9
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
DISTNAME= httpd-${PORTVERSION}
@@ -16,7 +17,7 @@ DISTFILES= ${DISTNAME}.tar.bz2
DIST_SUBDIR= apache22
MAINTAINER?= clement@FreeBSD.org
-COMMENT?= Version 2.2 of Apache web server with ${WITH_MPM:L} MPM.
+COMMENT?= Version 2.2.x of Apache web server with ${WITH_MPM:L} MPM.
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
@@ -41,7 +42,7 @@ USE_ICONV= yes
USE_AUTOTOOLS= autoconf:262 libtool:15
USE_PERL5= yes
USE_RC_SUBR= apache22.sh htcacheclean.sh
-SUB_LIST+= RC_SUBR_SUFFIX=${RC_SUBR_SUFFIX}
+#SUB_LIST+= RC_SUBR_SUFFIX=${RC_SUBR_SUFFIX}
LIBTOOLFILES= configure
# for slave ports
@@ -60,7 +61,8 @@ OPTIONS= \
SQLITE "Enable SQLite support for apr-dbd" Off \
IPV6 "Enable IPv6 support" On \
PCRE_FROM_PORTS "Use devel/pcre instead of bundled one" Off \
- BDB "Enable BerkeleyDB dbm" Off
+ BDB "Enable BerkeleyDB dbm" Off \
+ SVN "Enable Subversion support" Off
.include "${APACHEDIR}/Makefile.options"
.endif
@@ -104,6 +106,16 @@ CONFIGURE_ARGS+= --enable-exception-hook
.include "${APACHEDIR}/Makefile.doc"
.include "${APACHEDIR}/Makefile.modules"
.include <bsd.port.pre.mk>
+
+# OPTIONS fixups
+.if defined(WITH_SVN)
+APR_PORT= devel/apr-svn
+WITH_BDB= YES
+.endif
+.if defined (WITH_AUTHNZ_LDAP)
+WITH_LDAP= yes
+.endif
+
.include "${APACHEDIR}/Makefile.modules"
.if (defined(WITH_SSL)|| !defined(WITHOUT_SSL_MODULES))
@@ -115,7 +127,8 @@ LDFLAGS+= -L${OPENSSLLIB}
.if defined(WITH_APR_FROM_PORTS)
PLIST_SUB+= APR_PORTS="@comment "
-LIB_DEPENDS+= apr-1:${PORTSDIR}/devel/apr
+APR_PORT?= devel/apr
+LIB_DEPENDS+= apr-1:${PORTSDIR}/${APR_PORT}
CONFIGURE_ARGS+= --with-apr=${LOCALBASE}/bin/apr-1-config \
--with-apr-util=${LOCALBASE}/bin/apu-1-config
CONFIGURE_ENV+= LTFLAGS="--tag=CXX"
diff --git a/www/apache22/files/patch-srclib:apr-util:build:dbm.m4 b/www/apache22/files/patch-srclib:apr-util:build:dbm.m4
index 972b7d9a0a3..25c9242e8d7 100644
--- a/www/apache22/files/patch-srclib:apr-util:build:dbm.m4
+++ b/www/apache22/files/patch-srclib:apr-util:build:dbm.m4
@@ -1,6 +1,6 @@
---- srclib/apr-util/build/dbm.m4.orig Thu Feb 24 10:23:34 2005
-+++ srclib/apr-util/build/dbm.m4 Sun Oct 30 19:44:43 2005
-@@ -314,8 +314,8 @@
+--- srclib/apr-util/build/dbm.m4.orig 2008-05-28 16:27:01.000000000 +0000
++++ srclib/apr-util/build/dbm.m4 2008-07-11 20:32:59.000000000 +0000
+@@ -315,8 +315,8 @@
fi
APU_CHECK_BERKELEY_DB(1, -1, -1,
"$places",
@@ -11,7 +11,7 @@
)
if test "$apu_have_db" = "1"; then
apu_db_version=185
-@@ -357,7 +357,7 @@
+@@ -358,7 +358,7 @@
APU_CHECK_BERKELEY_DB(3, -1, -1,
"$places",
"db3/db.h db.h",
@@ -20,7 +20,7 @@
)
if test "$apu_have_db" = "1"; then
apu_db_version=3
-@@ -377,8 +377,8 @@
+@@ -378,8 +378,8 @@
fi
APU_CHECK_BERKELEY_DB("4", "0", "-1",
"$places",
@@ -31,7 +31,7 @@
)
if test "$apu_have_db" = "1"; then
apu_db_version=4
-@@ -398,8 +398,8 @@
+@@ -399,8 +399,8 @@
fi
APU_CHECK_BERKELEY_DB("4", "1", "-1",
"$places",
@@ -42,7 +42,7 @@
)
if test "$apu_have_db" = "1"; then
apu_db_version=4
-@@ -419,8 +419,8 @@
+@@ -420,8 +420,8 @@
fi
APU_CHECK_BERKELEY_DB("4", "2", "-1",
"$places",
@@ -53,7 +53,7 @@
)
if test "$apu_have_db" = "1"; then
apu_db_version=4
-@@ -438,8 +438,8 @@
+@@ -439,8 +439,8 @@
fi
APU_CHECK_BERKELEY_DB("4", "3", "-1",
"$places",
@@ -64,3 +64,127 @@
)
if test "$apu_have_db" = "1"; then
apu_db_version=4
+@@ -503,6 +503,25 @@
+ apu_db_version=4
+ fi
+ ])
++dnl
++dnl APU_CHECK_DB47: is DB4.7 present?
++dnl
++dnl if present: sets apu_db_header, apu_db_lib, and apu_db_version
++dnl
++AC_DEFUN([APU_CHECK_DB47], [
++ places=$1
++ if test -z "$places"; then
++ places="std /usr/local/BerkeleyDB.4.7 /boot/home/config"
++ fi
++ APU_CHECK_BERKELEY_DB("4", "7", "-1",
++ "$places",
++ "db47/db.h db4/db.h db.h",
++ "db-4.7 db4-4.7 db47 db4 db"
++ )
++ if test "$apu_have_db" = "1"; then
++ apu_db_version=4
++ fi
++])
+
+ AC_DEFUN([APU_CHECK_DB], [
+ requested=$1
+@@ -581,6 +600,12 @@
+ AC_MSG_ERROR(Berkeley db4 not found)
+ fi
+ ;;
++ db47)
++ APU_CHECK_DB47("$check_places")
++ if test "$apu_db_version" != "4"; then
++ AC_MSG_ERROR(Berkeley db4 not found)
++ fi
++ ;;
+ default)
+ APU_CHECK_DB_ALL("$check_places")
+ ;;
+@@ -588,32 +613,35 @@
+ ])
+
+ dnl
+-dnl APU_CHECK_DB_ALL: Try all Berkeley DB versions, from 4.6 to 1.
++dnl APU_CHECK_DB_ALL: Try all Berkeley DB versions, from 4.7 to 1.
+ dnl
+ AC_DEFUN([APU_CHECK_DB_ALL], [
+ all_places=$1
+
+- APU_CHECK_DB46("$all_places")
++ APU_CHECK_DB47("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB45("$all_places")
++ APU_CHECK_DB46("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB44("$all_places")
++ APU_CHECK_DB45("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB43("$all_places")
++ APU_CHECK_DB44("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB42("$all_places")
++ APU_CHECK_DB43("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB41("$all_places")
++ APU_CHECK_DB42("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB4("$all_places")
++ APU_CHECK_DB41("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB3("$all_places")
+- if test "$apu_db_version" != "3"; then
+- APU_CHECK_DB2("$all_places")
+- if test "$apu_db_version" != "2"; then
+- APU_CHECK_DB1("$all_places")
+- if test "$apu_db_version" != "1"; then
+- APU_CHECK_DB185("$all_places")
++ APU_CHECK_DB4("$all_places")
++ if test "$apu_db_version" != "4"; then
++ APU_CHECK_DB3("$all_places")
++ if test "$apu_db_version" != "3"; then
++ APU_CHECK_DB2("$all_places")
++ if test "$apu_db_version" != "2"; then
++ APU_CHECK_DB1("$all_places")
++ if test "$apu_db_version" != "1"; then
++ APU_CHECK_DB185("$all_places")
++ fi
+ fi
+ fi
+ fi
+@@ -651,11 +679,11 @@
+ apu_db_version=0
+
+ AC_ARG_WITH(dbm, [APR_HELP_STRING([--with-dbm=DBM], [choose the DBM type to use.
+- DBM={sdbm,gdbm,ndbm,db,db1,db185,db2,db3,db4,db41,db42,db43,db44,db45,db46}])],
++ DBM={sdbm,gdbm,ndbm,db,db1,db185,db2,db3,db4,db41,db42,db43,db44,db45,db46,db47}])],
+ [
+ if test "$withval" = "yes"; then
+ AC_MSG_ERROR([--with-dbm needs to specify a DBM type to use.
+- One of: sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4, db41, db42, db43, db44, db45, db46])
++ One of: sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4, db41, db42, db43, db44, db45, db46, db47])
+ fi
+ requested="$withval"
+ ], [
+@@ -850,6 +878,10 @@
+ apu_use_db=1
+ apu_default_dbm=db4
+ ;;
++ db47)
++ apu_use_db=1
++ apu_default_dbm=db4
++ ;;
+ default)
+ dnl ### use more sophisticated DBMs for the default?
+ apu_default_dbm="sdbm (default)"
+@@ -857,7 +889,7 @@
+ ;;
+ *)
+ AC_MSG_ERROR([--with-dbm=$look_for is an unknown DBM type.
+- Use one of: sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4, db41, db42, db43, db44, db45, db46])
++ Use one of: sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4, db41, db42, db43, db44, db45, db46, db47])
+ ;;
+ esac
+
diff --git a/www/apache22/pkg-plist b/www/apache22/pkg-plist
index 8fa4f01fb04..b9480906fea 100644
--- a/www/apache22/pkg-plist
+++ b/www/apache22/pkg-plist
@@ -533,6 +533,7 @@ www/apache22/icons/world2.png
@dirrmtry www/apache22/cgi-bin
@dirrm %%EXAMPLESDIR%%/extra
@dirrm %%EXAMPLESDIR%%
+@dirrm %%DOCSDIR%%
@dirrm share/apache22/build
@dirrm share/apache22
%%APR_PORTS%%@dirrm include/apr-1