aboutsummaryrefslogtreecommitdiffstats
path: root/www/checkbot
diff options
context:
space:
mode:
authorwosch <wosch@FreeBSD.org>2003-07-31 17:20:12 +0800
committerwosch <wosch@FreeBSD.org>2003-07-31 17:20:12 +0800
commita516cdafd5e871f3d9fbd85dd43df350856f12a5 (patch)
tree087069369abbcf9dfd1e7a51c3075984e0ac60d2 /www/checkbot
parent5d0c599a6fdda32abe7d1f186ec6056d57b0181e (diff)
downloadfreebsd-ports-graphics-a516cdafd5e871f3d9fbd85dd43df350856f12a5.tar.gz
freebsd-ports-graphics-a516cdafd5e871f3d9fbd85dd43df350856f12a5.tar.zst
freebsd-ports-graphics-a516cdafd5e871f3d9fbd85dd43df350856f12a5.zip
Fix package building problems on bento.
Not sure if this fully resolves the issue, but it fixes local tests. PR: ports/55074 Submitted by: Lars Eggert <larse@isi.edu>
Diffstat (limited to 'www/checkbot')
-rw-r--r--www/checkbot/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/www/checkbot/Makefile b/www/checkbot/Makefile
index a92f6e49e75..18fa1cf78be 100644
--- a/www/checkbot/Makefile
+++ b/www/checkbot/Makefile
@@ -14,8 +14,7 @@ MASTER_SITES= http://degraaff.org/checkbot/ \
MAINTAINER= wosch@FreeBSD.org
COMMENT= A WWW link verifier, similar like momspider
-RUN_DEPENDS= \
- ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+RUN_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
${SITE_PERL}/Net/FTP.pm:${PORTSDIR}/net/p5-Net \
@@ -23,9 +22,14 @@ RUN_DEPENDS= \
${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500000
MAN1PREFIX= ${PREFIX}/share
+.endif
+
MAN1= checkbot.1
USE_PERL5= YES
PERL_CONFIGURE= yes
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>