aboutsummaryrefslogtreecommitdiffstats
path: root/www/chromium
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2015-08-22 17:29:14 +0800
committerrene <rene@FreeBSD.org>2015-08-22 17:29:14 +0800
commitd3d2012d640058a027d6256cc353b7f021aee66e (patch)
tree9540db413597038378c812cc04471a81511cb2bb /www/chromium
parentcd6a2f0e9f54bbdf07e5fe82ec885d17ccb3f35b (diff)
downloadfreebsd-ports-graphics-d3d2012d640058a027d6256cc353b7f021aee66e.tar.gz
freebsd-ports-graphics-d3d2012d640058a027d6256cc353b7f021aee66e.tar.zst
freebsd-ports-graphics-d3d2012d640058a027d6256cc353b7f021aee66e.zip
Move definitions of MAKE_ARGS up to ensure that chromedriver is built when
requested [1] While here sort USES PR: 202560 [1] Submitted by: Carlos J Puga Medina [1] MFH: 2015Q3
Diffstat (limited to 'www/chromium')
-rw-r--r--www/chromium/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 912b229bc5c..43a4dfb8d31 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -55,13 +55,14 @@ RUN_DEPENDS= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:${PORTSDIR}/a
xdg-open:${PORTSDIR}/devel/xdg-utils
ONLY_FOR_ARCHS= i386 amd64
-USES= bison compiler:c++11-lib cpe desktop-file-utils jpeg pkgconfig \
- perl5 shebangfix ninja tar:xz python:2,build execinfo
+USES= bison compiler:c++11-lib cpe desktop-file-utils execinfo jpeg \
+ ninja perl5 pkgconfig python:2,build shebangfix tar:xz
CPE_VENDOR= google
CPE_PRODUCT= chrome
USE_PERL5= build
USE_XORG= scrnsaverproto x11 xproto xscrnsaver xtst
USE_GNOME= atk glib20 gtk20 dconf libxslt
+MAKE_ARGS= -C out/${BUILDTYPE}
SHEBANG_FILES= chrome/tools/build/linux/chrome-wrapper
ALL_TARGET= chrome
INSTALLS_ICONS= yes
@@ -137,7 +138,7 @@ OPTIONS_SUB= yes
GCONF_USE= GNOME=gconf2
PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
-
+DRIVER_MAKE_ARGS=chromedriver
TEST_DISTFILES= ${PORTNAME}-${DISTVERSION}-testdata${EXTRACT_SUFX}
.include <bsd.port.options.mk>
@@ -194,8 +195,6 @@ CONFIGURE_ENV+= CC="${CC}" \
GYP_DEFINES="${GYP_DEFINES}"
MAKE_ENV+= BUILDTYPE=${BUILDTYPE} \
GPERF="${LOCALBASE}/bin/gperf"
-MAKE_ARGS= -C out/${BUILDTYPE}
-DRIVER_MAKE_ARGS=chromedriver
.include <bsd.port.pre.mk>