aboutsummaryrefslogtreecommitdiffstats
path: root/www/dtse/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-03-30 02:05:44 +0800
committerpav <pav@FreeBSD.org>2004-03-30 02:05:44 +0800
commitc271fa0a9aea35a46a1063692e13b5ff4eaea50d (patch)
treeb69444bc5a027bbc42c74f1a5042c173a656ecf8 /www/dtse/Makefile
parent98b9aa662e9f1f994d51480ca7ecbe470bed6077 (diff)
downloadfreebsd-ports-graphics-c271fa0a9aea35a46a1063692e13b5ff4eaea50d.tar.gz
freebsd-ports-graphics-c271fa0a9aea35a46a1063692e13b5ff4eaea50d.tar.zst
freebsd-ports-graphics-c271fa0a9aea35a46a1063692e13b5ff4eaea50d.zip
Douglas Thrift's Search Engine is an indexing search engine for use on small
websites such as personal or small business sites. It is designed to be very similar to Google for end users and its output is customizable. For indexing, it supports both the Robots Exclusion Protocol and the Robots META Tag as specified at http://www.robotstxt.org/wc/exclusion.html. WWW: http://computers.douglasthrift.net/searchengine/ PR: ports/64794 Submitted by: Douglas Thrift <douglas@douglasthrift.net>
Diffstat (limited to 'www/dtse/Makefile')
-rw-r--r--www/dtse/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/www/dtse/Makefile b/www/dtse/Makefile
new file mode 100644
index 00000000000..2c02ded017b
--- /dev/null
+++ b/www/dtse/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: dtse
+# Date created: 7 Mar 2004
+# Whom: Douglas Thrift <douglas@douglasthrift.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dtse
+PORTVERSION= 1.2
+CATEGORIES= www perl5
+MASTER_SITES= http://computers.douglasthrift.net/searchengine/download/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= douglas@douglasthrift.net
+COMMENT= An indexing search engine for use on small websites
+
+.if defined(WITH_OPENSSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
+.endif
+
+USE_PERL5= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS+= --prefix=${PREFIX}/${PORTNAME}
+
+MAKEFILE= GNUmakefile
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+USE_GCC= 3.3
+.endif
+
+.include <bsd.port.post.mk>