aboutsummaryrefslogtreecommitdiffstats
path: root/www/dummyflash/Makefile
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2009-01-10 10:45:46 +0800
committermezz <mezz@FreeBSD.org>2009-01-10 10:45:46 +0800
commit867a335b88f91d457005fa0c7b3bb7c85c5fca14 (patch)
tree68af898c9a11dd756c516c49a6715cee75888e70 /www/dummyflash/Makefile
parent6f64cd00171c29c1c7cdfb1e40393e23fc35151d (diff)
downloadfreebsd-ports-graphics-867a335b88f91d457005fa0c7b3bb7c85c5fca14.tar.gz
freebsd-ports-graphics-867a335b88f91d457005fa0c7b3bb7c85c5fca14.tar.zst
freebsd-ports-graphics-867a335b88f91d457005fa0c7b3bb7c85c5fca14.zip
Add a new framework for browser plugins, USE_WEBPLUGINS. It is for which foo
plugins support one of web browsers and can take care of plist (depend on how you use it) at the same time. I have written a complete document and even show how it works in the www/firefox/Makefile.webplugins so be sure to read in there. If there is anything that isn't clear in the document, please feel free to ask and I will try my best to improvement it. FYI: GNOME 2.24 depends on this, so it's coming. BTW: It's based on www/linux-mplayer-plugin/Makefile.npapi with heavy modified. Approved by: portmgr
Diffstat (limited to 'www/dummyflash/Makefile')
-rw-r--r--www/dummyflash/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/www/dummyflash/Makefile b/www/dummyflash/Makefile
index dd6254be768..3305bf17ec0 100644
--- a/www/dummyflash/Makefile
+++ b/www/dummyflash/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dummyflash
PORTVERSION= 1.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www
MASTER_SITES= ftp://ftp.netscape.com/pub/sdk/plugin/unix/
DISTNAME= unix-sdk-3.0b5
@@ -21,8 +21,14 @@ BUILD_WRKSRC= ${WRKSRC}/PluginSDK30b5/examples/UnixTemplate/Unix
NO_WRKSUBDIR= yes
MAKEFILE= makefile.freebsd
+USE_WEBPLUGINS= native
+WEBPLUGINS_FILES=dummyflash.so
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
+
do-install:
- @${MKDIR} ${PREFIX}/lib/browser_plugins
- ${INSTALL_DATA} ${BUILD_WRKSRC}/dummyflash.so ${PREFIX}/lib/browser_plugins
+ @${MKDIR} ${WEBPLUGINS_DIR}
+ ${INSTALL_DATA} ${BUILD_WRKSRC}/dummyflash.so ${WEBPLUGINS_DIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>