aboutsummaryrefslogtreecommitdiffstats
path: root/www/galeon2
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-11-05 13:04:16 +0800
committermarcus <marcus@FreeBSD.org>2003-11-05 13:04:16 +0800
commit44f85cb214036eb071d16f8d50d10e5dfd4d8a0e (patch)
tree5521df02e0b456fb55ac019ec3086ed31db192a4 /www/galeon2
parent2413b1e40888f7613e8dabc0fdfa8feb08a402d3 (diff)
downloadfreebsd-ports-graphics-44f85cb214036eb071d16f8d50d10e5dfd4d8a0e.tar.gz
freebsd-ports-graphics-44f85cb214036eb071d16f8d50d10e5dfd4d8a0e.tar.zst
freebsd-ports-graphics-44f85cb214036eb071d16f8d50d10e5dfd4d8a0e.zip
Don't reference memory after free'ing it. This fixes a lockup and possible
crash when exiting Galeon. Reported by: Simon Barner <barner@in.tum.de>
Diffstat (limited to 'www/galeon2')
-rw-r--r--www/galeon2/Makefile1
-rw-r--r--www/galeon2/files/patch-src_galeon-shell.c22
2 files changed, 21 insertions, 2 deletions
diff --git a/www/galeon2/Makefile b/www/galeon2/Makefile
index 97b9730916e..3925ef83003 100644
--- a/www/galeon2/Makefile
+++ b/www/galeon2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= galeon2
PORTVERSION= 1.3.10
+PORTREVISION= 1
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME:S/2$//}
diff --git a/www/galeon2/files/patch-src_galeon-shell.c b/www/galeon2/files/patch-src_galeon-shell.c
index cf363fdf36e..bb5bd9d153d 100644
--- a/www/galeon2/files/patch-src_galeon-shell.c
+++ b/www/galeon2/files/patch-src_galeon-shell.c
@@ -1,5 +1,5 @@
---- src/galeon-shell.c.orig Tue Oct 28 01:07:00 2003
-+++ src/galeon-shell.c Tue Oct 28 01:09:34 2003
+--- src/galeon-shell.c.orig Mon Oct 13 17:56:13 2003
++++ src/galeon-shell.c Tue Nov 4 23:07:54 2003
@@ -186,6 +186,7 @@
if (gs->priv->automation_factory == NULL)
{
@@ -17,3 +17,21 @@
"<tt>\"GNOME_Galeon_Automation.server\"</tt>");
hig_alert_set_secondary_printf (HIG_ALERT (dialog), "%s\n\n%s", text,
_("Usually this is an indication of an incomplete installation. "
+@@ -283,8 +284,6 @@
+ gb_bookmark_set_check_save (gs->priv->bookmark_set);
+ g_object_unref (G_OBJECT (gs->priv->bookmark_set));
+
+- g_free (gs->priv);
+-
+ G_OBJECT_CLASS (parent_class)->finalize (object);
+
+ #ifdef DEBUG_MARCO
+@@ -295,6 +294,8 @@
+ {
+ bonobo_object_unref (gs->priv->automation_factory);
+ }
++
++ g_free (gs->priv);
+
+ bonobo_main_quit ();
+