aboutsummaryrefslogtreecommitdiffstats
path: root/www/galeon2
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-03-30 00:35:19 +0800
committersobomax <sobomax@FreeBSD.org>2001-03-30 00:35:19 +0800
commit6e2b9def0c49c3e565a14f5987fd3e9f46d285c6 (patch)
treec23d8d7c62c20c0978b7a404b38eb7b9d5596d0f /www/galeon2
parentfaa774bb672904227e681f88c16cfceef448ef6c (diff)
downloadfreebsd-ports-graphics-6e2b9def0c49c3e565a14f5987fd3e9f46d285c6.tar.gz
freebsd-ports-graphics-6e2b9def0c49c3e565a14f5987fd3e9f46d285c6.tar.zst
freebsd-ports-graphics-6e2b9def0c49c3e565a14f5987fd3e9f46d285c6.zip
-pthread --> ${PTHREAD_LIBS}
-D_THREAD_SAFE --> ${PTHREAD_CFLAGS} Note: my first intention was to test this out on bento/beta, but per ade's requiest I opted to do it quickly.
Diffstat (limited to 'www/galeon2')
-rw-r--r--www/galeon2/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/www/galeon2/Makefile b/www/galeon2/Makefile
index 674bd58ef19..4a42e13b96b 100644
--- a/www/galeon2/Makefile
+++ b/www/galeon2/Makefile
@@ -39,8 +39,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-mozilla-includes="${X11BASE}/include/mozilla" \
--with-mozilla-libs="${X11BASE}/lib/${MOZILLA}"
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include \
- -D_REENTRANT -D_THREAD_SAFE -fno-rtti" \
- LIBS="-L${LOCALBASE}/lib -L${WRKSRC} -pthread ${GCC_R_LIB}"
+ -D_REENTRANT ${PTHREAD_CFLAGS} -fno-rtti" \
+ LIBS="-L${LOCALBASE}/lib -L${WRKSRC} ${PTHREAD_LIBS} ${GCC_R_LIB}"
.if exists(/usr/lib/libgcc_r.a)
GCC_R_LIB= -lgcc_r
@@ -56,12 +56,12 @@ post-extract:
.endif
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
- s|-lpthread|-pthread|g'
+ s|-lpthread|${PTHREAD_LIBS}|g'
post-configure:
@${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g ; \