aboutsummaryrefslogtreecommitdiffstats
path: root/www/horde2
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-06-08 14:00:39 +0800
committernork <nork@FreeBSD.org>2003-06-08 14:00:39 +0800
commita8b55f99857b04ba4a279ede0049731cbddd5bf8 (patch)
tree3dc09cffc9086ecb1eb10241c122c3731d3378da /www/horde2
parent4e3d1fd04f5333f3b5c305910b206faf3ab3d2ea (diff)
downloadfreebsd-ports-graphics-a8b55f99857b04ba4a279ede0049731cbddd5bf8.tar.gz
freebsd-ports-graphics-a8b55f99857b04ba4a279ede0049731cbddd5bf8.tar.zst
freebsd-ports-graphics-a8b55f99857b04ba4a279ede0049731cbddd5bf8.zip
Fixing Horde to work with the new PEAR strcture.
PR: ports/52642 Submitted by: Thierry Thomas <thierry@pompo.net>
Diffstat (limited to 'www/horde2')
-rw-r--r--www/horde2/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/www/horde2/Makefile b/www/horde2/Makefile
index 0ce676c24b5..36d9485c61f 100644
--- a/www/horde2/Makefile
+++ b/www/horde2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= horde
PORTVERSION= 2.2.3
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ftp://ftp.horde.org/pub/horde/ \
ftp://ftp.au.horde.org/pub/horde/ \
@@ -30,10 +31,10 @@ LIB_DEPENDS+= intl.4:${PORTSDIR}/devel/gettext
LIB_DEPENDS+= mcal.0:${PORTSDIR}/misc/libmcal
.endif
# Remark: pear-XML_sql2xml is included, but never used.
-RUN_DEPENDS= ${PHP_LIB}/Date.php:${PORTSDIR}/devel/pear-Date \
- ${PHP_LIB}/HTML/Select.php:${PORTSDIR}/devel/pear-HTML_Select_Common \
- ${PHP_LIB}/Log.php:${PORTSDIR}/sysutils/pear-Log \
- ${PHP_LIB}/Mail/mime.php:${PORTSDIR}/mail/pear-Mail_Mime
+RUN_DEPENDS= ${PEARDIR}/Date.php:${PORTSDIR}/devel/pear-Date \
+ ${PEARDIR}/HTML/Common.php:${PORTSDIR}/devel/pear-HTML_Common \
+ ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log \
+ ${PEARDIR}/Mail/mime.php:${PORTSDIR}/mail/pear-Mail_Mime
NO_BUILD= yes
USE_REINPLACE= yes
@@ -58,7 +59,7 @@ HORDESBIN= ${PREFIX}/${LHORDESBIN}
CONFDIR= ${HORDEDIR}/config
APACHE_CONF= ${APACHE_CNFDIR}/httpd.conf
-PHP_LIB?= ${LOCALBASE}/lib/php
+PEARDIR?= ${LOCALBASE}/share/pear
.if defined(WITH_APACHE2)
APACHE_CNFDIR= ${LOCALBASE}/etc/apache2
MOD_DIR= libexec/apache2
@@ -149,11 +150,11 @@ do-install:
${MKDIR} ${HORDE_INC} ; \
${CP} -p ${FILESDIR}/httpd.conf.horde ${HORDE_INC} ; \
${REINPLACE_CMD} -e "s:/home/httpd/html/horde:${HORDEDIR}:g ; \
- s:/home/httpd/phplib:${PHP_LIB}:g" ${HORDE_INC}/httpd.conf.horde ; \
+ s:/home/httpd/phplib:${PEARDIR}:g" ${HORDE_INC}/httpd.conf.horde ; \
${RM} ${HORDE_INC}/httpd.conf.horde.beforeHorde ; \
${ECHO_MSG} "===> Updating ${APACHE_CONF}..." ; \
${REINPLACE_CMD} -e "s:php_value auto_prepend_file:# php_value auto_prepend_file:g ; \
- s:${HORDEDIR}/phplib:${PHP_LIB}:g" ${APACHE_CONF} ; \
+ s:${HORDEDIR}/phplib:${PEARDIR}:g" ${APACHE_CONF} ; \
${ECHO_CMD} "# Horde's include directory" >> ${APACHE_CONF} ; \
${ECHO_CMD} "Include ${HORDE_INC}" >> ${APACHE_CONF} ; \
fi)