aboutsummaryrefslogtreecommitdiffstats
path: root/www/kdedict
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-12-21 16:48:24 +0800
committeredwin <edwin@FreeBSD.org>2005-12-21 16:48:24 +0800
commitd1b57371b17d215ddafaf8fba06ac46e852f3855 (patch)
treefa392caa4b5ab081ed126ae2559b8c4a117d8a2c /www/kdedict
parent8d5b72d0248294def1f820b46446f5d0456466f6 (diff)
downloadfreebsd-ports-graphics-d1b57371b17d215ddafaf8fba06ac46e852f3855.tar.gz
freebsd-ports-graphics-d1b57371b17d215ddafaf8fba06ac46e852f3855.tar.zst
freebsd-ports-graphics-d1b57371b17d215ddafaf8fba06ac46e852f3855.zip
[NEW PORT] www/kdedict: Web based DB app. to administer standard translations of a translation team
KDE Dictionary is used by a few KDE i18n teams; kdedict is written by Matthias Kiefer from German team and i18n.kde.org's instalaltion is currently administered by Claudiu Costin from Romaninan Team. kdedict is a web based database to administer the standard translations of a translation team. You can search the database for different criterias and the found entries are shown in a table. kdedict does not use a full blown database but stores the information in a plain text file. This way, everybody can easily run kdedict offline (using a local web server) without having to install and admin a big database. To enable users to update their locale database easily, kdedict offers a download option. But if you have basic knowledge of Perl, it should be no problem to adapt kdedict for using a real database. The database consists of the fields: original text, description, translation, description, category of the word (i.e. GUI, Network), date of last update and flag, if the translation is accepted by the team. This flag allows you to include translations, that your team is not in agreement about, into the database. kdedict is able to manage user logins, so you can easily maintain your database over the web. When logged in, it is easy to edit, insert or delete entries. kdedict can also manage multiple languages, by creating one table for each user. WWW: http://i18n.kde.org/tools/kdedict/ PR: ports/90507 Submitted by: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
Diffstat (limited to 'www/kdedict')
-rw-r--r--www/kdedict/Makefile56
-rw-r--r--www/kdedict/distinfo3
-rw-r--r--www/kdedict/files/pkg-message.in3
-rw-r--r--www/kdedict/pkg-descr24
-rw-r--r--www/kdedict/pkg-plist20
5 files changed, 106 insertions, 0 deletions
diff --git a/www/kdedict/Makefile b/www/kdedict/Makefile
new file mode 100644
index 00000000000..6452ad3dcfe
--- /dev/null
+++ b/www/kdedict/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: www/kdedict
+# Date created: 2005-12-16
+# Whom: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
+#
+# $FreeBSD$
+# $Tecnik: ports/www/kdedict/Makefile,v 1.1 2005/12/16 16:44:16 itetcu Exp $
+#
+
+PORTNAME= kdedict
+PORTVERSION= 20030925
+CATEGORIES= www
+MASTER_SITES= ftp://ftp.i18n.kde.org/tools/${PORTNAME}/ \
+ http://people.tecnik93.com/~itetcu/FreeBSD/ports/${PORTNAME}/sources/
+
+MAINTAINER= itetcu@people.tecnik93.com
+COMMENT= Web based db to administer standard translations of a translation team
+
+RUN_DEPENDS= p5-Date-Manip>0:${PORTSDIR}/devel/p5-Date-Manip \
+ p5-SQL-Statement>0:${PORTSDIR}/databases/p5-SQL-Statement \
+ p5-Text-CSV_XS>0:${PORTSDIR}/textproc/p5-Text-CSV_XS
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+USE_APACE= yes
+USE_REINPLACE= yes
+
+CGI_DIR?= ${PREFIX}/www/cgi-bin
+SUB_FILES= pkg-message
+SUB_LIST+= PORTNAME=${PORTNAME} CGI_DIR=${CGI_DIR}
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL}<500800
+RUN_DEPENDS+= p5-DBD-File>0:${PORTSDIR}/databases/p5-DBD-File
+.endif
+
+pre-everything::
+ @${ECHO_CMD} "Define to suit your needs:"
+ @${ECHO_CMD} "CGI_DIR (default: ${PREFIX}/www/cgi-bin)"
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,/usr/bin/perl,${PERL},g" \
+ ${WRKSRC}/${PORTNAME}.cgi
+
+do-install:
+ @${MKDIR} ${CGI_DIR}/kdedictionary
+ @${CHOWN} ${WWWOWN}:${WWWGRP} ${CGI_DIR}/kdedictionary
+ cd ${WRKSRC} && \
+ ${INSTALL_SCRIPT} -o ${WWWOWN} -g ${WWWGRP} ${PORTNAME}.cgi ${CGI_DIR} && \
+ ${INSTALL} -o ${WWWOWN} -g ${WWWGRP} -m 0644 kdedictionary/* ${CGI_DIR}/kdedictionary
+
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/kdedict/distinfo b/www/kdedict/distinfo
new file mode 100644
index 00000000000..4c9bc3d4303
--- /dev/null
+++ b/www/kdedict/distinfo
@@ -0,0 +1,3 @@
+MD5 (kdedict-20030925.tar.gz) = 6a41747aa7add3f33533bd6861d70981
+SHA256 (kdedict-20030925.tar.gz) = 0c7778ae97571e1b1b355008211fc914924f7fcdb8cf5edc23655905d544efff
+SIZE (kdedict-20030925.tar.gz) = 248362
diff --git a/www/kdedict/files/pkg-message.in b/www/kdedict/files/pkg-message.in
new file mode 100644
index 00000000000..430b1326800
--- /dev/null
+++ b/www/kdedict/files/pkg-message.in
@@ -0,0 +1,3 @@
+*******************************************************************
+ Edit %%CGI_DIR%%/%%PORTNAME%%.cgi to configure your instalation.
+*******************************************************************
diff --git a/www/kdedict/pkg-descr b/www/kdedict/pkg-descr
new file mode 100644
index 00000000000..352b26850a8
--- /dev/null
+++ b/www/kdedict/pkg-descr
@@ -0,0 +1,24 @@
+KDE Dictionary is used by a few KDE i18n teams.
+Kdedict is written by Matthias Kiefer from German team
+and i18n.kde.org's instalaltion is currently administered by Claudiu Costin
+from Romaninan Team.
+Kdedict is a web based database to administer the standard translations of a
+translation team. You can search the database for different criterias and the
+found entries are shown in a table.
+Kdedict does not use a full blown database but stores the information in a
+plain text file. This way, everybody can easily run kdedict offline (using a
+local web server) without having to install and admin a big database. To enable
+users to update their locale database easily, kdedict offers a download option.
+But if you have basic knowledge of Perl, it should be no problem to adapt
+dedict for using a real database.
+The database consists of the fields: original text, description, translation,
+description, category of the word (i.e. GUI, Network), date of last update and
+flag, if the translation is accepted by the team. This flag allows you to
+include translations, that your team is not in agreement about, into the
+database.
+Kdedict is able to manage user logins, so you can easily maintain your database
+over the web. When logged in, it is easy to edit, insert or delete entries.
+Kdedict can also manage multiple languages, by creating one table for each
+user.
+
+WWW: http://i18n.kde.org/tools/kdedict/
diff --git a/www/kdedict/pkg-plist b/www/kdedict/pkg-plist
new file mode 100644
index 00000000000..0809046a834
--- /dev/null
+++ b/www/kdedict/pkg-plist
@@ -0,0 +1,20 @@
+www/cgi-bin/kdedict.cgi
+www/cgi-bin/kdedictionary/accounts
+www/cgi-bin/kdedictionary/errorlogs
+www/cgi-bin/kdedictionary/kdedictionary_de
+www/cgi-bin/kdedictionary/kdedictionary_es
+www/cgi-bin/kdedictionary/kdedictionary_fr
+www/cgi-bin/kdedictionary/kdedictionary_hu
+www/cgi-bin/kdedictionary/kdedictionary_pl
+www/cgi-bin/kdedictionary/kdedictionary_pt_BR
+www/cgi-bin/kdedictionary/kdedictionary_ro
+www/cgi-bin/kdedictionary/kdedictionary_sl
+www/cgi-bin/kdedictionary/kdedictionary_tr
+www/cgi-bin/kdedictionary/languages
+www/cgi-bin/kdedictionary/messages
+www/cgi-bin/kdedictionary/messages_de
+www/cgi-bin/kdedictionary/sessiondb
+www/cgi-bin/kdedictionary/userdb
+www/cgi-bin/kdedictionary/users
+@dirrm www/cgi-bin/kdedictionary
+@unexec rmdir %D/www/cgi-bin 2>/dev/null || true