aboutsummaryrefslogtreecommitdiffstats
path: root/www/lighttpd
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2010-10-07 06:15:16 +0800
committermm <mm@FreeBSD.org>2010-10-07 06:15:16 +0800
commit9708805820909b99c577a51222773bce9f841e43 (patch)
tree3eb2b67cbd8ed80be649500270a18e9a492a6678 /www/lighttpd
parentbc78c124244fffe23a1205979b9bd2a417457762 (diff)
downloadfreebsd-ports-graphics-9708805820909b99c577a51222773bce9f841e43.tar.gz
freebsd-ports-graphics-9708805820909b99c577a51222773bce9f841e43.tar.zst
freebsd-ports-graphics-9708805820909b99c577a51222773bce9f841e43.zip
- Use autotools only if building lighttpd modules
Diffstat (limited to 'www/lighttpd')
-rw-r--r--www/lighttpd/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 4b96588e1ca..766a9bdc39f 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -20,8 +20,13 @@ LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GNOME= lthack
+
+.if !defined(_BUILDING_LIGHTTPD_MODULE)
+USE_AUTOTOOLS= libtool:22
+.else
USE_AUTOTOOLS= autoconf:267 autoheader:267 aclocal:111 automake:111 libtool:22
ACLOCAL_ARGS= -I m4
+.endif
CONFIGURE_ARGS+= --libdir=${PREFIX}/lib/lighttpd --enable-static
CFLAGS+= -I${LOCALBASE}/include