aboutsummaryrefslogtreecommitdiffstats
path: root/www/lighttpd
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-01-05 07:40:44 +0800
committerantoine <antoine@FreeBSD.org>2014-01-05 07:40:44 +0800
commitd7498c6d88b3aea9a8b8c2846b21199d346c3b10 (patch)
tree42cd39480ede7db9874484f52a6c0467161329e6 /www/lighttpd
parent24561e31331927221bcf5442be4516ab833c0e4f (diff)
downloadfreebsd-ports-graphics-d7498c6d88b3aea9a8b8c2846b21199d346c3b10.tar.gz
freebsd-ports-graphics-d7498c6d88b3aea9a8b8c2846b21199d346c3b10.tar.zst
freebsd-ports-graphics-d7498c6d88b3aea9a8b8c2846b21199d346c3b10.zip
Convert the tree to USES=fam
Approved by: portmgr (bapt)
Diffstat (limited to 'www/lighttpd')
-rw-r--r--www/lighttpd/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index ab77513e552..3e3509ea5da 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -19,8 +19,7 @@ LIB_DEPENDS+= pcre.3:${PORTSDIR}/devel/pcre
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GNOME= lthack
-USE_GMAKE= yes
-USES= pkgconfig
+USES= gmake pkgconfig
#.if !defined(_BUILDING_LIGHTTPD_MODULE)
#USE_AUTOTOOLS= libtool
@@ -56,6 +55,10 @@ SPAWNFCGI_DESC= Depend on spawn-fcgi utility
VALGRIND_DESC= valgrind support
WEBDAV_DESC= WebDAV support
+FAM_USES= fam
+FAM_CONFIGURE_ON= --with-fam
+FAM_CONFIGURE_ENV= FAM_CFLAGS="-I${LOCALBASE}/include" FAM_LIBS="-L${LOCALBASE}/lib"
+
LIGHTTPD_CONF_FILES= lighttpd.conf modules.conf
LIGHTTPD_CONF_D_FILES= access_log.conf \
@@ -103,12 +106,6 @@ CONFIGURE_ARGS+= --with-openssl \
CONFIGURE_ARGS+= --with-bzip2
.endif
-.if ${PORT_OPTIONS:MFAM}
-USE_FAM= yes
-CONFIGURE_ARGS+= --with-fam
-CONFIGURE_ENV+= FAM_CFLAGS="-I${LOCALBASE}/include" FAM_LIBS="-L${LOCALBASE}/lib"
-.endif
-
.if ${PORT_OPTIONS:MGDBM}
LIB_DEPENDS+= gdbm:${PORTSDIR}/databases/gdbm
CONFIGURE_ARGS+= --with-gdbm