aboutsummaryrefslogtreecommitdiffstats
path: root/www/lws/Makefile
diff options
context:
space:
mode:
authorarchie <archie@FreeBSD.org>2002-08-22 07:09:38 +0800
committerarchie <archie@FreeBSD.org>2002-08-22 07:09:38 +0800
commit1dbdcb5fd7eb838000fb8cff8d7e20aeb1766026 (patch)
tree93c537858e018dc419c29148e311c5c89d86f1eb /www/lws/Makefile
parent993874b14e4afa81de14dd008c4816f232171626 (diff)
downloadfreebsd-ports-graphics-1dbdcb5fd7eb838000fb8cff8d7e20aeb1766026.tar.gz
freebsd-ports-graphics-1dbdcb5fd7eb838000fb8cff8d7e20aeb1766026.tar.zst
freebsd-ports-graphics-1dbdcb5fd7eb838000fb8cff8d7e20aeb1766026.zip
LWS is a lightweight web server which uses pthreads(3) for multi-tasking
and libpdel(3) for HTTP, HTTPS, and configurable servlet support. The server can be configured via a buit-in admin web interface, or by manu- ally editing the XML configuration file. LWS supports multiple HTTP and HTTPS servers, each containing multiple virtual hosts. Each virtual host has a configurable list of servlets. The supported servlets types are file, redirect, and cookieauth. The file servlet includes optional support for tmpl(3) HTML templates. LWS maintains a self-rotating logfile(3) error log, with optional support for logging via syslog as well. LWS is intended to demonstrate features of the libpdel(3) library, and to be a lightweight web server for simple applications.
Diffstat (limited to 'www/lws/Makefile')
-rw-r--r--www/lws/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/www/lws/Makefile b/www/lws/Makefile
new file mode 100644
index 00000000000..b744e81f871
--- /dev/null
+++ b/www/lws/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: lws
+# Date created: 21 Aug 2002
+# Whom: Archie Cobbs
+#
+# $FreeBSD$
+#
+
+PORTNAME= lws
+PORTVERSION= 0.1.0
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= archie
+
+MAINTAINER= archie@freebsd.org
+
+LIB_DEPENDS= pdel.0:${PORTSDIR}/devel/libpdel
+
+MAN1= lws.1
+MANCOMPRESSED= yes
+
+.include <bsd.port.mk>