aboutsummaryrefslogtreecommitdiffstats
path: root/www/mgstat/Makefile
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2004-10-31 00:46:42 +0800
committerleeym <leeym@FreeBSD.org>2004-10-31 00:46:42 +0800
commit0b8f43d62b67727a13103b1eeb3cb4e6121beae1 (patch)
tree629e54fab288f6e9a804554c4378513c9164308d /www/mgstat/Makefile
parent3f9a8919296b0d73456854eb3ebd5bd4c987b0b1 (diff)
downloadfreebsd-ports-graphics-0b8f43d62b67727a13103b1eeb3cb4e6121beae1.tar.gz
freebsd-ports-graphics-0b8f43d62b67727a13103b1eeb3cb4e6121beae1.tar.zst
freebsd-ports-graphics-0b8f43d62b67727a13103b1eeb3cb4e6121beae1.zip
- add USE_GCC=3.3 and unbreak this port
- replace pkg-plist with PLIST_FILES and PORTDOCS
Diffstat (limited to 'www/mgstat/Makefile')
-rw-r--r--www/mgstat/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/www/mgstat/Makefile b/www/mgstat/Makefile
index 6fea3efd723..02d114a9b3c 100644
--- a/www/mgstat/Makefile
+++ b/www/mgstat/Makefile
@@ -18,20 +18,19 @@ LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
GNU_CONFIGURE= yes
-MGDOCDIR= ${PREFIX}/share/doc/mgstat
+PORTDOCS= Copyright README USAGE
+PLIST_FILES= bin/mgstat
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile with gcc 3.4.2"
+USE_GCC= 3.3
.endif
post-install:
.if !defined(NOPORTDOCS)
- @if ! [ -d ${MGDOCDIR} ]; then ${MKDIR} ${MGDOCDIR}; fi
- ${INSTALL_DATA} ${WRKSRC}/Copyright ${MGDOCDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${MGDOCDIR}
- ${INSTALL_DATA} ${WRKSRC}/USAGE ${MGDOCDIR}
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
.include <bsd.port.post.mk>