aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_auth_any
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-04-11 06:28:40 +0800
committerwill <will@FreeBSD.org>2001-04-11 06:28:40 +0800
commita47d2a5fdfde2e207cc9d32bea3d7ef3d1e8e0de (patch)
treea2e508fa4665df1bc6ae4a3a3b2dfb4dc56aa2f4 /www/mod_auth_any
parentcefb0509d20583448ecc40765b830213a8afb7df (diff)
downloadfreebsd-ports-graphics-a47d2a5fdfde2e207cc9d32bea3d7ef3d1e8e0de.tar.gz
freebsd-ports-graphics-a47d2a5fdfde2e207cc9d32bea3d7ef3d1e8e0de.tar.zst
freebsd-ports-graphics-a47d2a5fdfde2e207cc9d32bea3d7ef3d1e8e0de.zip
Add mod_auth_any 1.0.2, an apache module to use any command line
program to authenticate a user.
Diffstat (limited to 'www/mod_auth_any')
-rw-r--r--www/mod_auth_any/Makefile27
-rw-r--r--www/mod_auth_any/distinfo1
-rw-r--r--www/mod_auth_any/pkg-comment1
-rw-r--r--www/mod_auth_any/pkg-descr6
-rw-r--r--www/mod_auth_any/pkg-plist3
5 files changed, 38 insertions, 0 deletions
diff --git a/www/mod_auth_any/Makefile b/www/mod_auth_any/Makefile
new file mode 100644
index 00000000000..b04a82f2b6f
--- /dev/null
+++ b/www/mod_auth_any/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: mod_auth_any
+# Date created: 10 April 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_auth_any
+PORTVERSION= 1.0.2
+CATEGORIES= www
+MASTER_SITES= ftp://ftp.itlab.musc.edu/pub/toolbox/mod_auth_any/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+
+APXS?= ${LOCALBASE}/sbin/apxs
+
+do-build:
+ @cd ${WRKSRC} && ${APXS} -c ${PORTNAME}.c
+
+do-install:
+ ${APXS} -i -A -n ${PORTNAME:S/mod_//g} ${WRKSRC}/${PORTNAME}.so
+
+.include <bsd.port.mk>
diff --git a/www/mod_auth_any/distinfo b/www/mod_auth_any/distinfo
new file mode 100644
index 00000000000..92f0b80ba1b
--- /dev/null
+++ b/www/mod_auth_any/distinfo
@@ -0,0 +1 @@
+MD5 (mod_auth_any-1.0.2.tgz) = cd2f0c6d39af4fe4c6919caeac38e1b3
diff --git a/www/mod_auth_any/pkg-comment b/www/mod_auth_any/pkg-comment
new file mode 100644
index 00000000000..b69de0da377
--- /dev/null
+++ b/www/mod_auth_any/pkg-comment
@@ -0,0 +1 @@
+Apache module to use any command line program to authenticate a user
diff --git a/www/mod_auth_any/pkg-descr b/www/mod_auth_any/pkg-descr
new file mode 100644
index 00000000000..83d164609a8
--- /dev/null
+++ b/www/mod_auth_any/pkg-descr
@@ -0,0 +1,6 @@
+This module allows you to use any command line program such as
+WebNIS to authenticate a user. No more having to keep AuthUserFiles
+in sync, or maintain some nasty database. You can even have an
+expect script that does ssh authentication.
+
+WWW: http://www.itlab.musc.edu/~nafees/mod_auth_any.html
diff --git a/www/mod_auth_any/pkg-plist b/www/mod_auth_any/pkg-plist
new file mode 100644
index 00000000000..3fffd2cc8e6
--- /dev/null
+++ b/www/mod_auth_any/pkg-plist
@@ -0,0 +1,3 @@
+libexec/apache/mod_auth_any.so
+@exec %D/sbin/apxs -e -A -n auth_any %D/%F
+@unexec %D/sbin/apxs -e -A -n auth_any %D/%F