aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_auth_external2
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2003-10-14 18:57:45 +0800
committererwin <erwin@FreeBSD.org>2003-10-14 18:57:45 +0800
commit4d656890e9ced9991afe407d2329f29ae8e8089f (patch)
tree33647e0d912712a879389a0aa0559df6b72e7e96 /www/mod_auth_external2
parent79e0a4c9330aab89e4e366dc97d6668f0d4cc869 (diff)
downloadfreebsd-ports-graphics-4d656890e9ced9991afe407d2329f29ae8e8089f.tar.gz
freebsd-ports-graphics-4d656890e9ced9991afe407d2329f29ae8e8089f.tar.zst
freebsd-ports-graphics-4d656890e9ced9991afe407d2329f29ae8e8089f.zip
Add mod_auth_external2 2.2.6,
Mod_Auth_External is an Apache module used for authentication. The Apache HTTP Daemon can be configured to require users to supply logins and passwords before accessing pages in some directories. Authentication is the process of checking if the password given is correct for a user. Apache has standard modules for authenticating out of several different kinds of databases. Mod_Auth_External is a flexible tool for creating authentication systems based on other databases. WWW: http://www.unixpapa.com/mod_auth_external.html PR: 57967 Submitted by: Clement Laforet <sheepkiller@cultdeadsheep.org>
Diffstat (limited to 'www/mod_auth_external2')
-rw-r--r--www/mod_auth_external2/Makefile36
-rw-r--r--www/mod_auth_external2/distinfo1
-rw-r--r--www/mod_auth_external2/pkg-descr9
-rw-r--r--www/mod_auth_external2/pkg-plist7
4 files changed, 53 insertions, 0 deletions
diff --git a/www/mod_auth_external2/Makefile b/www/mod_auth_external2/Makefile
new file mode 100644
index 00000000000..37a948453f9
--- /dev/null
+++ b/www/mod_auth_external2/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: mod_auth_external2
+# Date created: Fri Oct 10
+# Whom: Clement Laforet <sheepkiller@cultdeadsheep.org>
+#
+# $FreeBSD$
+
+PORTNAME= mod_auth_external
+PORTVERSION= 2.2.6
+CATEGORIES= www
+MASTER_SITES= http://www.unixpapa.com/software/
+DIST_SUBDIR= apache
+
+MAINTAINER= sheeepkiller@cultdeadsheep.org
+COMMENT= Allows users authentication based on external mechanisms
+
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+LATEST_LINK= mod_auth_external2
+
+APXS?= ${LOCALBASE}/sbin/apxs
+
+DOC_FILES= AUTHENTICATORS INSTALL README
+do-build:
+ @(cd ${WRKSRC}/ && ${APXS} -I. -c ${PORTNAME}.c)
+
+do-install:
+ @(cd ${WRKSRC}/ && ${APXS} -A -i ${PORTNAME}.la)
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+. for f in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/mod_auth_external2/distinfo b/www/mod_auth_external2/distinfo
new file mode 100644
index 00000000000..db712b500b3
--- /dev/null
+++ b/www/mod_auth_external2/distinfo
@@ -0,0 +1 @@
+MD5 (apache/mod_auth_external-2.2.6.tar.gz) = e06e9593816f81597f06f88555ff4658
diff --git a/www/mod_auth_external2/pkg-descr b/www/mod_auth_external2/pkg-descr
new file mode 100644
index 00000000000..85407668527
--- /dev/null
+++ b/www/mod_auth_external2/pkg-descr
@@ -0,0 +1,9 @@
+Mod_Auth_External is an Apache module used for authentication. The Apache HTTP
+Daemon can be configured to require users to supply logins and passwords
+before accessing pages in some directories. Authentication is the process of
+checking if the password given is correct for a user. Apache has standard
+modules for authenticating out of several different kinds of databases.
+Mod_Auth_External is a flexible tool for creating authentication systems based
+on other databases.
+
+WWW: http://www.unixpapa.com/mod_auth_external.html
diff --git a/www/mod_auth_external2/pkg-plist b/www/mod_auth_external2/pkg-plist
new file mode 100644
index 00000000000..8a91733f068
--- /dev/null
+++ b/www/mod_auth_external2/pkg-plist
@@ -0,0 +1,7 @@
+libexec/apache2/mod_auth_external.so
+%%PORTDOCS%%%%DOCSDIR%%/AUTHENTICATORS
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@exec %D/sbin/apxs -e -a -n auth_external %D/%f
+@unexec echo "===> If you do not plan on reinstalling mod_auth_external, you must manually remove"; echo "===> references to it in httpd.conf."