aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_auth_pgsql
diff options
context:
space:
mode:
authorlawrance <lawrance@FreeBSD.org>2005-08-07 12:46:58 +0800
committerlawrance <lawrance@FreeBSD.org>2005-08-07 12:46:58 +0800
commit124862cb9a4a11b55c7066b666fc628f32c88800 (patch)
treea19e9682744ca3b98c1627d95313c45022b29615 /www/mod_auth_pgsql
parentc266ed4cd78d4cb6a159985978afc414dd557936 (diff)
downloadfreebsd-ports-graphics-124862cb9a4a11b55c7066b666fc628f32c88800.tar.gz
freebsd-ports-graphics-124862cb9a4a11b55c7066b666fc628f32c88800.tar.zst
freebsd-ports-graphics-124862cb9a4a11b55c7066b666fc628f32c88800.zip
Unbreak and fix plist.
Use DOCSDIR. Use default DOCSDIR location. Approved by: portmgr (linimon)
Diffstat (limited to 'www/mod_auth_pgsql')
-rw-r--r--www/mod_auth_pgsql/Makefile19
-rw-r--r--www/mod_auth_pgsql/pkg-plist8
2 files changed, 8 insertions, 19 deletions
diff --git a/www/mod_auth_pgsql/Makefile b/www/mod_auth_pgsql/Makefile
index cfad072dea2..fbe5e8d91e0 100644
--- a/www/mod_auth_pgsql/Makefile
+++ b/www/mod_auth_pgsql/Makefile
@@ -16,10 +16,6 @@ COMMENT= Allows users to use PostgreSQL databases for user authentication
BUILD_DEPENDS= ${APXS}:${PORTSDIR}/${APACHE_PORT}
RUN_DEPENDS= ${LOCALBASE}/sbin/${AP_TARGET}:${PORTSDIR}/${APACHE_PORT}
-BROKEN= Incomplete pkg-plist
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2005-09-22
-
USE_PGSQL= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/a//}
@@ -42,26 +38,21 @@ AP_INCLUDE?= ${PREFIX}/include/apache
AP_LIBEXEC?= ${PREFIX}/libexec/apache
.endif
-AUTH_PGSQL_DOCS= apache/manual/mod/mod_auth_pgsql
-
-PLIST_SUB+= AUTH_PGSQL_DOCS="${AUTH_PGSQL_DOCS}"
-
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --with-pgsql=${PREFIX} \
--with-apxs=${APXS}
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/${AUTH_PGSQL_DOCS}
+ @${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README \
- ${PREFIX}/share/doc/${AUTH_PGSQL_DOCS}/
+ ${DOCSDIR}
${TR} -d \\015 < ${WRKSRC}/mod_auth_pgsql.html \
- > ${PREFIX}/share/doc/${AUTH_PGSQL_DOCS}/index.html
+ > ${DOCSDIR}/index.html
${CHMOD} ${SHAREMODE} \
- ${PREFIX}/share/doc/${AUTH_PGSQL_DOCS}/index.html
+ ${DOCSDIR}/index.html
${CHOWN} ${SHAREOWN}:${SHAREGRP} \
- ${PREFIX}/share/doc/${AUTH_PGSQL_DOCS}/index.html
- ${LN} -sf ${AUTH_PGSQL_DOCS} ${PREFIX}/share/doc/
+ ${DOCSDIR}/index.html
.endif
${CAT} ${PKGMESSAGE}
diff --git a/www/mod_auth_pgsql/pkg-plist b/www/mod_auth_pgsql/pkg-plist
index cebde958049..da8c9599e81 100644
--- a/www/mod_auth_pgsql/pkg-plist
+++ b/www/mod_auth_pgsql/pkg-plist
@@ -1,8 +1,6 @@
libexec/apache/mod_auth_pgsql.so
@exec %D/sbin/apxs -e -a -n auth_pgsql %f
@unexec %D/sbin/apxs -e -A -n auth_pgsql %f
-%%PORTDOCS%%share/doc/%%AUTH_PGSQL_DOCS%%/README
-%%PORTDOCS%%share/doc/%%AUTH_PGSQL_DOCS%%/index.html
-%%PORTDOCS%%@exec (cd %D/share/doc && ln -sf %%AUTH_PGSQL_DOCS%% mod_auth_pgsql)
-%%PORTDOCS%%@unexec rm -f %D/share/doc/mod_auth_pgsql
-%%PORTDOCS%%@dirrm share/doc/%%AUTH_PGSQL_DOCS%%
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%