aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_dav/Makefile
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-10-13 16:37:32 +0800
committerclement <clement@FreeBSD.org>2004-10-13 16:37:32 +0800
commit7c67c635767fdd7bd97f1cb0bb6be8716be21803 (patch)
treef2c4227fe8cf2564fdfe5c688b9cd9ee82e7ec1b /www/mod_dav/Makefile
parentc735c25f941fb45cbf6c496eb02b91dbf2430add (diff)
downloadfreebsd-ports-graphics-7c67c635767fdd7bd97f1cb0bb6be8716be21803.tar.gz
freebsd-ports-graphics-7c67c635767fdd7bd97f1cb0bb6be8716be21803.tar.zst
freebsd-ports-graphics-7c67c635767fdd7bd97f1cb0bb6be8716be21803.zip
- Add WITHOUT_APACHE_EXPAT knob.
It ensures to link with expat when apache isn't built with its own expat Noticed by: Nik Clayton <nik _at_ crf-consulting _dot_ co _dot_ uk> PR: ports/71988
Diffstat (limited to 'www/mod_dav/Makefile')
-rw-r--r--www/mod_dav/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/www/mod_dav/Makefile b/www/mod_dav/Makefile
index 6ce1a8382a9..343c3ab2184 100644
--- a/www/mod_dav/Makefile
+++ b/www/mod_dav/Makefile
@@ -35,6 +35,11 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
--includedir=${PREFIX}/include/apache \
--with-apxs=${APXS}
+.if defined(WITHOUT_APACHE_EXPAT)
+CONFIGURE_ARGS+= --with-expat=${LOCALBASE}
+LIB_DEPENDS+= expat.5:${PORTSDIR}/textproc/expat2
+.endif
+
CONFIGURE_ENV= CFLAGS='${CFLAGS}' \
PATH="${PREFIX}/bin:${PREFIX}/sbin:${PATH}"