aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_pcgi2
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-11-07 17:12:58 +0800
committermarcus <marcus@FreeBSD.org>2003-11-07 17:12:58 +0800
commit264cdcd7a6bead083ad3106f86fb0744dedb57f5 (patch)
tree1a018b24ee2f215bd6917d868f44c8f904dda8bf /www/mod_pcgi2
parent8ea77b67d66da4a3b085568e881b2aab1f559c32 (diff)
downloadfreebsd-ports-graphics-264cdcd7a6bead083ad3106f86fb0744dedb57f5.tar.gz
freebsd-ports-graphics-264cdcd7a6bead083ad3106f86fb0744dedb57f5.tar.zst
freebsd-ports-graphics-264cdcd7a6bead083ad3106f86fb0744dedb57f5.zip
Use the new Apache bits from bsd.port.mk.
Submitted by: dinoex
Diffstat (limited to 'www/mod_pcgi2')
-rw-r--r--www/mod_pcgi2/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/www/mod_pcgi2/Makefile b/www/mod_pcgi2/Makefile
index 6fc295427da..c80d72f163c 100644
--- a/www/mod_pcgi2/Makefile
+++ b/www/mod_pcgi2/Makefile
@@ -17,18 +17,17 @@ COMMENT= Persistent CGI module for Apache and Zope
RUN_DEPENDS= ${LOCALBASE}/${SZOPEBASEDIR}/z2.py:${PORTSDIR}/www/zope
.if defined(WITH_APACHE13)
-BUILD_DEPENDS= ${LOCALBASE}/include/apache/httpd.h:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${LOCALBASE}/include/apache/httpd.h:${PORTSDIR}/www/apache13
+BUILD_DEPENDS= ${LOCALBASE}/include/apache/httpd.h:${PORTSDIR}/${APACHE_PORT}
+RUN_DEPENDS= ${LOCALBASE}/include/apache/httpd.h:${PORTSDIR}/${APACHE_PORT}
.else
-BUILD_DEPENDS= ${LOCALBASE}/include/apache2/httpd.h:${PORTSDIR}/www/apache2
-RUN_DEPENDS= ${LOCALBASE}/include/apache2/httpd.h:${PORTSDIR}/www/apache2
+BUILD_DEPENDS= ${LOCALBASE}/include/apache2/httpd.h:${PORTSDIR}/${APACHE_PORT}
+RUN_DEPENDS= ${LOCALBASE}/include/apache2/httpd.h:${PORTSDIR}/${APACHE_PORT}
.endif
USE_PYTHON= yes
# You can change this in the environment if you like.
SZOPEBASEDIR?= www/Zope
-APXS?= ${LOCALBASE}/sbin/apxs
# Don't change these
ZOPEBASEDIR= ${LOCALBASE}/${SZOPEBASEDIR}
@@ -43,6 +42,7 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
.if defined(WITH_APACHE13)
APACHEVER= apache
.else
+WITH_APACHE2= yes
APACHEVER= apache2
BUILDOPT+= -DAPACHE2 -Wc,-shared
.endif