aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_php3
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>1999-08-30 18:56:07 +0800
committerdirk <dirk@FreeBSD.org>1999-08-30 18:56:07 +0800
commitef36127bae599c3c689edd3f3e97beb5d36177ed (patch)
tree13861852fc88f28bceac75dfed0f38a341c7afd1 /www/mod_php3
parent8cccc9b9c5290475befe8e37bd054974417b3417 (diff)
downloadfreebsd-ports-graphics-ef36127bae599c3c689edd3f3e97beb5d36177ed.tar.gz
freebsd-ports-graphics-ef36127bae599c3c689edd3f3e97beb5d36177ed.tar.zst
freebsd-ports-graphics-ef36127bae599c3c689edd3f3e97beb5d36177ed.zip
Make sure directory ${WRKDIRPREFIX}${CURDIR} exists before
touching files in that directory. Problem only occurs when ${WRKDIRPREFIX} is set. Found by: bento.freebsd.org
Diffstat (limited to 'www/mod_php3')
-rw-r--r--www/mod_php3/Makefile5
-rw-r--r--www/mod_php3/scripts/configure.php3
2 files changed, 5 insertions, 3 deletions
diff --git a/www/mod_php3/Makefile b/www/mod_php3/Makefile
index 40a7801757f..15eb8758ff6 100644
--- a/www/mod_php3/Makefile
+++ b/www/mod_php3/Makefile
@@ -3,7 +3,7 @@
# Date created: So 21 Jun 1998 16:09:39 CEST
# Whom: Stefan Herrmann <stefan@asterix.webaffairs.net>
#
-# $Id: Makefile,v 1.89 1999/08/26 09:24:16 dirk Exp $
+# $Id: Makefile,v 1.90 1999/08/26 21:18:12 dirk Exp $
#
DISTNAME= apache_${VERSION_APACHE}
@@ -88,7 +88,8 @@ CFLAGS+= -O6 -funroll-loops -fstrength-reduce -fomit-frame-pointer \
CONFIGURE_ENV= OPTIM='${OPTIM}' LIBS='-L${PREFIX}/lib'
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
- TOUCH="${TOUCH}"
+ TOUCH="${TOUCH}" \
+ MKDIR="${MKDIR}"
INSTALL_TARGET= install-quiet
diff --git a/www/mod_php3/scripts/configure.php b/www/mod_php3/scripts/configure.php
index 36271240174..7464fe2a3de 100644
--- a/www/mod_php3/scripts/configure.php
+++ b/www/mod_php3/scripts/configure.php
@@ -1,6 +1,7 @@
#!/bin/sh
if [ "${BATCH}" ]; then
+ ${MKDIR} ${WRKDIRPREFIX}${CURDIR}
${TOUCH} ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
exit
fi
@@ -46,7 +47,7 @@ case $retval in
;;
esac
-mkdir -p ${WRKDIRPREFIX}${CURDIR}
+${MKDIR} -p ${WRKDIRPREFIX}${CURDIR}
exec > ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
while [ "$1" ]; do