aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_php5
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>1999-06-30 17:56:39 +0800
committerdirk <dirk@FreeBSD.org>1999-06-30 17:56:39 +0800
commit41a7f44c68cfdc8c27b7fae6c40a77350d0d9822 (patch)
tree683f8f3d12870434cbaf9d5ecb3e961f83e3c621 /www/mod_php5
parenta10c91db3318fb58a452afcc4f30b6d585d1101e (diff)
downloadfreebsd-ports-graphics-41a7f44c68cfdc8c27b7fae6c40a77350d0d9822.tar.gz
freebsd-ports-graphics-41a7f44c68cfdc8c27b7fae6c40a77350d0d9822.tar.zst
freebsd-ports-graphics-41a7f44c68cfdc8c27b7fae6c40a77350d0d9822.zip
Clean up the latest mhash and mcrypt additions by nsayer:
- increase the number of menu items - use LIB_DEPENDS instead BUILD_DEPENDS (shared libs are used) - add ${PREFIX} to --with-mcrypt and --with-mhash
Diffstat (limited to 'www/mod_php5')
-rw-r--r--www/mod_php5/scripts/configure.php10
1 files changed, 5 insertions, 5 deletions
diff --git a/www/mod_php5/scripts/configure.php b/www/mod_php5/scripts/configure.php
index 958470a1fe3..858fcc560a8 100644
--- a/www/mod_php5/scripts/configure.php
+++ b/www/mod_php5/scripts/configure.php
@@ -6,7 +6,7 @@ fi
/usr/bin/dialog --title "configuration options" --clear \
--checklist "\n\
-Please select desired options:" -1 -1 12 \
+Please select desired options:" -1 -1 14 \
tuning "Apache: performance tuning" OFF \
modssl "Apache: SSL support" OFF \
GD "PHP3: GD library support" ON \
@@ -63,12 +63,12 @@ while [ "$1" ]; do
echo "PHP3_CONF_ARGS+= --with-zlib" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
;;
\"mcrypt\")
- echo "BUILD_DEPENDS+= \${PREFIX}/lib/libmcrypt.a:\${PORTSDIR}/security/mcrypt" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
- echo "PHP3_CONF_ARGS+= --with-mcrypt" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ echo "LIB_DEPENDS+= mcrypt.2:\${PORTSDIR}/security/libmcrypt" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ echo "PHP3_CONF_ARGS+= --with-mcrypt=\${PREFIX}" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
;;
\"mhash\")
- echo "BUILD_DEPENDS+= \${PREFIX}/lib/libmhash.a:\${PORTSDIR}/security/mhash" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
- echo "PHP3_CONF_ARGS+= --with-mhash" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ echo "LIB_DEPENDS+= mhash.1:\${PORTSDIR}/security/mhash" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ echo "PHP3_CONF_ARGS+= --with-mhash=\${PREFIX}" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
;;
\"pdflib\")
echo "BUILD_DEPENDS+= \${PREFIX}/lib/libpdf.a:\${PORTSDIR}/print/pdflib" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc